summaryrefslogtreecommitdiff
path: root/sci-mathematics/easycrypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-30 17:40:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-30 17:40:25 +0100
commit3c78a1ce7924fbf571e133e697f8a29e18d2bf4b (patch)
tree5bbedb5d3c2716d5b332f7e74f54941c9a2b50b8 /sci-mathematics/easycrypt
parentc417025a2ab386cddabb71ad598a9b75b47af313 (diff)
gentoo auto-resync : 30:09:2023 - 17:40:25
Diffstat (limited to 'sci-mathematics/easycrypt')
-rw-r--r--sci-mathematics/easycrypt/Manifest2
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2023.09.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
index f9c321bc261a..2593beed4fc5 100644
--- a/sci-mathematics/easycrypt/Manifest
+++ b/sci-mathematics/easycrypt/Manifest
@@ -1,3 +1,5 @@
DIST easycrypt-2022.04_p20230324.tar.gz 1296898 BLAKE2B 119cb10ad5c2cd50db9f70eb858e2779cae0350b9e5370060b8045f36684a9de87ad746e75c6a7e7fcc7ad93e40bde2164866bb16e67dd2ebc3409657760cbd8 SHA512 917d5ff2fe65a1fd02a19d700cfb77910290746023458b6ed9eb9dc1290faa5469571a3c77510caac8734ad7d2ada6c7fbfc75bb933d0a57e9c303a8cf207026
+DIST easycrypt-2023.09.tar.gz 1317177 BLAKE2B 98e1c13b530f1cac6f3e166a01627cfb9cd0f1660f51187dac66397caad9cd71fe6b8923ac9757015a50ee479d3427d4906dcdf3bd36012559087657904489b8 SHA512 06fbd3993db951b620c946679566910c8f32035da6d0e8991c794edbc95a31acf3c60c5d3e909a60535ba0252dadf86ccfba2d1998a3929c4653e159d9a4dfac
EBUILD easycrypt-2022.04_p20230324.ebuild 1197 BLAKE2B a3f363f547cea997bf3e49953df448d00cf72cbc828a2ab495e636d9903fce7bb72c7b047cb0001859faac6d30d369fd6a38905a537a057b26075b1e490fe546 SHA512 48b15f4bd30f8c47d39009a76e0094f480822d9f50d5015e87b94a9c2b661a59df6f8512352886cfb26730f7797cfd81cda8150590a2cc56528203c41105b644
+EBUILD easycrypt-2023.09.ebuild 1006 BLAKE2B 115202937c5ee8094e83427e9cf4d9ca7f82f911cc119974abeff5c2d19b70cca1c0fe3a5c271b65e76c764a154685c923e3a1e62ad4c282753c92ede5a94375 SHA512 09994233f3eff6f1ff3d5c0a958d030ca737d1a6b9c795ad701ef898288c9f9846be11c42af6fe3fd6edb9809132fc8b3d543fd2371d36f03c59b02bfefe6ff8
MISC metadata.xml 799 BLAKE2B 967a758171a2fe87b648a29bf2663beaae7834119e55a7619c98518c96cfe459e59fe5dc72a9faea071c0b488dc8144f1c0e43677ac63646f1ba12cf831f4a88 SHA512 411ff1acad400c3e70e546fd59b20db13b0f1db121aca9f1af23da708cd82340114bc966f64cfb5a35e84967c1131c660ab260f867639932c67edf47c859c4ca
diff --git a/sci-mathematics/easycrypt/easycrypt-2023.09.ebuild b/sci-mathematics/easycrypt/easycrypt-2023.09.ebuild
new file mode 100644
index 000000000000..938be55dac7e
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2023.09.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/r${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-r${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=sci-mathematics/why3-1.6:= <sci-mathematics/why3-1.7:=
+
+ dev-ml/batteries:=
+ dev-ml/camlp-streams:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}