summaryrefslogtreecommitdiff
path: root/sci-mathematics/cvc4/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /sci-mathematics/cvc4/files
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'sci-mathematics/cvc4/files')
-rw-r--r--sci-mathematics/cvc4/files/cvc4-1.8-gentoo.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/cvc4/files/cvc4-1.8-gentoo.patch b/sci-mathematics/cvc4/files/cvc4-1.8-gentoo.patch
new file mode 100644
index 000000000000..372bea03fb72
--- /dev/null
+++ b/sci-mathematics/cvc4/files/cvc4-1.8-gentoo.patch
@@ -0,0 +1,42 @@
+--- a/CMakeLists.txt 2019-07-09 14:47:12.552425226 +0200
++++ b/CMakeLists.txt 2019-07-09 14:50:02.595001358 +0200
+@@ -143,7 +143,7 @@
+
+ # Note: Module CodeCoverage requires the name of the debug build to conform
+ # to cmake standards (first letter uppercase).
+-set(BUILD_TYPES Production Debug Testing Competition)
++set(BUILD_TYPES Production Debug Testing Competition Gentoo)
+
+ if(ENABLE_ASAN)
+ #_cmake_modify_IGNORE set(CMAKE_BUILD_TYPE Debug)
+@@ -166,12 +166,10 @@
+ endif()
+
+ message(STATUS "Building ${CMAKE_BUILD_TYPE} build")
+-include(Config${CMAKE_BUILD_TYPE})
+
+ #-----------------------------------------------------------------------------#
+ # Compiler flags
+
+-add_check_c_cxx_flag("-O${OPTIMIZATION_LEVEL}")
+ add_check_c_cxx_flag("-Wall")
+ add_check_c_flag("-fexceptions")
+ add_check_c_cxx_flag("-Wno-deprecated")
+--- a/test/regress/CMakeLists.txt 2019-07-14 09:49:38.429990489 +0200
++++ b/test/regress/CMakeLists.txt 2019-07-14 09:50:28.854234838 +0200
+@@ -2155,7 +2155,6 @@
+ regress4/C880mul.miter.shuffled-as.sat03-348.smtv1.smt2
+ regress4/NEQ016_size5.smtv1.smt2
+ regress4/bug143.smtv1.smt2
+- regress4/comb2.shuffled-as.sat03-420.smtv1.smt2
+ regress4/hole10.cvc
+ regress4/instance_1151.smtv1.smt2
+ )
+--- a/src/CMakeLists.txt 2019-07-18 08:56:47.923025745 +0200
++++ b/src/CMakeLists.txt 2019-07-18 08:58:10.584750385 +0200
+@@ -915,4 +915,4 @@
+ # Note: This is a temporary fix until the new C++ API is in place.
+ install(CODE "execute_process(COMMAND
+ ${CMAKE_CURRENT_LIST_DIR}/fix-install-headers.sh
+- ${CMAKE_INSTALL_PREFIX})")
++ \$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX})")