summaryrefslogtreecommitdiff
path: root/sci-mathematics/cvc4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /sci-mathematics/cvc4
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'sci-mathematics/cvc4')
-rw-r--r--sci-mathematics/cvc4/Manifest3
-rw-r--r--sci-mathematics/cvc4/cvc4-1.8.ebuild55
-rw-r--r--sci-mathematics/cvc4/files/cvc4-1.8-gentoo.patch42
3 files changed, 100 insertions, 0 deletions
diff --git a/sci-mathematics/cvc4/Manifest b/sci-mathematics/cvc4/Manifest
index 49486bb48265..2ee260903c55 100644
--- a/sci-mathematics/cvc4/Manifest
+++ b/sci-mathematics/cvc4/Manifest
@@ -1,4 +1,7 @@
AUX cvc4-1.7-gentoo.patch 1665 BLAKE2B db98e67fb3b152e0c78019b21b32c99d06377f1b1c1cc6a3ac2edea5e27d6f8ba082fc209c3694e1144a94d9d3b1897418af250252ff40a26e521bbf72d7da0f SHA512 b6b7af8c48c0398375343c8fa72f3e15d8f9031848cf94e6e2880f04b5e8d695691dcf67b84daa1706464289f7db0300046af4c93adcf278f7951eccc734af89
+AUX cvc4-1.8-gentoo.patch 1655 BLAKE2B 019d1cd6cc1b95042f4a04470c659a0e6b14e6e4d45eee16187feed1ee7664564e29a230b6d859ad70a3f2e442a44cb1ae296617e29cd894106a10e290490ee3 SHA512 1cf38e1d817f9347308dd982c6ff1f6344d654fda69fc6a2313cf6c9fbeb331cc168e002a1f9731c5481ed063aa5feb360014d60fd0e1cc55a6aeeea44ac13c0
DIST cvc4-1.7.tar.gz 6969953 BLAKE2B 3a64db14a734e0314fb7d7b8dbed79e067c9bbf1723343dac1e9c47b3f09811b1a32ff0116412667bd0afefda2489c6c1679bf109710402a67bee0d91b62dd94 SHA512 b91dfac7ddf979a3474f562eb98f2d6f17a53efa38c1be5502429309a0c059e1f2b0d85ee95e5aee17d35f34c825f01f879ec4aaf26025b1fcac835c33a867c6
+DIST cvc4-1.8.tar.gz 7554297 BLAKE2B f4d2b223ba2c01ef745520d8874381a1873358fbc7eca12559656512ffeefccec4eca3d73a26debf34110ca14a3bccf35ca87e2a49575b8b67484bed79df081c SHA512 d6b0153b0f5c4e615c995a8eecfbfd783cfc1004c5134c6880230044081c71d638fee39cceb987eb8d72e91b2b6596b184dc0daacec8880cfc176c6dee8aa445
EBUILD cvc4-1.7-r1.ebuild 1379 BLAKE2B c806041f0941649a8108f6148ad2226647721a9396e5d8d889649e3185ba229aaa405ab1a22409aa4d1b7a21142213646df734e24bcec26b5899bbd114d92aff SHA512 d4ad9b8b61f48feb744d3ea5f6964112e63e9beba1f156b997bcde57a2aed295a54e3e93444d9570d997979a81b3fd74cae5f4fd335df201b504ba2ab9b67469
+EBUILD cvc4-1.8.ebuild 1294 BLAKE2B b582be8424ee773310d4decdf2a03f7144037a80e117584dd9961b4a4548119cd553ddc30ea7ab5beaae3e6ec37b062993931a2d7c48c15b230c9b9efd0fda97 SHA512 0192be6902b0482a229581f8a7fb33ffe884ef101021959cf4f2cc98acec1bb344a21f18f57d43150681b058c0a83c0c7252e5a238c51315c3617a3194cc8ddf
MISC metadata.xml 801 BLAKE2B a8dffba2bb9a740412d4193911d1ab118336993d12d6d7e42c758af438d297baf6798e2ce9c6aa9be4282678e366087d54b8d3f8c46b43be6d73bcf421ee318a SHA512 d90e35c93e5defc5599f5e9d9b88a757a4a845574684270f1aab0cb8194c50b31fa3135ea221f63d0d71f867619c039f32cfb46b63fa370289e8eb5205d3b25d
diff --git a/sci-mathematics/cvc4/cvc4-1.8.ebuild b/sci-mathematics/cvc4/cvc4-1.8.ebuild
new file mode 100644
index 000000000000..347dbda0a248
--- /dev/null
+++ b/sci-mathematics/cvc4/cvc4-1.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR=emake
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit cmake python-any-r1
+
+DESCRIPTION="Automatic theorem prover for satisfiability modulo theories (SMT) problems"
+HOMEPAGE="https://cvc4.github.io/"
+SRC_URI="https://github.com/CVC4/CVC4-archived/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cln proofs readline replay +statistics"
+
+RDEPEND="dev-libs/antlr-c
+ dev-java/antlr:3
+ dev-libs/boost
+ readline? ( sys-libs/readline:0= )
+ cln? ( sci-libs/cln )
+ !cln? ( dev-libs/gmp:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}"/${PN^^}-archived-${PV}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DANTLR_BINARY=/usr/bin/antlr3
+ -DENABLE_GPL=ON
+ -DENABLE_OPTIMIZED=ON
+ -DUSE_CLN="$(usex cln ON OFF)"
+ -DUSE_READLINE="$(usex readline ON OFF)"
+ -DENABLE_STATISTICS="$(usex statistics ON OFF)"
+ -DENABLE_PROOFS="$(usex proofs ON OFF)"
+ -DENABLE_REPLAY="$(usex replay ON OFF)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" \
+ systemtests
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+ mv "${D}"/usr/{lib,$(get_libdir)}
+}
diff --git a/sci-mathematics/cvc4/files/cvc4-1.8-gentoo.patch b/sci-mathematics/cvc4/files/cvc4-1.8-gentoo.patch
new file mode 100644
index 000000000000..372bea03fb72
--- /dev/null
+++ b/sci-mathematics/cvc4/files/cvc4-1.8-gentoo.patch
@@ -0,0 +1,42 @@
+--- a/CMakeLists.txt 2019-07-09 14:47:12.552425226 +0200
++++ b/CMakeLists.txt 2019-07-09 14:50:02.595001358 +0200
+@@ -143,7 +143,7 @@
+
+ # Note: Module CodeCoverage requires the name of the debug build to conform
+ # to cmake standards (first letter uppercase).
+-set(BUILD_TYPES Production Debug Testing Competition)
++set(BUILD_TYPES Production Debug Testing Competition Gentoo)
+
+ if(ENABLE_ASAN)
+ #_cmake_modify_IGNORE set(CMAKE_BUILD_TYPE Debug)
+@@ -166,12 +166,10 @@
+ endif()
+
+ message(STATUS "Building ${CMAKE_BUILD_TYPE} build")
+-include(Config${CMAKE_BUILD_TYPE})
+
+ #-----------------------------------------------------------------------------#
+ # Compiler flags
+
+-add_check_c_cxx_flag("-O${OPTIMIZATION_LEVEL}")
+ add_check_c_cxx_flag("-Wall")
+ add_check_c_flag("-fexceptions")
+ add_check_c_cxx_flag("-Wno-deprecated")
+--- a/test/regress/CMakeLists.txt 2019-07-14 09:49:38.429990489 +0200
++++ b/test/regress/CMakeLists.txt 2019-07-14 09:50:28.854234838 +0200
+@@ -2155,7 +2155,6 @@
+ regress4/C880mul.miter.shuffled-as.sat03-348.smtv1.smt2
+ regress4/NEQ016_size5.smtv1.smt2
+ regress4/bug143.smtv1.smt2
+- regress4/comb2.shuffled-as.sat03-420.smtv1.smt2
+ regress4/hole10.cvc
+ regress4/instance_1151.smtv1.smt2
+ )
+--- a/src/CMakeLists.txt 2019-07-18 08:56:47.923025745 +0200
++++ b/src/CMakeLists.txt 2019-07-18 08:58:10.584750385 +0200
+@@ -915,4 +915,4 @@
+ # Note: This is a temporary fix until the new C++ API is in place.
+ install(CODE "execute_process(COMMAND
+ ${CMAKE_CURRENT_LIST_DIR}/fix-install-headers.sh
+- ${CMAKE_INSTALL_PREFIX})")
++ \$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX})")