summaryrefslogtreecommitdiff
path: root/sci-mathematics/cryptominisat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-mathematics/cryptominisat/files
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-mathematics/cryptominisat/files')
-rw-r--r--sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch b/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch
new file mode 100644
index 000000000000..5280f27bbd8f
--- /dev/null
+++ b/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch
@@ -0,0 +1,23 @@
+index b3ab64af4..293eb1f80 100644
+--- a/python/setup.py.in
++++ b/python/setup.py.in
+@@ -27,7 +27,7 @@ import sys
+ import os
+ import platform
+ from distutils.core import setup, Extension
+-from distutils import sysconfig
++import sysconfig
+ from distutils.cmd import Command
+
+ __PACKAGE_VERSION__ = "0.2.0"
+@@ -59,8 +59,8 @@ def _init_posix(init):
+ Forces g++ instead of gcc on most systems
+ credits to eric jones (eric@enthought.com) (found at Google Groups)
+ """
+- def wrapper():
+- init()
++ def wrapper(vars):
++ init(vars)
+
+ config_vars = sysconfig.get_config_vars() # by reference
+ if config_vars["MACHDEP"].startswith("sun"):