summaryrefslogtreecommitdiff
path: root/sci-mathematics/cryptominisat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-mathematics/cryptominisat
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/Manifest3
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild4
-rw-r--r--sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch23
3 files changed, 28 insertions, 2 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
index 2fe9f833da46..e9326ae1fa29 100644
--- a/sci-mathematics/cryptominisat/Manifest
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -1,3 +1,4 @@
+AUX cryptominisat-5.8.0-setup.py.in-sysconfig.patch 678 BLAKE2B b42dd9ebed8076e8c46ddf92107bdd776d078c0869a824b87c27876c49818ca96b1455912c3af3957c507b59fadb5ecbdedbd94404a87f4672295553d40ce612 SHA512 9836faddf2d502af08a15a08611dfcd1e476d4155fe6a6a9a68b4d6ff851fa7dd485e0c08ba23920cda43f8fc72e5ec9f05fce816b7b0ead65144daa38490601
DIST cryptominisat-5.8.0.tar.gz 943785 BLAKE2B 534af88a8432c7e3da63989cad8fd5e1491bd69a80b44977fa681e0356e857a505a82dc860b0d04d07987e3edae2861da67ec9dd781261e03a1120dc342b9759 SHA512 3eb954f01524b189a8de57a05f6060471a083addc4b9077c1e32b769d26393ce3d33468819ba8169deedce43fc3663b0ad8bbad95c6afe5e562e438c57b75496
-EBUILD cryptominisat-5.8.0.ebuild 920 BLAKE2B b22d56c5e175d44acb483b1b684cd0236b7f517337c627fde15aa92ee7cb6e69942751e6e8ff6fe66cd40be83eb1144502b0e9d7b094910dafae3faaf182196b SHA512 209995f8551665b615c3a23b50d59fc2ff41f7b57ffbe5570521a67a06f38ef8a9a9cda4faf3465b05c8b05f4da31337c95c12eeb40fdce1e27e7a6e18f9a6b8
+EBUILD cryptominisat-5.8.0.ebuild 980 BLAKE2B a4e47be2b7f6f9ba2fe6669afbdeeee25ac69586ce1fba042f6f940a0befeaded258f9c855e9d6c6d0dbe10cd996f712174e4fa5cae27d936fb6c0231e5859d9 SHA512 b0e65d01e24fdc3fb938185540594e1bf1dedafebf0f889a4368997d8e5c8b3d0afab8f8e19b93ba81d4af275bf0576d4149b60a3a426fe4a9574f836bc11948
MISC metadata.xml 858 BLAKE2B 4543d51cedd7b5e5e8508c14dfae420360f9d76ada1b969d855ca2b17b2c967036b29a9f2769a2c78e736c1e449e2b079558cd7460a72d402e9f1ce029ba414a SHA512 e1b39d888ab6c09f8707a164c7f683831a908477b2c7f219f4c9f71161ba84c145836ca2b1665e200f15a6e2ff6ca6318bd16fc40d57ad9c64bd1a4e229fbabc
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
index d4517fca935e..8542bea79b7f 100644
--- a/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-setup.py.in-sysconfig.patch )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
diff --git a/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch b/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch
new file mode 100644
index 000000000000..5280f27bbd8f
--- /dev/null
+++ b/sci-mathematics/cryptominisat/files/cryptominisat-5.8.0-setup.py.in-sysconfig.patch
@@ -0,0 +1,23 @@
+index b3ab64af4..293eb1f80 100644
+--- a/python/setup.py.in
++++ b/python/setup.py.in
+@@ -27,7 +27,7 @@ import sys
+ import os
+ import platform
+ from distutils.core import setup, Extension
+-from distutils import sysconfig
++import sysconfig
+ from distutils.cmd import Command
+
+ __PACKAGE_VERSION__ = "0.2.0"
+@@ -59,8 +59,8 @@ def _init_posix(init):
+ Forces g++ instead of gcc on most systems
+ credits to eric jones (eric@enthought.com) (found at Google Groups)
+ """
+- def wrapper():
+- init()
++ def wrapper(vars):
++ init(vars)
+
+ config_vars = sysconfig.get_config_vars() # by reference
+ if config_vars["MACHDEP"].startswith("sun"):