summaryrefslogtreecommitdiff
path: root/sci-mathematics/cliquer/cliquer-1.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-mathematics/cliquer/cliquer-1.22.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-mathematics/cliquer/cliquer-1.22.ebuild')
-rw-r--r--sci-mathematics/cliquer/cliquer-1.22.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-mathematics/cliquer/cliquer-1.22.ebuild b/sci-mathematics/cliquer/cliquer-1.22.ebuild
new file mode 100644
index 000000000000..03f84005300a
--- /dev/null
+++ b/sci-mathematics/cliquer/cliquer-1.22.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C routines for finding cliques in an arbitrary weighted graph"
+
+# autocliquer is a fork of cliquer (whose last release was in 2010) by
+# one of the SageMath developers with an autotools build system.
+HOMEPAGE="https://users.aalto.fi/~pat/cliquer.html
+ https://github.com/dimpase/autocliquer"
+
+# The github tarball doesn't contain the generated autotools files (like
+# the ./configure script).
+SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}