summaryrefslogtreecommitdiff
path: root/sci-mathematics/cliquer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-mathematics/cliquer
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-mathematics/cliquer')
-rw-r--r--sci-mathematics/cliquer/Manifest2
-rw-r--r--sci-mathematics/cliquer/cliquer-1.22.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/cliquer/Manifest b/sci-mathematics/cliquer/Manifest
index f8e7e75ebcb1..ace708d58b27 100644
--- a/sci-mathematics/cliquer/Manifest
+++ b/sci-mathematics/cliquer/Manifest
@@ -1,3 +1,5 @@
DIST cliquer-1.21.tar.gz 412440 BLAKE2B 0a4f31f6b005822271c67ab2f2532809b112a5ceb7aaf828b06bf6ca4cadfb836d3c1f6b70187908104c2eefedeececad6b020cde2d198141dc69801d5b1ce81 SHA512 2f72a649cfef46ef07cc3817a704fbfcda910b0b0a419deb361b2aa18437e4689a8b965e0e364a5d9ae391ba8591e022a0dc414b21c9102094ad28fb2f1b15a8
+DIST cliquer-1.22.tar.gz 416433 BLAKE2B 3f43d443b1ecfef599213da99ffa15b5077392dd8d1bebdd0f5db73898d1fe997d6eabe6dbdb29852d40355228f082cfa7e3198be90dc9166965b90f062cae69 SHA512 3285cb0a3987ff730d9f9b25419a98201f399daf28444179ba8902211ddda87adcc7189f5b94f062d0648039a1b6217b80c8db482887d7dc8552b20459eff861
EBUILD cliquer-1.21.ebuild 784 BLAKE2B 5d822c6f11114d9fd0254af5cd1552c0149d78b506eb75ca61f34506f7af24ef51ab593fdee61db0a8562170c638ba6b61bfdbb014d0708e99c64ebaa43390f5 SHA512 eaa0766c99060fdb7662eff8cab91a09b7a4a9f7a09c8ff8b609f184cd762a4feed18431fd817273feb2aa2704488d1c176b0b1314ac8d944531afaf333d9262
+EBUILD cliquer-1.22.ebuild 786 BLAKE2B b968cc114f0966bf3ccd8914fd5559c6c0074972a8b46bb26cdeecbddf33303c655fc9a640604484a0091a2d2ac478c0b75e10856cef71b02c8c8e232179f869 SHA512 81b896044c300c2f522905b794f8047fac638388799b97d358c29ce14ed9a3a4133fd8f4dcabbaf856a1cafc739879a37ab8dd1051e3a9f1d8e3ff0bb022f39a
MISC metadata.xml 739 BLAKE2B c6fa693dfa35996f2bb14d5a466538770264b47830afb59b09b8e0a5b99818e5532ffd6b893b6ed906922fd24ff9abf2511cc849ed01dd5d39d0830b5f289b22 SHA512 a9414bab8c1b6c8858c0de265fd864deb31fef36294a5ebcda07fdaf54eabb1dd0694286215ac48f7f1d36a2682bfdf9fb2d0bcc7fecc5126c815c7281bc731f
diff --git a/sci-mathematics/cliquer/cliquer-1.22.ebuild b/sci-mathematics/cliquer/cliquer-1.22.ebuild
new file mode 100644
index 000000000000..03f84005300a
--- /dev/null
+++ b/sci-mathematics/cliquer/cliquer-1.22.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C routines for finding cliques in an arbitrary weighted graph"
+
+# autocliquer is a fork of cliquer (whose last release was in 2010) by
+# one of the SageMath developers with an autotools build system.
+HOMEPAGE="https://users.aalto.fi/~pat/cliquer.html
+ https://github.com/dimpase/autocliquer"
+
+# The github tarball doesn't contain the generated autotools files (like
+# the ./configure script).
+SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}