summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-04 02:04:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-04 02:04:17 +0100
commit00d9a8fc3e9e5bafeff6747e978c1685b384e587 (patch)
tree43c6db3767706ffe339a7040cb0a5dea8bd1ef26 /sci-libs
parent799073eb168d35819904276f6c912be4ac76166a (diff)
gentoo auto-resync : 04:08:2022 - 02:04:17
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin44564 -> 44569 bytes
-rw-r--r--sci-libs/brial/Manifest2
-rw-r--r--sci-libs/brial/brial-1.2.11.ebuild36
-rw-r--r--sci-libs/cddlib/Manifest2
-rw-r--r--sci-libs/cddlib/cddlib-094m-r1.ebuild3
-rw-r--r--sci-libs/sundials/Manifest2
-rw-r--r--sci-libs/sundials/metadata.xml41
7 files changed, 64 insertions, 22 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 56050e9c591b..a7463af7a4f4 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
index 86374caf3722..b4b4727b25a2 100644
--- a/sci-libs/brial/Manifest
+++ b/sci-libs/brial/Manifest
@@ -1,3 +1,5 @@
DIST brial-1.2.10.tar.bz2 1229830 BLAKE2B a1cfe4fcd19824d04388bbab1130a9d07e5920fb05ea1686424f1e0193c6f5d29300bba66bdf7ac59665cbceed3f6ff84fbb5a95311858196a0fbdecda5a2cc7 SHA512 163d9f3703271f412d20ec165d713280d9b46c50b66eed0b15385c6d94569e0ea5d7e84c3b6715d51197e97be4062325551402c844f70235a4aa1cebc5e9d3a1
+DIST brial-1.2.11.tar.bz2 1260892 BLAKE2B 910f4ffd728235c8b18deb0d36c76778ce2c392644b7eaba06a9c00a832b4ccb0c2cd69f4d9ab9770e060b54491bd6b613e4e1324a32f57d7c32f200fb0a900d SHA512 00532b6361c709fce44940bfd22563046cfcbc06d41282a01a26f9bcb25fa86df1406685d7ba4b1ebbb08cd7fa8b9811c81eccf78e72ea96960ef7a059c2e926
EBUILD brial-1.2.10.ebuild 957 BLAKE2B b37370aef6a8cadcdb0d5ed34b5640bc53eac4a90c1757f3de168c05622ca580b211fd935b0da9237456d4b78365498b85e0a1497a0feb7b124558d73504f09b SHA512 c536b54927457c463cddec863ea3e96753ed11d7fc40e5010b0416810185b3d0b2acf69f4e56e0bcb43cfcc10ade93a11e74dc932eecc28c8132a0c8e982a84c
+EBUILD brial-1.2.11.ebuild 912 BLAKE2B a7c9114dedecfff4fd90db92c896fbd718939d5c7c7c4bac8d58be11fb593b5b650affd0c857f3e99a7900daecae1d03f4af2090a4db0c16f9e050f637a813e5 SHA512 a9e832ee8ebeeef4ec33f0a46fc8978b4a5c15d6040662e93961ebc14fb9578743320fdaf4e56b30f8ad3ca42b8fa245c35e303f1808336f0fb20856878b48fb
MISC metadata.xml 1077 BLAKE2B 516f3390d40d27d4d1934be2eea344e888112ae8912985134bc288fe4d9414f49100874ddf94f7b0d517e60b7a37801464a6f64108df0465a015e6e9f3c3702e SHA512 284c49e862464bf2d825598a9ef6aa6dbf40c6f42f02f1dcb53f7d3baf8c728771dec129a63fcadb711c40ff623e5c4036cfdc54afc4dbaf07c73b75329aefe0
diff --git a/sci-libs/brial/brial-1.2.11.ebuild b/sci-libs/brial/brial-1.2.11.ebuild
new file mode 100644
index 000000000000..aa41242e9a0b
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2+, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="png"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${ESYSROOT}"/usr \
+ --with-boost-libdir="${ESYSROOT}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/cddlib/Manifest b/sci-libs/cddlib/Manifest
index cbcc9ecc79b9..8db2721e69ba 100644
--- a/sci-libs/cddlib/Manifest
+++ b/sci-libs/cddlib/Manifest
@@ -1,3 +1,3 @@
DIST cddlib-0.94m.tar.gz 1351298 BLAKE2B 0e1931ba94771f0dcae0ee10b003940ca331839eb8ce001ab02c4f1b382dde74d7dfcf74f4c62e1ae7214a3139547c09f56ef0cba5df74fc03a63ab741b64690 SHA512 50997bda38c36990456345881dc1eac65b1880aa510ea3812ae46a122ba7696bf3577f2b6976ff16811ee00f0a920c8ed6f1e7de0a4060bfaa96def11bab816e
-EBUILD cddlib-094m-r1.ebuild 1414 BLAKE2B 45051b76609e6befc0eb22b7f99dfd6be34deed84f2b98a0710c377e380f624b6c0b1105feb29c900decff8cfe724444832ce62a8fd64076e50c530a1ffb994c SHA512 a24bc9dbebc2befd6fc51ef2cbe6643fc0d6191bfa3df5fd02c979c47c943ab31248275cdbdb6794bedc3c1a5d6173e16bea1ce169c8ac83098229022bf10970
+EBUILD cddlib-094m-r1.ebuild 1446 BLAKE2B e0dc047e66b1f226340682f67d8c863f7aef6883b0fd39ee642baaff7e2738385bf620694f082d95a7feaa9a80cf3fa46b1e8a6f5f65b11ffb9d11bb80eabb1e SHA512 767ce2030bc7f55387ab8495b40e99cb7a3043ce8c9f3f89d2d5cb34172bddd61e862cc4301374f59fd49737784b9b2a1bec35b6b183f889eb9eeab9bf34be08
MISC metadata.xml 1848 BLAKE2B 98d72e3809807ac701b575e31068012b568893cc4db0cb8b12c0a0ec6c83862e3e132981192026a279c1bf516fda829e20fb9e314ddd3fa0bcd5613f2e074f33 SHA512 d4b7eccde619f6be50621dba566a186b46c62537dfb26c3d34157ddad7179040ea9ddfaa7b63e363053c935d101581bdeb3a4350db955665d4d163b322e43367
diff --git a/sci-libs/cddlib/cddlib-094m-r1.ebuild b/sci-libs/cddlib/cddlib-094m-r1.ebuild
index bcfb95f450cd..6aa6754453b0 100644
--- a/sci-libs/cddlib/cddlib-094m-r1.ebuild
+++ b/sci-libs/cddlib/cddlib-094m-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,6 +6,7 @@ EAPI=7
# This can't work forever; but for now, it's better than hard-coding the
# correct version string.
MY_PV="${PV:0:1}.${PV:1}"
+QA_PKGCONFIG_VERSION="${MY_PV}"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="C library implementing the Double Description Method"
diff --git a/sci-libs/sundials/Manifest b/sci-libs/sundials/Manifest
index 3b2570e55266..f2337ea859ea 100644
--- a/sci-libs/sundials/Manifest
+++ b/sci-libs/sundials/Manifest
@@ -6,4 +6,4 @@ DIST sundials-6.2.0.tar.gz 82410068 BLAKE2B c6aa9735198465bb458590ef1a90101e2462
EBUILD sundials-5.2.0.ebuild 2173 BLAKE2B c7765f5fbb12395c2474f352a3200225cb2ec75360fa2089bf34ee0ddb313d136b0e66ad1955936bac2bf6f6e63bca055e7077d46fb92a69771417c51b86fb9a SHA512 00d5b62fabe026e5637cd655dc53ba12e4ff8db286b451e79a993b18ef09dcbce58805424c903bfb35ebbfcd2881873f91cfb63faa353f1789bd95fba7f17a17
EBUILD sundials-5.8.0.ebuild 2759 BLAKE2B 2f2872218e337cda6e067925f4f67ce4021a284d0d4badb31737efd6fc0917808769c24b74df4086aaef08384bd36dd744358b9d797da08c40d34f5b1aa34bdc SHA512 7cdaed08db6eab4713df5477d3051d009881cb1ef38714496618f56f831ab9e3973a0b37092cc716512c5d8dc6ed73cbb7da2fb46d0373b066290c48993cd805
EBUILD sundials-6.2.0.ebuild 2723 BLAKE2B 3d0bdf7847bb61ff87b78a3fdc806d3edcf9d72422d5c27dc05c69ffbf69a609777e25d9b2931bd11b70c911de76e84dcb06843f39aed05f5c76d56474abf78f SHA512 a3e17643240fbcb9383cccf5b90122f53f19d27213d978aa0315db52e1afa20d8c0afa57a52f6315a7050f8112e0f03d558d3b60448bc661cc4054a328ed6ff8
-MISC metadata.xml 1131 BLAKE2B f898dfbe0da057432c5c0549d850293224137cb07d234721894752821b638f3002a1d17a06c4258b94fbc2d0e4ce5e9ee2b06c1099c473989de36b62001f2d63 SHA512 f53a7aec4b5ebc0f7737938f811e4c87842a07b03c423715296ad2992e353f661022eb2bb344e33fb03d70af6e4ffdf1908a34bdbafc3ebe9d30fa7f4bd7cad1
+MISC metadata.xml 1170 BLAKE2B b2ddcc6f5a958ed045bea77fef0c8842f76fd9f3756bd82870bd605b7dcf5ae5be64c0b5a00a248d17518d0411c90f6b9da539aa5b35bf00d532f84867ed46cf SHA512 539f5e1c372b48f0f6d81a444b52c0ab2a80ecf3e7d278ed870d7189c330e8bfa3c296ddc4ea10e09029b7e44860cde62af6a4bda58d4bcd841704f5920ca23d
diff --git a/sci-libs/sundials/metadata.xml b/sci-libs/sundials/metadata.xml
index 7e8359df0301..3a9a3b121469 100644
--- a/sci-libs/sundials/metadata.xml
+++ b/sci-libs/sundials/metadata.xml
@@ -1,23 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Scientific Project</name>
- </maintainer>
- <longdescription lang="en">
- SUite of Nonlinear and DIfferential/ALgebraic equation Solvers was
- implemented with the goal of providing robust time integrators and
- nonlinear solvers that can easily be incorporated into existing
- simulation codes. The primary design goals were to require minimal
- information from the user, allow users to easily supply their own
- data structures underneath the solvers, and allow for easy
- incorporation of user-supplied linear solvers and preconditioners.
- </longdescription>
- <use>
- <flag name="hypre">Build with <pkg>sci-libs/hypre</pkg> conditioners</flag>
- <flag name="int64">Use index size of 64 rather than 32 bits</flag>
- <flag name="sparse">Enable support for <pkg>sci-libs/klu</pkg> sparse solver</flag>
- <flag name="superlumt">Build with <pkg>sci-libs/superlu_mt</pkg></flag>
- </use>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Scientific Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ SUite of Nonlinear and DIfferential/ALgebraic equation Solvers was
+ implemented with the goal of providing robust time integrators and
+ nonlinear solvers that can easily be incorporated into existing
+ simulation codes. The primary design goals were to require minimal
+ information from the user, allow users to easily supply their own
+ data structures underneath the solvers, and allow for easy
+ incorporation of user-supplied linear solvers and preconditioners.
+ </longdescription>
+ <use>
+ <flag name="hypre">Build with <pkg>sci-libs/hypre</pkg> conditioners</flag>
+ <flag name="int64">Use index size of 64 rather than 32 bits</flag>
+ <flag name="sparse">Enable support for <pkg>sci-libs/klu</pkg> sparse solver</flag>
+ <flag name="superlumt">Build with <pkg>sci-libs/superlu_mt</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">LLNL/sundials</remote-id>
+ </upstream>
</pkgmetadata>