summaryrefslogtreecommitdiff
path: root/sci-libs/pyshp/pyshp-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
commitebadb1bcdd3c4fdd2e1a569a04d2cd8c5049b64d (patch)
tree261a9ff495381f4023c98dfb4ecd5cb195b5f346 /sci-libs/pyshp/pyshp-2.3.1.ebuild
parent2666e9c75caf914c25a25329523c982df8512930 (diff)
gentoo auto-resync : 28:12:2022 - 14:12:52
Diffstat (limited to 'sci-libs/pyshp/pyshp-2.3.1.ebuild')
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/pyshp/pyshp-2.3.1.ebuild b/sci-libs/pyshp/pyshp-2.3.1.ebuild
new file mode 100644
index 000000000000..af715dcb9263
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{7..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GeospatialPython/${PN}/archive/${PV}.tar.gz -> ${P}..gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ epytest test_shapefile.py -m "not network" || die
+}