summaryrefslogtreecommitdiff
path: root/sci-libs/pyshp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
commitebadb1bcdd3c4fdd2e1a569a04d2cd8c5049b64d (patch)
tree261a9ff495381f4023c98dfb4ecd5cb195b5f346 /sci-libs/pyshp
parent2666e9c75caf914c25a25329523c982df8512930 (diff)
gentoo auto-resync : 28:12:2022 - 14:12:52
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/Manifest4
-rw-r--r--sci-libs/pyshp/metadata.xml1
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1.ebuild27
3 files changed, 31 insertions, 1 deletions
diff --git a/sci-libs/pyshp/Manifest b/sci-libs/pyshp/Manifest
index 6733c596b8df..518a8f3248ed 100644
--- a/sci-libs/pyshp/Manifest
+++ b/sci-libs/pyshp/Manifest
@@ -1,3 +1,5 @@
DIST pyshp-2.1.3.tar.gz 219626 BLAKE2B 2da94cb4b1514a504b9f961b58add973a73dea641ad5867b670860000decd29af72092079b5d16f516b99a59be83028f4698faa2cb013200e533bbe772746d48 SHA512 249302e784bb38860037242b70899faaf504ef626c37decca44dc0d7c4f9482737e3234c0002393d1ef9800778715fc2b9946f3e3f3ecf507921e9db218d0d33
+DIST pyshp-2.3.1..gh.tar.gz 2213685 BLAKE2B ca5b87dec442508bc4a0612982984ba0fb91aa8acffddb6a448c43ccf42285305600a5e28e1fb781a3d94e8ce0624d027642fddcc5f2176dca3df095e59df170 SHA512 08844492b8d1d824c639844f7f314909d946bd4d3703a4f8d4cb64d400729671b42ff5b0f80aa68d9469f3939a3c7619ba13c9efdcba3b244ec01d7be3a371c5
EBUILD pyshp-2.1.3.ebuild 549 BLAKE2B a48d9defa84bed8d33e05da68c64daa98d2f4af0265e35d7ddecb7458d8104536b9c7f16070fb009d0aa72d244440ca13e1effec239efbcd9efce276df07abc5 SHA512 ff101b2859f9d70b3f4b06356820709f55d6451d3b7116a3ed17f3e0331d364a2c76f9e405ec078a39b09a829e50848b8ca4b602b5c1d54ef8a9ddc8a3f439b3
-MISC metadata.xml 328 BLAKE2B 9ffef2bc5ef9a6697205359bcb8b2ceb1eebc67e96bb2de6e12e868daf663bf0c4bd4bd1c836f3eee452bace673dba3bf87a24322b5c0fbf497a6a6433b978b1 SHA512 33a6ce34c49c7d5e39e17c9f396c98e42209c8282a61b3a6db4f0391ab7e5399f42fa819a86bf2c5a3bcbf5cd5ec3e544cc3138ca44ebd2ed74b81951b25d1ff
+EBUILD pyshp-2.3.1.ebuild 697 BLAKE2B 8ac219194cbb868665340e4f087e9d88a4939ce3ff10fb22b38679bc6014704f2ed47a369a8e8090fb287dde821927863cb00498b39e6ff2c508719272ce89a9 SHA512 716e6f063da3d13bff5e75ac5017d3e2ff34ae39f437abe17955472e84eb1ccf07cf2eebe794cf796e1506c40b40213facc025be02ff0888f3d99151c05e474a
+MISC metadata.xml 392 BLAKE2B d0502636f7a083b4eca21dd9c9cb2604d96ec91616c88566f42687e53be965090683984d3289ae332c94309e89b25f39a12b601467abec718365d53f423fe21d SHA512 b3914985e7b8857a7f0841d4e987746f64a571a83ed3a237621c048e073c1f5a77512c40011ee1808c3ffadff08c03adc53ffe767e8a5f35c628882df779b771
diff --git a/sci-libs/pyshp/metadata.xml b/sci-libs/pyshp/metadata.xml
index 6635cddf96ed..698e51f02c5c 100644
--- a/sci-libs/pyshp/metadata.xml
+++ b/sci-libs/pyshp/metadata.xml
@@ -6,6 +6,7 @@
<name>Thomas Beierlein</name>
</maintainer>
<upstream>
+ <remote-id type="github">GeospatialPython/pyshp</remote-id>
<remote-id type="pypi">pyshp</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sci-libs/pyshp/pyshp-2.3.1.ebuild b/sci-libs/pyshp/pyshp-2.3.1.ebuild
new file mode 100644
index 000000000000..af715dcb9263
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{7..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GeospatialPython/${PN}/archive/${PV}.tar.gz -> ${P}..gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ epytest test_shapefile.py -m "not network" || die
+}