summaryrefslogtreecommitdiff
path: root/sci-libs/itpp/itpp-4.3.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-libs/itpp/itpp-4.3.1-r2.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-libs/itpp/itpp-4.3.1-r2.ebuild')
-rw-r--r--sci-libs/itpp/itpp-4.3.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/itpp/itpp-4.3.1-r2.ebuild b/sci-libs/itpp/itpp-4.3.1-r2.ebuild
new file mode 100644
index 000000000000..c2cdd0f1eedf
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.3.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="sci-libs/fftw:3.0=
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ )"
+
+DOCS=( ChangeLog NEWS AUTHORS README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.1-use-GNUInstallDirs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLA_VENDOR=Generic
+ -DHTML_DOCS=$(usex doc)
+ )
+
+ cmake_src_configure
+}