summaryrefslogtreecommitdiff
path: root/sci-libs/itpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-libs/itpp
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/Manifest3
-rw-r--r--sci-libs/itpp/files/itpp-4.3.1-use-GNUInstallDirs.patch116
-rw-r--r--sci-libs/itpp/itpp-4.3.1-r1.ebuild59
-rw-r--r--sci-libs/itpp/itpp-4.3.1-r2.ebuild40
4 files changed, 158 insertions, 60 deletions
diff --git a/sci-libs/itpp/Manifest b/sci-libs/itpp/Manifest
index 3a8baa42badc..4f4c4a1a29c7 100644
--- a/sci-libs/itpp/Manifest
+++ b/sci-libs/itpp/Manifest
@@ -1,3 +1,4 @@
+AUX itpp-4.3.1-use-GNUInstallDirs.patch 4717 BLAKE2B 2f1ba3119fc88d4a1fbf4d37c56dfd2e83877c71908f90b2ac8f9751c7714556dff8ccf7a04598b62517f5330684d79ad0acb9ab366e07be76678cbb1c6e9f86 SHA512 2743077344955bdc47b0ec5a763f04fdbecdb86edb00f1661e0b94f878324dff54e7feb8de4e157ae9b9e7c6c853789dd24faa1bced65a5ebab9179d59531d8e
DIST itpp-4.3.1.tar.bz2 1289687 BLAKE2B e14b88e6e37185525bda0d85dd13b3ef9ec8fa68f1757f56dce6436f7b9492a40aa256872186058d8fc090be656e977e0ce3bdbdf7346d2a940b481865e6d02c SHA512 b46d048fa7f33e80d2291a5e38e205c159791ea200f92c70d69e8ad8447ac2f0c847fece566a99af739853a1643cb16e226b4200c8bf115417f324e6d38c66bd
-EBUILD itpp-4.3.1-r1.ebuild 1345 BLAKE2B 6e8ca886e084b1c21cab9bcded4f9e0a4471b3d60bb6339167dfe0cda2f5e97b2271bb192f4eeb0835a9d86ef47082710170bea6fa828bd077a87fae296c1e6b SHA512 728ef2d5fb9d34f5187b4e738cfbf4cac32c8bacc432a7abddc75e877f771ff6986edc3e00ff182ea29f3d351cbc2fe61f6b3166778ad5db4dc59fbfd64ad2df
+EBUILD itpp-4.3.1-r2.ebuild 768 BLAKE2B be40a4fe11c383b9709143c9da9c27718d54791e9a69d565933280c27568cfc1c7672d1188d86ce229e08abf2af97b9526ae60a16312cd3c5d49d2035596ccfa SHA512 7697fbcb42a1ab55d958b15dfab612ea4f74edb0ccb2d3c6ecd25fb35a73830e4a791c73c5834c998533fb8111f1c0ac7dc473be002fb52c73636cdb90c82de2
MISC metadata.xml 779 BLAKE2B ff592882b0a1367992130a702424d173764a245e2755c859f3f6e4c7f17720d2fed5189b9b16aad8b13e8a71e839ecdc6508e5948108b420cd5c397a8791d47c SHA512 495dc884b01a94e45e5a86d9c640a9f25daa62aefda1ed47ed183ea17a18274802e362e6c9585fe2cb621bdfc4d2bfd89f6ed26e3302ed14a474b99465812a37
diff --git a/sci-libs/itpp/files/itpp-4.3.1-use-GNUInstallDirs.patch b/sci-libs/itpp/files/itpp-4.3.1-use-GNUInstallDirs.patch
new file mode 100644
index 000000000000..4fa9c464e4e5
--- /dev/null
+++ b/sci-libs/itpp/files/itpp-4.3.1-use-GNUInstallDirs.patch
@@ -0,0 +1,116 @@
+From 3ed973b46b50015108a9577a51feec503f06025f Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 2 Mar 2022 04:10:20 +0000
+Subject: [PATCH] Use GNUInstallDirs
+
+---
+ CMakeLists.txt | 4 ----
+ itpp-config.cmake.in | 2 +-
+ itpp.pc.cmake.in | 2 +-
+ itpp/CMakeLists.txt | 23 ++++++++++++-----------
+ 4 files changed, 14 insertions(+), 17 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a2c6958..cd661d1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -172,12 +172,8 @@ endif()
+ option(ITPP_SHARED_LIB "Building IT++ as shared library" on)
+ #set library name here to be available for all targets
+ if (ITPP_SHARED_LIB)
+- if ((CMAKE_BUILD_TYPE STREQUAL Release) OR (NOT CMAKE_BUILD_TYPE))
+ set (libitpp_target itpp)
+ set (CMAKE_CXX_FLAGS "-DNDEBUG ${CMAKE_CXX_FLAGS}")
+- else()
+- set (libitpp_target itpp_debug)
+- endif()
+ else()
+ set (libitpp_target itpp_static)
+ endif()
+diff --git a/itpp-config.cmake.in b/itpp-config.cmake.in
+index d24b57f..7d31753 100644
+--- a/itpp-config.cmake.in
++++ b/itpp-config.cmake.in
+@@ -2,7 +2,7 @@
+
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/lib
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
+ includedir=${prefix}/include
+
+ debug_flag=no
+diff --git a/itpp.pc.cmake.in b/itpp.pc.cmake.in
+index d92ce96..ac62b88 100644
+--- a/itpp.pc.cmake.in
++++ b/itpp.pc.cmake.in
+@@ -1,6 +1,6 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=@CMAKE_INSTALL_PREFIX@
+-libdir=@CMAKE_INSTALL_PREFIX@/lib
++libdir=@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@
+ includedir=@CMAKE_INSTALL_PREFIX@/include
+
+ Name: @PACKAGE_NAME@
+diff --git a/itpp/CMakeLists.txt b/itpp/CMakeLists.txt
+index e8c78d3..ee8f587 100644
+--- a/itpp/CMakeLists.txt
++++ b/itpp/CMakeLists.txt
+@@ -24,6 +24,7 @@
+ # with IT++. If not, see <http://www.gnu.org/licenses/>.
+ #
+ # -------------------------------------------------------------------------
++include(GNUInstallDirs)
+
+ file ( GLOB ITPP_SRCS
+ "base/*.cpp"
+@@ -68,18 +69,18 @@ set_target_properties(${libitpp_target} PROPERTIES VERSION ${LIBITPP_VERSION_STR
+
+ #library
+ install(TARGETS ${libitpp_target}
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+ #headers
+-install(DIRECTORY ${CMAKE_SOURCE_DIR}/itpp DESTINATION include FILES_MATCHING PATTERN "*.h")
++install(DIRECTORY ${CMAKE_SOURCE_DIR}/itpp DESTINATION ${CMAKE_INSTALL_INCLUDEDIR} FILES_MATCHING PATTERN "*.h")
+ if (WIN32 AND NOT MINGW)
+- install(FILES ${CMAKE_BINARY_DIR}/itpp/config_msvc.h DESTINATION include/itpp)
++ install(FILES ${CMAKE_BINARY_DIR}/itpp/config_msvc.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/itpp)
+ else()
+- install(FILES ${CMAKE_BINARY_DIR}/itpp/config.h DESTINATION include/itpp)
++ install(FILES ${CMAKE_BINARY_DIR}/itpp/config.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/itpp)
+ endif()
+-install(FILES ${CMAKE_BINARY_DIR}/itpp/itexports.h DESTINATION include/itpp)
++install(FILES ${CMAKE_BINARY_DIR}/itpp/itexports.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/itpp)
+
+ #extra files (MATLAB and python)
+ install(FILES ${CMAKE_SOURCE_DIR}/extras/itsave.m
+@@ -97,7 +98,7 @@ if (HTML_DOCS AND DOXYGEN_FOUND)
+ WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
+ COMMENT "Generating API documentation with Doxygen" VERBATIM)
+ file(COPY ${CMAKE_SOURCE_DIR}/doc/images/itpp_logo.png DESTINATION ${CMAKE_BINARY_DIR}/html)
+- install(DIRECTORY ${CMAKE_BINARY_DIR}/html DESTINATION share/doc/itpp)
++ install(DIRECTORY ${CMAKE_BINARY_DIR}/html DESTINATION ${CMAKE_INSTALL_DOCDIR}/itpp)
+ endif()
+
+ #itpp-config script for UNIX-like systems
+@@ -108,8 +109,8 @@ if (UNIX)
+ configure_file(${CMAKE_SOURCE_DIR}/itpp-config.cmake.in ${CMAKE_BINARY_DIR}/itpp-config @ONLY)
+ configure_file(${CMAKE_SOURCE_DIR}/itpp-config.1.cmake.in ${CMAKE_BINARY_DIR}/itpp-config.1 @ONLY)
+ configure_file(${CMAKE_SOURCE_DIR}/itpp.pc.cmake.in ${CMAKE_BINARY_DIR}/itpp.pc @ONLY)
+- install(FILES ${CMAKE_BINARY_DIR}/itpp-config DESTINATION bin PERMISSIONS OWNER_READ OWNER_EXECUTE
++ install(FILES ${CMAKE_BINARY_DIR}/itpp-config DESTINATION ${CMAKE_INSTALL_BINDIR} PERMISSIONS OWNER_READ OWNER_EXECUTE
+ GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+- install(FILES ${CMAKE_BINARY_DIR}/itpp-config.1 DESTINATION share/man/man1)
+- install(FILES ${CMAKE_BINARY_DIR}/itpp.pc DESTINATION lib/pkgconfig)
++ install(FILES ${CMAKE_BINARY_DIR}/itpp-config.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
++ install(FILES ${CMAKE_BINARY_DIR}/itpp.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
+--
+2.35.1
+
diff --git a/sci-libs/itpp/itpp-4.3.1-r1.ebuild b/sci-libs/itpp/itpp-4.3.1-r1.ebuild
deleted file mode 100644
index 8d522b501ed5..000000000000
--- a/sci-libs/itpp/itpp-4.3.1-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="C++ library of mathematical, signal processing and communication"
-HOMEPAGE="http://itpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="
- sci-libs/fftw:3.0=
- virtual/blas
- virtual/lapack
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- virtual/latex-base
- )
-"
-
-DOCS=( ChangeLog NEWS AUTHORS README )
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # gentoo redefines the CMAKE_BUILD_TYPE
- sed -i \
- -e 's/CMAKE_BUILD_TYPE STREQUAL Release/NOT CMAKE_BUILD_TYPE STREQUAL Debug/' \
- CMakeLists.txt || die
- # respect gentoo doc dir
- sed -i \
- -e "s:share/doc/itpp:share/doc/${PF}:" \
- itpp/CMakeLists.txt || die
-
- # respect gentoo libdir
- sed -i "s#/lib#/$(get_libdir)#" itpp-config.cmake.in || die
- sed -i "s#/lib#/$(get_libdir)#" itpp.pc.cmake.in || die
- sed -i \
- -e "s#LIBRARY DESTINATION lib#LIBRARY DESTINATION $(get_libdir)#" \
- -e "s#ARCHIVE DESTINATION lib#ARCHIVE DESTINATION $(get_libdir)#" \
- itpp/CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBLA_VENDOR=Generic
- -DHTML_DOCS=$(usex doc)
- )
- cmake-utils_src_configure
-}
diff --git a/sci-libs/itpp/itpp-4.3.1-r2.ebuild b/sci-libs/itpp/itpp-4.3.1-r2.ebuild
new file mode 100644
index 000000000000..c2cdd0f1eedf
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.3.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="sci-libs/fftw:3.0=
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ )"
+
+DOCS=( ChangeLog NEWS AUTHORS README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.1-use-GNUInstallDirs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLA_VENDOR=Generic
+ -DHTML_DOCS=$(usex doc)
+ )
+
+ cmake_src_configure
+}