summaryrefslogtreecommitdiff
path: root/sci-libs/idlcoyote/idlcoyote-20161220.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/idlcoyote/idlcoyote-20161220.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/idlcoyote/idlcoyote-20161220.ebuild')
-rw-r--r--sci-libs/idlcoyote/idlcoyote-20161220.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/idlcoyote/idlcoyote-20161220.ebuild b/sci-libs/idlcoyote/idlcoyote-20161220.ebuild
new file mode 100644
index 000000000000..20857bb5a31f
--- /dev/null
+++ b/sci-libs/idlcoyote/idlcoyote-20161220.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} != 99999999 ]]; then
+ SRC_URI="http://www.idlcoyote.com/programs/zip_files/coyoteprograms.zip -> ${P}.zip"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/coyote"
+ DEPEND="app-arch/unzip"
+else
+ inherit git-r3
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/idl-coyote/coyote.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="GDL library from D. Fannings IDL courses"
+HOMEPAGE="http://www.idlcoyote.com/"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-lang/gdl"
+
+src_install() {
+ dodoc README.txt
+ rm README.txt || die
+ insinto /usr/share/gnudatalanguage/coyote
+ doins -r *
+}