summaryrefslogtreecommitdiff
path: root/sci-libs/idlcoyote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/idlcoyote
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/idlcoyote')
-rw-r--r--sci-libs/idlcoyote/Manifest5
-rw-r--r--sci-libs/idlcoyote/idlcoyote-20161220.ebuild32
-rw-r--r--sci-libs/idlcoyote/idlcoyote-99999999.ebuild32
-rw-r--r--sci-libs/idlcoyote/metadata.xml14
4 files changed, 83 insertions, 0 deletions
diff --git a/sci-libs/idlcoyote/Manifest b/sci-libs/idlcoyote/Manifest
new file mode 100644
index 000000000000..3655a1708b46
--- /dev/null
+++ b/sci-libs/idlcoyote/Manifest
@@ -0,0 +1,5 @@
+DIST idlcoyote-20161220.zip 1437560 SHA256 64cf332a6f630f97799837dc0592a28945aa3543bc38976fc1543af22fecbd30 SHA512 2c175cf3a42a0f2915eb8d02884f06892245ee023e6f3f2702b00ced0311dcde504d014fb8936aef7148fe6d91e258e3f6ffeec7d5c0bb22f65962b8ebe3bd8b WHIRLPOOL a4949825fc53d5002af68764df598e914525e853b929c9a686550b33c741466e1aec00b01ed083442c5baebcd89ef2314e0cb103050cfd379e161aaed49fa94d
+EBUILD idlcoyote-20161220.ebuild 716 SHA256 8f9cd0c21c5951ecff449f1b3a414bbc9833a3769e5c9a4564c9fd1adc943d0a SHA512 ab15c9d275ff96b99814952ec5a1f6cc5ce079e338908688e97625ebf519d8da474df7188bd8932e1587b92565d965bb77b4c4c7f75983c530ebcd1b23f56979 WHIRLPOOL c0e6eca2848756dcf4b8a7110b9f4af04dcee9249d611f98c4856826eec5a2d6c4c07780e8985df76aab7ce731200db9b29426a2d96ecce986593b1719dfab22
+EBUILD idlcoyote-99999999.ebuild 716 SHA256 8f9cd0c21c5951ecff449f1b3a414bbc9833a3769e5c9a4564c9fd1adc943d0a SHA512 ab15c9d275ff96b99814952ec5a1f6cc5ce079e338908688e97625ebf519d8da474df7188bd8932e1587b92565d965bb77b4c4c7f75983c530ebcd1b23f56979 WHIRLPOOL c0e6eca2848756dcf4b8a7110b9f4af04dcee9249d611f98c4856826eec5a2d6c4c07780e8985df76aab7ce731200db9b29426a2d96ecce986593b1719dfab22
+MISC ChangeLog 395 SHA256 b1eba7fdf87d446ecef0d150f7717d006174dccfc83175cf0026bbc1f87f321f SHA512 7bc4be108b09cebaf2f333c0cdb5bfadc82c8755b1399b05b913958d0e783cf431ccc35cc5b1e7916876c8cc7defee708a8e64460f3efe8e80dcd98218f8f8d1 WHIRLPOOL 226e5aff3fdbfee2296f09bd3cb697362f2a489d28e8b5b01421168d454e127afe187a6c20eee23711e45d266ff4b741dabcda1a726401da409acf7cddbc4055
+MISC metadata.xml 606 SHA256 c3be8b6eb906a1937da691cf9fa05537fcc7a44e47eee09bf31f6929fb6b13c3 SHA512 06b29c96c7e57cf99f22333ba9df18a23fac6659d1ae57fbe9273c0f548cec1f0a18a5500222e4c000cfb3307bdc8c450da7c57e6e4be7143490c3ca282c76cb WHIRLPOOL f9a1f4844ce68356e1d86a9d05a5b7e77596378318bba39a9596a64e2bcedc51a78af3688aa5f693d5305373c078f94b6cdf3bb7977a2ed445b416a904dd5d00
diff --git a/sci-libs/idlcoyote/idlcoyote-20161220.ebuild b/sci-libs/idlcoyote/idlcoyote-20161220.ebuild
new file mode 100644
index 000000000000..20857bb5a31f
--- /dev/null
+++ b/sci-libs/idlcoyote/idlcoyote-20161220.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} != 99999999 ]]; then
+ SRC_URI="http://www.idlcoyote.com/programs/zip_files/coyoteprograms.zip -> ${P}.zip"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/coyote"
+ DEPEND="app-arch/unzip"
+else
+ inherit git-r3
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/idl-coyote/coyote.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="GDL library from D. Fannings IDL courses"
+HOMEPAGE="http://www.idlcoyote.com/"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-lang/gdl"
+
+src_install() {
+ dodoc README.txt
+ rm README.txt || die
+ insinto /usr/share/gnudatalanguage/coyote
+ doins -r *
+}
diff --git a/sci-libs/idlcoyote/idlcoyote-99999999.ebuild b/sci-libs/idlcoyote/idlcoyote-99999999.ebuild
new file mode 100644
index 000000000000..20857bb5a31f
--- /dev/null
+++ b/sci-libs/idlcoyote/idlcoyote-99999999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} != 99999999 ]]; then
+ SRC_URI="http://www.idlcoyote.com/programs/zip_files/coyoteprograms.zip -> ${P}.zip"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/coyote"
+ DEPEND="app-arch/unzip"
+else
+ inherit git-r3
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/idl-coyote/coyote.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="GDL library from D. Fannings IDL courses"
+HOMEPAGE="http://www.idlcoyote.com/"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-lang/gdl"
+
+src_install() {
+ dodoc README.txt
+ rm README.txt || die
+ insinto /usr/share/gnudatalanguage/coyote
+ doins -r *
+}
diff --git a/sci-libs/idlcoyote/metadata.xml b/sci-libs/idlcoyote/metadata.xml
new file mode 100644
index 000000000000..298edd428429
--- /dev/null
+++ b/sci-libs/idlcoyote/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Coyote Library evolved from work David Fanning was doing teaching
+ IDL courses and answering IDL questions on the IDL newsgroup. It is
+ meant to be a well-documented library that demonstrates how to write
+ solid IDL/GDL programs that are easy to maintain and extend.
+ </longdescription>
+</pkgmetadata>