summaryrefslogtreecommitdiff
path: root/sci-biology/pysam
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /sci-biology/pysam
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'sci-biology/pysam')
-rw-r--r--sci-biology/pysam/Manifest2
-rw-r--r--sci-biology/pysam/pysam-0.17.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index 66e54f590b92..3647402b6949 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1,4 +1,6 @@
AUX pysam-0.16.0.1-fix-tests.patch 1128 BLAKE2B 8e395496c23186b29622b8e87369f910326724b70b63f3eccfd6d4b6cea86abf8b34a712a931f205711e2c5a6e76c9572a93aa9bd994f915312c55dcc888da52 SHA512 e725143c72d04fc0e2e37e607e6d9b85b4c883bcc5a530ff3c92e3bbd45d7d7fb09c315766a19254bea2a19a2d00a5f64220094a4e9b1090e412b26ea489b530
DIST pysam-0.16.0.1.tar.gz 3294073 BLAKE2B 8df1c9b061b0d4b3962ff4b0e30f1589e02d7df41ce362bff861596d3599bf800bb16b2fa4de326fc07102dc7801b48c6b821e5d47e694a3536bec2c5b1cfece SHA512 5cebb9f3bc8dc6186a629e91423a3c8cb802af6529b943fcd880e056661ec6ee2a00de789cf144c9e40b9d1ef2459c0e06ce27a1b9eab8e2875d2087f275af28
+DIST pysam-0.17.0.tar.gz 3579324 BLAKE2B 6b88fe771350f20fa7c90a4c02c60fefd6a34d979c687fce1e34a17e1ff203c7d2d07e36b64f7a73f99676b805334df7f049932ce15e26362a5214da03435d64 SHA512 16740f08fb68a1f24656454b834dd9ac52ad9f864f307564566fc244bbd2efb7cb17107b2e85ca5c56af817918a138d1c071533de1b80e5bba42b01bbad7f552
EBUILD pysam-0.16.0.1.ebuild 1393 BLAKE2B 1b68d4d351483c8082905460185395d560a9c3157d10f2cb5b2eee76d8828e7e50252f1eb920b9411761c4081f11b293de2c87cede8e9d5e22b568cee0691cfc SHA512 b8e2b792eefbc12e30e51ae01fa48977dfd904abcaf7fcbbd5b5148da76fb5411d0b412f0f0aae060ddf462eb4b69269f362d00dfa1371bda4a38dcce0a6baca
+EBUILD pysam-0.17.0.ebuild 1586 BLAKE2B 38351a74c0a57348fdc1999f35b10cd8645160175386b94885e49bbd99bc64f577c326d04e09ba56abce0c0c01331276ebef080fbf519dbfbae41960b6ccc61a SHA512 bd0e336603727c67cd363c628daa9aa9b95e6fe2dbcc06425fcbcf03bd8bd4bd79e651b637434cdbbecd85ebc2841647863910e31f94dd9641694fb4c68de8d4
MISC metadata.xml 442 BLAKE2B e3d339868a09d8930ff6d83f414f8166ed283a66d83d5b0fed0031024db151b17b1347f5e015f2b9c2152a041e2beb70696362be9b4e3fc225078bc5c520ad58 SHA512 4b1d08c5524e1bb04129e0d38f0584654b34979024afd2cf15bd482654ca8fac9c82e6db0661f7370f9fefa6949f1291ba3c18a9dca5d5041bd6f76554fa33c7
diff --git a/sci-biology/pysam/pysam-0.17.0.ebuild b/sci-biology/pysam/pysam-0.17.0.ebuild
new file mode 100644
index 000000000000..afdc4777e20e
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.17.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="
+ https://github.com/pysam-developers/pysam
+ https://pypi.org/project/pysam/"
+SRC_URI="https://github.com/pysam-developers/pysam/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sci-libs/htslib-1.13*:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ =sci-biology/bcftools-1.13*
+ =sci-biology/samtools-1.13*
+ )"
+
+distutils_enable_tests pytest
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+EPYTEST_DESELECT=(
+ # only work with bundled htslib
+ 'tests/tabix_test.py::TestRemoteFileHTTP'
+ 'tests/tabix_test.py::TestRemoteFileHTTPWithHeader'
+)
+
+python_prepare_all() {
+ # unbundle htslib
+ export HTSLIB_MODE="external"
+ export HTSLIB_INCLUDE_DIR="${EPREFIX}"/usr/include
+ export HTSLIB_LIBRARY_DIR="${EPREFIX}"/usr/$(get_libdir)
+ rm -r htslib || die
+
+ # prevent setup.py from adding RPATHs (except $ORIGIN)
+ sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
+ -i setup.py || die
+
+ if use test; then
+ einfo "Building test data"
+ emake -C tests/pysam_data
+ emake -C tests/cbcf_data
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # breaks with parallel build
+ # need to avoid dropping .so plugins into
+ # build-lib, which breaks tests
+ esetup.py build_ext --inplace -j1
+ distutils-r1_python_compile -j1
+}