summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /sci-biology
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin21279 -> 21298 bytes
-rw-r--r--sci-biology/bcftools/Manifest2
-rw-r--r--sci-biology/bcftools/bcftools-1.13.ebuild44
-rw-r--r--sci-biology/pysam/Manifest2
-rw-r--r--sci-biology/pysam/pysam-0.17.0.ebuild66
-rw-r--r--sci-biology/samtools/Manifest2
-rw-r--r--sci-biology/samtools/samtools-1.13.ebuild47
7 files changed, 163 insertions, 0 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index 72463ed5f3f1..fbc00040d679 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index 4b55d93fe29d..359793c2e6bc 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1,3 +1,5 @@
DIST bcftools-1.10.2.tar.bz2 3702679 BLAKE2B 51acce94d463868562199206504dc8afb50c671c11139c5a96f52cedf135bb7a46115c69411b9943b970a2395e3c866275c85e345a4a40a90194d1094698314e SHA512 f07e405efa16b9b1b18521342df3eaf840ed1b3028b736a6b4d139012ea85769ddfb3cd3a2c94958415d984d07805dfcd3d4bbec0db401b3f071b861a56d1300
+DIST bcftools-1.13.tar.bz2 6906796 BLAKE2B 4c02d65733d28684f9a976e082913d79dbac4463c9471fc26d8ee0cbe7ad25af429cf7d01b9771bc34309386ccd2d77ebd54fbf64ed4183d1c2ebfbc0e727afb SHA512 aa533233dd2fec2279859204be39430c4fc630137a91d57fe917fd7a220044d5202ddc3d44bcffc3bd5bd5bb64f6ea4c8ec3c31e5e1ec72399998f1e6f23a55a
EBUILD bcftools-1.10.2.ebuild 864 BLAKE2B b98c493d6e50d982917ecbf32c424a45231c3f512a49a0c9cd675cbb3d5f21a57d62cc53a20556663b6fd1d58a68df01a9ed56185dd5f400b8ee5b5c7b5497fd SHA512 c8c3173376a35824ce10413e7cba172d6a90dae91352a292df5603f1a7e17cd5987fc91b463b030221b577bce5424ae7a219625cb684cb3fa2f6777581bb19bb
+EBUILD bcftools-1.13.ebuild 896 BLAKE2B 74b1387b81ec75926bd76d62033d7cf0708ac3b9a0b0b0573fec1c70efb47b84bd3fa626f3ff3144e380f07822bd3d9e56f4ddb1e09a4a09082cb1d6d3229b39 SHA512 bb0f18c2102fbfa8d5ee636c81308ea8a0ef6de80943423377846ebd2180881ca745e7eddd94be7ad7b34a2313acc43553d8a31ee474542de5d29d4874e935e4
MISC metadata.xml 344 BLAKE2B 37f8e82e8a5a9ad572580a7e5ae6daa6911d672f17b8526f81b236cbc2e50a32c4cd2566aaed9f5feee016d7e2de7db2a40b60616e86c3e8cae307d60cebc70e SHA512 0160c9606089d610613d71dc0aa9c9c5e5266483fdc9c407b6e0ed911eac8f8b32ffaf5a49bbb427393c8240e9868df51f0fc68b2f45467f65d9b3d54b0ddde1
diff --git a/sci-biology/bcftools/bcftools-1.13.ebuild b/sci-biology/bcftools/bcftools-1.13.ebuild
new file mode 100644
index 000000000000..b0ddd23857c2
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep '
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ ')
+ =sci-libs/htslib-${PV}*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{gff2gff,guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index 66e54f590b92..3647402b6949 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1,4 +1,6 @@
AUX pysam-0.16.0.1-fix-tests.patch 1128 BLAKE2B 8e395496c23186b29622b8e87369f910326724b70b63f3eccfd6d4b6cea86abf8b34a712a931f205711e2c5a6e76c9572a93aa9bd994f915312c55dcc888da52 SHA512 e725143c72d04fc0e2e37e607e6d9b85b4c883bcc5a530ff3c92e3bbd45d7d7fb09c315766a19254bea2a19a2d00a5f64220094a4e9b1090e412b26ea489b530
DIST pysam-0.16.0.1.tar.gz 3294073 BLAKE2B 8df1c9b061b0d4b3962ff4b0e30f1589e02d7df41ce362bff861596d3599bf800bb16b2fa4de326fc07102dc7801b48c6b821e5d47e694a3536bec2c5b1cfece SHA512 5cebb9f3bc8dc6186a629e91423a3c8cb802af6529b943fcd880e056661ec6ee2a00de789cf144c9e40b9d1ef2459c0e06ce27a1b9eab8e2875d2087f275af28
+DIST pysam-0.17.0.tar.gz 3579324 BLAKE2B 6b88fe771350f20fa7c90a4c02c60fefd6a34d979c687fce1e34a17e1ff203c7d2d07e36b64f7a73f99676b805334df7f049932ce15e26362a5214da03435d64 SHA512 16740f08fb68a1f24656454b834dd9ac52ad9f864f307564566fc244bbd2efb7cb17107b2e85ca5c56af817918a138d1c071533de1b80e5bba42b01bbad7f552
EBUILD pysam-0.16.0.1.ebuild 1393 BLAKE2B 1b68d4d351483c8082905460185395d560a9c3157d10f2cb5b2eee76d8828e7e50252f1eb920b9411761c4081f11b293de2c87cede8e9d5e22b568cee0691cfc SHA512 b8e2b792eefbc12e30e51ae01fa48977dfd904abcaf7fcbbd5b5148da76fb5411d0b412f0f0aae060ddf462eb4b69269f362d00dfa1371bda4a38dcce0a6baca
+EBUILD pysam-0.17.0.ebuild 1586 BLAKE2B 38351a74c0a57348fdc1999f35b10cd8645160175386b94885e49bbd99bc64f577c326d04e09ba56abce0c0c01331276ebef080fbf519dbfbae41960b6ccc61a SHA512 bd0e336603727c67cd363c628daa9aa9b95e6fe2dbcc06425fcbcf03bd8bd4bd79e651b637434cdbbecd85ebc2841647863910e31f94dd9641694fb4c68de8d4
MISC metadata.xml 442 BLAKE2B e3d339868a09d8930ff6d83f414f8166ed283a66d83d5b0fed0031024db151b17b1347f5e015f2b9c2152a041e2beb70696362be9b4e3fc225078bc5c520ad58 SHA512 4b1d08c5524e1bb04129e0d38f0584654b34979024afd2cf15bd482654ca8fac9c82e6db0661f7370f9fefa6949f1291ba3c18a9dca5d5041bd6f76554fa33c7
diff --git a/sci-biology/pysam/pysam-0.17.0.ebuild b/sci-biology/pysam/pysam-0.17.0.ebuild
new file mode 100644
index 000000000000..afdc4777e20e
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.17.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="
+ https://github.com/pysam-developers/pysam
+ https://pypi.org/project/pysam/"
+SRC_URI="https://github.com/pysam-developers/pysam/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sci-libs/htslib-1.13*:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ =sci-biology/bcftools-1.13*
+ =sci-biology/samtools-1.13*
+ )"
+
+distutils_enable_tests pytest
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+EPYTEST_DESELECT=(
+ # only work with bundled htslib
+ 'tests/tabix_test.py::TestRemoteFileHTTP'
+ 'tests/tabix_test.py::TestRemoteFileHTTPWithHeader'
+)
+
+python_prepare_all() {
+ # unbundle htslib
+ export HTSLIB_MODE="external"
+ export HTSLIB_INCLUDE_DIR="${EPREFIX}"/usr/include
+ export HTSLIB_LIBRARY_DIR="${EPREFIX}"/usr/$(get_libdir)
+ rm -r htslib || die
+
+ # prevent setup.py from adding RPATHs (except $ORIGIN)
+ sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
+ -i setup.py || die
+
+ if use test; then
+ einfo "Building test data"
+ emake -C tests/pysam_data
+ emake -C tests/cbcf_data
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # breaks with parallel build
+ # need to avoid dropping .so plugins into
+ # build-lib, which breaks tests
+ esetup.py build_ext --inplace -j1
+ distutils-r1_python_compile -j1
+}
diff --git a/sci-biology/samtools/Manifest b/sci-biology/samtools/Manifest
index 81ff987d83da..258415bacb57 100644
--- a/sci-biology/samtools/Manifest
+++ b/sci-biology/samtools/Manifest
@@ -1,6 +1,8 @@
AUX samtools-0.1.20-buildsystem.patch 6737 BLAKE2B 71445f57735903bccc2720a32f42b27093f670e383d2d194b5692b1ba536e3df44204711cf4574b3933e5ce00605b661b1a36d79ca7f193ce36816271a3f8214 SHA512 ecb05971fbea4570ec161a165cb581b38ed727bb7e5b769862984bf035414cd564ab809882dc3272f8b192feeb86e29247d7327afa73ff668b01c03c58bb177d
DIST samtools-0.1.20.tar.gz 566387 BLAKE2B a62d74c408877754af50f5e5fea0e2289ec1e0c9f25013ed0d039bfe8ef61108600d917f8c9d356e98aca632795b4eb0f01ea1b54526a652577fb74a38a433c2 SHA512 15bd8cf401d14c1ab4faa591b6054f5ea9731c4e966f37f71d33d9081a270cfeb91e8a3d80c631e0725b49da81387f824c206e8c21553ad554d0cfc5c238a6e5
DIST samtools-1.10.tar.bz2 4721173 BLAKE2B 103c71ec5740eac151a4fc40d67286ee00123c7befd5f654cf5c89812bda44f82b38ab662a4a3216ac84434cabab49500b903612137f97f89a7ea38063e8fc08 SHA512 828ec2638592b440e06b81eafc57634416ab54dac6caaecb06f22a90e9bf99da1fd8bb54509cb98591899c4e097ac9038ee5d57ea7bfe1a18967cde4018d840a
+DIST samtools-1.13.tar.bz2 7984998 BLAKE2B e46161c43d4ea51c3ef1d9ed74c40c21b70aef80aa903a49b94b3d468f9211e9147281204eb61b9843c071f09ead08c924e3d624d4df76a1d02ba9ceb318399a SHA512 647fbad2935dfc3e4f85da257a6ee59af40078024a3b77f117dada5f55846e381a096db3cf62a63c04ae95dfc9fadb1d515b8d618e6388bc93f0b2ac85eaf6ea
EBUILD samtools-0.1.20-r4.ebuild 2049 BLAKE2B d377712eaca931258b37645e6a6b3cc379fdb550ef83a0c272a3eb564d7753185fea53416973e4fdf2c25b79475a81ae72b646ce22c570c934e4eabce8a9ded6 SHA512 c0d387f715ebf1f746ea4e4a7eab85a86ef0bff646c9a69639b17ef02e93c39982941d7eb811a6d67b0e635c9c4e05924d2b89a6809c3bd0592db91894dab4aa
EBUILD samtools-1.10-r1.ebuild 993 BLAKE2B 69080337f15d653be56680f3183c2eab3c1813805e3ffc3be1d6dc0e04264a063ae758b694ccb1ff097e952cad736a387de02905ca4f7d4af779233d9e1fced2 SHA512 15dab01b933e56fc83b71f68b2c52c69b115df19f72599e4b4d9d959f9035a468e3ad825cb2e12a80ba558b953879d1b6f8e9dc50922d099c375312dd7580040
+EBUILD samtools-1.13.ebuild 886 BLAKE2B e96ccbff6d7310e4691118bc191a020525a92aa49dd24478be11185e1767788849bae9d575d59dc139f77b0c977222684c82a45487b4d10d77da20347f5170b5 SHA512 3eb07532ae9d7995279663d8e09602e30a5055b13388ceb83aa369e52bb2291f21014f60dccc5569825f6e7683801b737557539270007bc16a12015d86c17fec
MISC metadata.xml 409 BLAKE2B c94eab9ebda4844beb471694106e353ccbbaca53e69de680301c6cfab3f3b6224ec94fcd631c9de2811d309463e5ee6decf2e443bfc68921f3362c6a312cd3af SHA512 fb2d3686e1ee70e4e80266a26603b3e52b680b1537a4569493a3a0511b93e2acdb2be3136df7ae54905a9f86fb7e53fa054607262751ebd8f54903f1905dad24
diff --git a/sci-biology/samtools/samtools-1.13.ebuild b/sci-biology/samtools/samtools-1.13.ebuild
new file mode 100644
index 000000000000..3165c7b7381c
--- /dev/null
+++ b/sci-biology/samtools/samtools-1.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-${PV}*:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-htslib=system \
+ CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw || die)"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}