summaryrefslogtreecommitdiff
path: root/sci-biology/pysam
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
commit8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (patch)
treeced0310e563ec21deb23ca12d5459aebadba36f6 /sci-biology/pysam
parent93c735f5f1ff867aadcc947348d984ff2c5a29cb (diff)
gentoo auto-resync : 30:03:2023 - 16:00:34
Diffstat (limited to 'sci-biology/pysam')
-rw-r--r--sci-biology/pysam/Manifest1
-rw-r--r--sci-biology/pysam/pysam-9999.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index 9bdae09a6265..1fd20223d758 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1,3 +1,4 @@
DIST pysam-0.20.0.gh.tar.gz 3748498 BLAKE2B 1c1b99e5ec34641c196dd574e634cc87d49baa594243eca20ad1f99d2c01b8aadead70a729f389c93cf6f5e95f20d9c7e3d050a47821d1b0dcaaff39d88e6825 SHA512 3f8402057e1d5c807886d1d38180dbdbfa8557700fa97bd59cb42df4d7cc461dcbe54808a169ba5f9696651e801fd0431480cd033b601cd4e9c11bf8bbf14e49
EBUILD pysam-0.20.0.ebuild 1767 BLAKE2B 45a292847762698e9629508f6b22624202509f946085995d8bd110fe4cd227e707546ecdae33b68036029b94bcf4824699a62031fd05144c6cfdd605b0c2e190 SHA512 3e54171befa77ac9d03114069064b5b166a4010c9fc8076540680660d8d90a7650264583d41bd6dce8d10e5c1a4723969cc2deb568d29283b91bf5b53351de35
+EBUILD pysam-9999.ebuild 1709 BLAKE2B b7297d21abf0e581c5c2d8a72a7e6805cb5f96f6e878cc979fc0f5a34e57bdd25a2f50abaa9ee10040559e66ee42d3a24696a7093103658175b27858acaac95c SHA512 7e7a782243897a89a3539b3eb79ccd0790c6b0afcf79453526c30371f867faaf8eca6454e64d3bea250ff13753ff400fe5ff3352c080c85285cafa2346e3564a
MISC metadata.xml 442 BLAKE2B e3d339868a09d8930ff6d83f414f8166ed283a66d83d5b0fed0031024db151b17b1347f5e015f2b9c2152a041e2beb70696362be9b4e3fc225078bc5c520ad58 SHA512 4b1d08c5524e1bb04129e0d38f0584654b34979024afd2cf15bd482654ca8fac9c82e6db0661f7370f9fefa6949f1291ba3c18a9dca5d5041bd6f76554fa33c7
diff --git a/sci-biology/pysam/pysam-9999.ebuild b/sci-biology/pysam/pysam-9999.ebuild
new file mode 100644
index 000000000000..a162ddf2158b
--- /dev/null
+++ b/sci-biology/pysam/pysam-9999.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pysam-developers/pysam.git"
+else
+ SRC_URI="https://github.com/pysam-developers/pysam/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="
+ https://github.com/pysam-developers/pysam
+ https://pypi.org/project/pysam/"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=sci-libs/htslib-1.17"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=sci-biology/bcftools-1.17
+ >=sci-biology/samtools-1.17
+ )"
+
+distutils_enable_tests pytest
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+EPYTEST_DESELECT=(
+ # only work with bundled htslib
+ 'tests/tabix_test.py::TestRemoteFileHTTP'
+ 'tests/tabix_test.py::TestRemoteFileHTTPWithHeader'
+)
+
+python_prepare_all() {
+ # unbundle htslib
+ export HTSLIB_MODE="external"
+ export HTSLIB_INCLUDE_DIR="${ESYSROOT}"/usr/include
+ export HTSLIB_LIBRARY_DIR="${ESYSROOT}"/usr/$(get_libdir)
+ rm -r htslib || die
+
+ # prevent setup.py from adding RPATHs (except $ORIGIN)
+ sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
+ -i setup.py || die
+
+ if use test; then
+ einfo "Building test data"
+ emake -C tests/pysam_data
+ emake -C tests/cbcf_data
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # breaks with parallel build
+ # need to avoid dropping .so plugins into
+ # build-lib, which breaks tests
+ esetup.py build_ext --inplace -j1
+ distutils-r1_python_compile -j1
+}