summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
commit8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (patch)
treeced0310e563ec21deb23ca12d5459aebadba36f6 /sci-biology
parent93c735f5f1ff867aadcc947348d984ff2c5a29cb (diff)
gentoo auto-resync : 30:03:2023 - 16:00:34
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin19495 -> 19502 bytes
-rw-r--r--sci-biology/bcftools/Manifest2
-rw-r--r--sci-biology/bcftools/bcftools-1.17.ebuild42
-rw-r--r--sci-biology/pysam/Manifest1
-rw-r--r--sci-biology/pysam/pysam-9999.ebuild72
-rw-r--r--sci-biology/samtools/Manifest2
-rw-r--r--sci-biology/samtools/samtools-1.17.ebuild47
7 files changed, 166 insertions, 0 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index 73acfdc415db..cc7f7a73cd0d 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index f4aeb61e0c0a..5e78fe941f36 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1,3 +1,5 @@
DIST bcftools-1.16.tar.bz2 7325862 BLAKE2B 0e1240448d4efb352d3d0cd83decd286f7544fff3676f0a5cca51dec9c445c47c37ac24a3317aa7b41182c576e7e57dba460fc98aca069dc2f8fe0625c0b0f06 SHA512 998d5ac941f73798c35dd1db7ac7aba9067f275bd3055728aabfd8edd9f40484130df1fb57621d1a762a57b28ffcac358570915c341d420ae6f12bd17f7651a3
+DIST bcftools-1.17.tar.bz2 7538043 BLAKE2B 82f65d53ebea0527ff000329f158ebdb1d603e04841a096cf8ca0434e7a5694ab43da7959ee10e9cb29328bf82301c03200e1203578a74e2e1118856b2641502 SHA512 39ae44a682e626a5261900e9412170a269e460b559d6607db697e6a12b1e512ffb3bdeb3486413e19b8adca26a8ccbb2bd4af24459decb74592c54473d2c6a68
EBUILD bcftools-1.16.ebuild 900 BLAKE2B 98f04325ca039867010c25c5ebff64725de637960c1980cce0faee7b8514d187ca3a309a3db79bb809ebcb9938869884c89b54f232fcf826aa34b38c5dde9c6e SHA512 82bb9a379019f0d9f9c601fad06d4041e5b890cb21618cc37f37f5f6ce0c3d5d9cd1d6223a19b8a53303e8ab3ce4046a21fbd3b7b18fd45243d57226d040ffc4
+EBUILD bcftools-1.17.ebuild 900 BLAKE2B 98f04325ca039867010c25c5ebff64725de637960c1980cce0faee7b8514d187ca3a309a3db79bb809ebcb9938869884c89b54f232fcf826aa34b38c5dde9c6e SHA512 82bb9a379019f0d9f9c601fad06d4041e5b890cb21618cc37f37f5f6ce0c3d5d9cd1d6223a19b8a53303e8ab3ce4046a21fbd3b7b18fd45243d57226d040ffc4
MISC metadata.xml 344 BLAKE2B 37f8e82e8a5a9ad572580a7e5ae6daa6911d672f17b8526f81b236cbc2e50a32c4cd2566aaed9f5feee016d7e2de7db2a40b60616e86c3e8cae307d60cebc70e SHA512 0160c9606089d610613d71dc0aa9c9c5e5266483fdc9c407b6e0ed911eac8f8b32ffaf5a49bbb427393c8240e9868df51f0fc68b2f45467f65d9b3d54b0ddde1
diff --git a/sci-biology/bcftools/bcftools-1.17.ebuild b/sci-biology/bcftools/bcftools-1.17.ebuild
new file mode 100644
index 000000000000..6adee705bb46
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]')
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{gff2gff,guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
index 9bdae09a6265..1fd20223d758 100644
--- a/sci-biology/pysam/Manifest
+++ b/sci-biology/pysam/Manifest
@@ -1,3 +1,4 @@
DIST pysam-0.20.0.gh.tar.gz 3748498 BLAKE2B 1c1b99e5ec34641c196dd574e634cc87d49baa594243eca20ad1f99d2c01b8aadead70a729f389c93cf6f5e95f20d9c7e3d050a47821d1b0dcaaff39d88e6825 SHA512 3f8402057e1d5c807886d1d38180dbdbfa8557700fa97bd59cb42df4d7cc461dcbe54808a169ba5f9696651e801fd0431480cd033b601cd4e9c11bf8bbf14e49
EBUILD pysam-0.20.0.ebuild 1767 BLAKE2B 45a292847762698e9629508f6b22624202509f946085995d8bd110fe4cd227e707546ecdae33b68036029b94bcf4824699a62031fd05144c6cfdd605b0c2e190 SHA512 3e54171befa77ac9d03114069064b5b166a4010c9fc8076540680660d8d90a7650264583d41bd6dce8d10e5c1a4723969cc2deb568d29283b91bf5b53351de35
+EBUILD pysam-9999.ebuild 1709 BLAKE2B b7297d21abf0e581c5c2d8a72a7e6805cb5f96f6e878cc979fc0f5a34e57bdd25a2f50abaa9ee10040559e66ee42d3a24696a7093103658175b27858acaac95c SHA512 7e7a782243897a89a3539b3eb79ccd0790c6b0afcf79453526c30371f867faaf8eca6454e64d3bea250ff13753ff400fe5ff3352c080c85285cafa2346e3564a
MISC metadata.xml 442 BLAKE2B e3d339868a09d8930ff6d83f414f8166ed283a66d83d5b0fed0031024db151b17b1347f5e015f2b9c2152a041e2beb70696362be9b4e3fc225078bc5c520ad58 SHA512 4b1d08c5524e1bb04129e0d38f0584654b34979024afd2cf15bd482654ca8fac9c82e6db0661f7370f9fefa6949f1291ba3c18a9dca5d5041bd6f76554fa33c7
diff --git a/sci-biology/pysam/pysam-9999.ebuild b/sci-biology/pysam/pysam-9999.ebuild
new file mode 100644
index 000000000000..a162ddf2158b
--- /dev/null
+++ b/sci-biology/pysam/pysam-9999.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pysam-developers/pysam.git"
+else
+ SRC_URI="https://github.com/pysam-developers/pysam/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="
+ https://github.com/pysam-developers/pysam
+ https://pypi.org/project/pysam/"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=sci-libs/htslib-1.17"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=sci-biology/bcftools-1.17
+ >=sci-biology/samtools-1.17
+ )"
+
+distutils_enable_tests pytest
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+EPYTEST_DESELECT=(
+ # only work with bundled htslib
+ 'tests/tabix_test.py::TestRemoteFileHTTP'
+ 'tests/tabix_test.py::TestRemoteFileHTTPWithHeader'
+)
+
+python_prepare_all() {
+ # unbundle htslib
+ export HTSLIB_MODE="external"
+ export HTSLIB_INCLUDE_DIR="${ESYSROOT}"/usr/include
+ export HTSLIB_LIBRARY_DIR="${ESYSROOT}"/usr/$(get_libdir)
+ rm -r htslib || die
+
+ # prevent setup.py from adding RPATHs (except $ORIGIN)
+ sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
+ -i setup.py || die
+
+ if use test; then
+ einfo "Building test data"
+ emake -C tests/pysam_data
+ emake -C tests/cbcf_data
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # breaks with parallel build
+ # need to avoid dropping .so plugins into
+ # build-lib, which breaks tests
+ esetup.py build_ext --inplace -j1
+ distutils-r1_python_compile -j1
+}
diff --git a/sci-biology/samtools/Manifest b/sci-biology/samtools/Manifest
index 6bce14af3d22..32fbf34b8f3b 100644
--- a/sci-biology/samtools/Manifest
+++ b/sci-biology/samtools/Manifest
@@ -1,6 +1,8 @@
AUX samtools-0.1.20-buildsystem.patch 6737 BLAKE2B 71445f57735903bccc2720a32f42b27093f670e383d2d194b5692b1ba536e3df44204711cf4574b3933e5ce00605b661b1a36d79ca7f193ce36816271a3f8214 SHA512 ecb05971fbea4570ec161a165cb581b38ed727bb7e5b769862984bf035414cd564ab809882dc3272f8b192feeb86e29247d7327afa73ff668b01c03c58bb177d
DIST samtools-0.1.20.tar.gz 566387 BLAKE2B a62d74c408877754af50f5e5fea0e2289ec1e0c9f25013ed0d039bfe8ef61108600d917f8c9d356e98aca632795b4eb0f01ea1b54526a652577fb74a38a433c2 SHA512 15bd8cf401d14c1ab4faa591b6054f5ea9731c4e966f37f71d33d9081a270cfeb91e8a3d80c631e0725b49da81387f824c206e8c21553ad554d0cfc5c238a6e5
DIST samtools-1.16.1.tar.bz2 8217689 BLAKE2B 51ca62655d1f43dd0c6f9bd38b323b8a9d8f7486ce42496e21186da06ea881d94e096214720f3fb8d1dd12d7a23881bc3b25e27b1a845d56157ac7ffda7130c1 SHA512 f9d6b8652234c782a1b369f028073ad4a66c44e9620ae60f0ecb35e0874f04ca633713078b692fdc1a1cc4f884ebdbf3ecae6881f11fb3b4fd3d27c5b8da67ba
+DIST samtools-1.17.tar.bz2 8605080 BLAKE2B 09cb0bff7bf7113a77f57fdb879765b28b65461a574e4a1ab20ae2327af46e5616e04f03eb68706d42ba0643e887d7921974a3d78c5f87d296a4c3b691215260 SHA512 107a6df858c6bd2556ba4e86cc1922c3184df095f347039fa94bfd24e5ee21e1a4a9fba5a7cce248a06ad47f99978d9aae570efee7e30e165f33ea848a2cd3c3
EBUILD samtools-0.1.20-r4.ebuild 2049 BLAKE2B d377712eaca931258b37645e6a6b3cc379fdb550ef83a0c272a3eb564d7753185fea53416973e4fdf2c25b79475a81ae72b646ce22c570c934e4eabce8a9ded6 SHA512 c0d387f715ebf1f746ea4e4a7eab85a86ef0bff646c9a69639b17ef02e93c39982941d7eb811a6d67b0e635c9c4e05924d2b89a6809c3bd0592db91894dab4aa
EBUILD samtools-1.16.1.ebuild 926 BLAKE2B 7856fb586ff9b879e353784635eb27d190da7d1dc41a42f103cb1116ebde092b94e086779883bc916d5223632d217ea3f3d5468278d174122845a48be6df2d3d SHA512 b6711d8b955e466cdd79a2a4a92fa9f7f98aaa302901c97f1bab439f7cc407ff65726957627a8182068a7eb5f5556e680b52d9f2514f461e4e2f33ac3dc4dfa3
+EBUILD samtools-1.17.ebuild 926 BLAKE2B c2baac0d68599fadfc1825e2c0046c0596d50cedd15e6859bbfffbd3d735ae6dca2e873d835120da7be8a9c91ce17dd449010dfa956899de69c807da0cc60c7c SHA512 d43c9a9da338c0820f0237925895684077a2df428be3892f3433f050c3082d605a1edefdb265ded6f123eed491dc05578d4e46177eb79d7fdad3eebc710e3764
MISC metadata.xml 409 BLAKE2B c94eab9ebda4844beb471694106e353ccbbaca53e69de680301c6cfab3f3b6224ec94fcd631c9de2811d309463e5ee6decf2e443bfc68921f3362c6a312cd3af SHA512 fb2d3686e1ee70e4e80266a26603b3e52b680b1537a4569493a3a0511b93e2acdb2be3136df7ae54905a9f86fb7e53fa054607262751ebd8f54903f1905dad24
diff --git a/sci-biology/samtools/samtools-1.17.ebuild b/sci-biology/samtools/samtools-1.17.ebuild
new file mode 100644
index 000000000000..e105621c7865
--- /dev/null
+++ b/sci-biology/samtools/samtools-1.17.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-htslib=system \
+ CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw || die)"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}