summaryrefslogtreecommitdiff
path: root/sci-biology/mcl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /sci-biology/mcl/files
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'sci-biology/mcl/files')
-rw-r--r--sci-biology/mcl/files/mcl-14.137-fix-autotools.patch52
-rw-r--r--sci-biology/mcl/files/mcl-14.137-fix-declarations.patch (renamed from sci-biology/mcl/files/mcl-14.137-qa-implicit-declarations.patch)34
2 files changed, 82 insertions, 4 deletions
diff --git a/sci-biology/mcl/files/mcl-14.137-fix-autotools.patch b/sci-biology/mcl/files/mcl-14.137-fix-autotools.patch
new file mode 100644
index 000000000000..0d2c052a91b0
--- /dev/null
+++ b/sci-biology/mcl/files/mcl-14.137-fix-autotools.patch
@@ -0,0 +1,52 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -144,6 +144,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+ # Checks for libraries.
+ # FIXME: Replace `main' with a function in `-lm':
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -9,7 +9,6 @@
+ ## http://www.w3.org/People/Raggett/tidy/ , by Dave Raggett <dsr@w3.org>
+ TIDY = tidy
+
+-docdir = $(datadir)/doc/$(PACKAGE)
+
+ # mclfamily.html mclfamily.ps
+
+--- a/graphs/Makefile.am
++++ b/graphs/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+ ## $Id: Makefile.am,v 1.7 2007-01-29 11:35:37 flux Exp $
+
+-exampledir = $(datadir)/doc/$(PACKAGE)/examples
++exampledir = $(docdir)/examples
+
+ example_DATA = falkner.mci falkner2.mci falkner.coords make-falkner.pl \
+ proteins.mci matula.mci lattice.mci honey.mci seven.mci infinity.mci \
+--- a/img/Makefile.am
++++ b/img/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+ ## $Id: Makefile.am,v 1.7 2007-01-29 11:35:37 flux Exp $
+
+-exampledir = $(datadir)/doc/$(PACKAGE)/examples
++exampledir = $(docdir)/examples
+
+ example_DATA = fa_1024.png fa_400.png fa_600.png fa_large.png fa.ps falkner-bidi.ps falkner.ps small.ps small.png
+
+--- a/src/alien/oxygen/doc/Makefile.am
++++ b/src/alien/oxygen/doc/Makefile.am
+@@ -17,7 +17,6 @@
+ ## http://www.w3.org/People/Raggett/tidy/ , by Dave Raggett <dsr@w3.org>
+ TIDY = tidy
+
+-docdir = $(datadir)/doc/$(PACKAGE)
+
+ ## zoemtut.html is "on hold": do not install; zoem is not yet ready
+ ## for prime time
diff --git a/sci-biology/mcl/files/mcl-14.137-qa-implicit-declarations.patch b/sci-biology/mcl/files/mcl-14.137-fix-declarations.patch
index df4309874d48..4974d352bf7b 100644
--- a/sci-biology/mcl/files/mcl-14.137-qa-implicit-declarations.patch
+++ b/sci-biology/mcl/files/mcl-14.137-fix-declarations.patch
@@ -5,8 +5,34 @@ Fix QA issues related to implicit declarations.
* clmadjust.c:184:10: warning: implicit declaration of function ‘mcxFree’ [-Wimplicit-function-declaration]
* mcxi.c:42:16: warning: implicit declaration of function ‘isatty’ [-Wimplicit-function-declaration]
---- mcl-14-137/src/shcl/clmadjust.c
-+++ mcl-14-137/src/shcl/clmadjust.c
+--- a/src/impala/iface.h
++++ b/src/impala/iface.h
+@@ -16,15 +16,15 @@
+
+ /* This file currently provides nothing */
+
+-dim nu_meet_can ;
+-dim nu_meet_sl ;
+-dim nu_meet_zip ;
+-dim nu_diff_can ;
+-dim nu_diff_sl ;
+-dim nu_diff_zip ;
+-double nu_magic ;
++extern dim nu_meet_can ;
++extern dim nu_meet_sl ;
++extern dim nu_meet_zip ;
++extern dim nu_diff_can ;
++extern dim nu_diff_sl ;
++extern dim nu_diff_zip ;
++extern double nu_magic ;
+
+-dim mclx_n_thread_g ;
++extern dim mclx_n_thread_g ;
+
+ #endif
+
+--- a/src/shcl/clmadjust.c
++++ b/src/shcl/clmadjust.c
@@ -14,6 +14,7 @@
#include "report.h"
#include "clmadjust.h"
@@ -15,8 +41,8 @@ Fix QA issues related to implicit declarations.
#include "util/io.h"
#include "util/types.h"
#include "util/err.h"
---- mcl-14-137/src/shmcx/mcxi.c
-+++ mcl-14-137/src/shmcx/mcxi.c
+--- a/src/shmcx/mcxi.c
++++ b/src/shmcx/mcxi.c
@@ -8,6 +8,7 @@
*/