summaryrefslogtreecommitdiff
path: root/sci-biology/clustalx/clustalx-2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/clustalx/clustalx-2.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/clustalx/clustalx-2.1-r1.ebuild')
-rw-r--r--sci-biology/clustalx/clustalx-2.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/clustalx/clustalx-2.1-r1.ebuild b/sci-biology/clustalx/clustalx-2.1-r1.ebuild
new file mode 100644
index 000000000000..1d3ce97d942d
--- /dev/null
+++ b/sci-biology/clustalx/clustalx-2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Graphical interface for the ClustalW multiple alignment program"
+HOMEPAGE="http://www.ebi.ac.uk/tools/clustalw2/"
+SRC_URI="http://www.clustal.org/download/current/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ >=sci-biology/clustalw-${PV}"
+
+src_prepare() {
+ sed \
+ -e "s|colprot.xml|${EPREFIX}/usr/share/${PN}/colprot.xml|" \
+ -e "s|coldna.xml|${EPREFIX}/usr/share/${PN}/coldna.xml|" \
+ -e "s|colprint.xml|${EPREFIX}/usr/share/${PN}/colprint.xml|" \
+ -i ClustalQtParams.h || \
+ die "Failed to patch shared files location."
+ sed \
+ -e "s|clustalx.hlp|${EPREFIX}/usr/share/${PN}/clustalx.hlp|" \
+ -i HelpDisplayWidget.cpp || \
+ die "Failed to patch help file location."
+ rm -rf usr || die
+}
+
+src_install() {
+ dobin clustalx
+ insinto /usr/share/${PN}
+ doins colprot.xml coldna.xml colprint.xml clustalx.hlp
+ make_desktop_entry ${PN} ClustalX
+}