summaryrefslogtreecommitdiff
path: root/sci-astronomy/gnuastro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-astronomy/gnuastro
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-astronomy/gnuastro')
-rw-r--r--sci-astronomy/gnuastro/Manifest3
-rw-r--r--sci-astronomy/gnuastro/gnuastro-0.3.ebuild49
-rw-r--r--sci-astronomy/gnuastro/metadata.xml20
3 files changed, 72 insertions, 0 deletions
diff --git a/sci-astronomy/gnuastro/Manifest b/sci-astronomy/gnuastro/Manifest
new file mode 100644
index 000000000000..1154f1b7ea2b
--- /dev/null
+++ b/sci-astronomy/gnuastro/Manifest
@@ -0,0 +1,3 @@
+DIST gnuastro-0.3.tar.gz 4525361 SHA256 8a5bc2f977d4839f820d7423d10a6b94391a9571df97a64b9feb99a117973d81 SHA512 08556fd0de196c331cfd68e4b385fbef5c130fa9c914889367f4e3637b8dc6270a2424ef92c6641ec803c355d0577cebf3ace5ad76a7024f0414bb516338beac WHIRLPOOL 1fea9c239f896be1b931a2c7ab64041e9cdaeba95b24c76058169a7337d3c4a360b86e1d11747fe74b3af8122ed8eea719ee4db2f5601d72b67c3421ed4f1e7a
+EBUILD gnuastro-0.3.ebuild 929 SHA256 5b1ee66b8e74332f6f5f06f72ba62712be57af7df1a9dccabb183a976629cd6b SHA512 4d3e3f27c4c11e55002236a5fa708b63638bad3b47e553b49e5f140eacf443ff71e0b455276a5f413fab463aa4d4a263e860e040276f52aee6dac24a81cbabff WHIRLPOOL 0eabd00f9a06cbf10c4cd676b9cf7a5946ef0bef24595a6300fe9da379d79ec28dd4fa5243c10faac9f7fff02ff7dfa6959e90c012f0f0b70353c2aeb3f59878
+MISC metadata.xml 988 SHA256 4ffb2c1a3f5cd3327f2f08faa015e79b96534e91c682d2661c8eba93ead91ef5 SHA512 208e0ea993adb14966523de6b012b6c2a97c6373e9a7bf03039dd50d32b03cd07a1a5da5196081a18b39b93d7d7d5d078b283a949b8b258f3f966cc2df00d00f WHIRLPOOL 1677ebc48324fde1b96eae76a46cc29a798c9ed848b40f231fd48cf053be6c19daca08b8e4c12da3650e8d99a3eae182f0c38c8b25b526ffb759bb8559469eb0
diff --git a/sci-astronomy/gnuastro/gnuastro-0.3.ebuild b/sci-astronomy/gnuastro/gnuastro-0.3.ebuild
new file mode 100644
index 000000000000..54ffe177332a
--- /dev/null
+++ b/sci-astronomy/gnuastro/gnuastro-0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="GNU Astronomy Utilities"
+HOMEPAGE="https://www.gnu.org/software/gnuastro"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs threads"
+
+# jpeg, pdf, and libgit2 are forced deps
+# because they are automagically detected.
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ dev-libs/libgit2:=
+ sci-astronomy/wcslib:0=
+ sci-libs/cfitsio:0=
+ sci-libs/gsl:0=
+ virtual/jpeg:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e 's/-O3//' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-bin-op-alltypes
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ )
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+}
diff --git a/sci-astronomy/gnuastro/metadata.xml b/sci-astronomy/gnuastro/metadata.xml
new file mode 100644
index 000000000000..c91cdd639148
--- /dev/null
+++ b/sci-astronomy/gnuastro/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The GNU Astronomy Utilities (Gnuastro) is an official GNU package
+ consisting of various programs and library functions for the
+ manipulation and analysis of astronomical data. All the programs
+ share the same basic command-line user interface for the comfort
+ of both the users and developers. Gnuastro is written to comply
+ fully with the GNU coding standards so it integrates finely with
+ the GNU/Linux operating system. This also enables astronomers to
+ expect a fully familiar experience in the source code, building,
+ installing and command-line user interaction that they have seen
+ in all the other GNU software that they use.
+ </longdescription>
+</pkgmetadata>