summaryrefslogtreecommitdiff
path: root/sci-astronomy/funtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-astronomy/funtools
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-astronomy/funtools')
-rw-r--r--sci-astronomy/funtools/Manifest5
-rw-r--r--sci-astronomy/funtools/funtools-1.4.7.ebuild71
-rw-r--r--sci-astronomy/funtools/metadata.xml18
3 files changed, 94 insertions, 0 deletions
diff --git a/sci-astronomy/funtools/Manifest b/sci-astronomy/funtools/Manifest
new file mode 100644
index 000000000000..5d4d04eb1a5c
--- /dev/null
+++ b/sci-astronomy/funtools/Manifest
@@ -0,0 +1,5 @@
+DIST funtools-1.4.7.tar.gz 3270079 SHA256 5388a7475e8c1fa92ff2429bf5de64212e79701dda6d24663bdab60293b63132 SHA512 d53bdb00a2eb9cd70bf60e34a10e5e16435a10b96f89cd55f0ffb686fac30438e2dfc1d823578286be51bee5caf0dcd1c0f257cd8e725cf8e5aa798a6f3c245a WHIRLPOOL e2928f6b193fea9509b7aaebff27ae1b5e48cf1005c4ddf1044d00dc62905ee3f8c5beacb8823ec0cc2c0c48becfff25fdbd2d2e8c1f7e99c95cc1e836a67a22
+EBUILD funtools-1.4.7.ebuild 1849 SHA256 f0d39e567b84184883e0e44d686e3780b098d55c674ebfc42de0a8eae60a1e56 SHA512 0b9f0dd6f35bad3e6e7dbd4ea9e386b26f65f5773785f594a965d5cf79a0871b66f10b640ecd15bae250410f78f64fb71cfb950011981a6f9d7a80b2e251cdb0 WHIRLPOOL 3ed125d336222b93fe2741497e16bd9c0efad1858f2aec7f82ae2d75eb1e22a2449f2652224440313b5caa48029f99683f32befe3094058ab041115d432c5732
+MISC ChangeLog 3253 SHA256 bb9fc00b1ac3d834973c6fb948f30c0309d680a44473bac12c4d5734c03e981b SHA512 a3b1017e734047ec4d8108c159df78f0504ec348ac8838374c1760c876defcce0abacf1230771765bddcf64a226bcd6f9f6546cf6cc9c3f1d726553a8384375f WHIRLPOOL d5c45ea1eeef8eb9d0f6263eb8848a0f976775c7f9c77dafb6d87b4bbf9ab3f5f8ed30ddd8cc78fda1fab949b5d2ed6273c102febeaa3abf825d2ff2fd9895d2
+MISC ChangeLog-2015 2490 SHA256 e92bc17ebe44a285f3cb5c8a75359cdaf021ae152fd9a30b2bf7ee5d76dd7bc6 SHA512 16a0735c3e521b27ebe0457042d1bef2bc9543955dd52403d225a9c80244a56041a384bb549e53febfecccf3aec5b2e9c208cc7f9d3f8d630d3ca1a3a665d6bd WHIRLPOOL 56e5877c50fb9ed82707cb115e89bbeca33f50e12d6a28dba18aae6e26634e78562e813731fb96b811fa4f57e98c53128c8326a38e2ea59db6bcf6ab5ca65d66
+MISC metadata.xml 729 SHA256 e20147ae5c75751d71a5241f4631885240c14e0210c91a38a95676174490edd7 SHA512 fd8156acb3dbfdd6c3d2120f70eba4c5d06d09d8dd4cafcb26ff6c1ea520ae51e9e1ee5fdefc4a7a03aee62b8bb521f37cabb781159121f3197cb44c4755fb35 WHIRLPOOL 87c7f9a7bc6dc2b9b0931bd03f3b48f4562173d8fdd4ddc331a9fa4394c7718b7175216f7368fdf18661257920f391e5ab8eecb8d230742cee0c2887f1ebff86
diff --git a/sci-astronomy/funtools/funtools-1.4.7.ebuild b/sci-astronomy/funtools/funtools-1.4.7.ebuild
new file mode 100644
index 000000000000..a9b6e77aa319
--- /dev/null
+++ b/sci-astronomy/funtools/funtools-1.4.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs autotools
+
+DESCRIPTION="FITS library and utlities for astronomical images"
+HOMEPAGE="https://github.com/ericmandel/funtools"
+SRC_URI="https://github.com/ericmandel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ sci-astronomy/wcstools:0=
+ sci-visualization/gnuplot
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ # respect libdir, dont build wcs, respect toolchain
+ sed -e "/INSTALL/s|/lib|/$(get_libdir)|g" \
+ -e 's|${OBJS}|$(OBJS)|g' \
+ -e '/^SUBLIBS/s|wcs||g' \
+ -e 's/mkdir/mkdir -p/g' \
+ -e '/mklib/s|-o $(PACKAGE)|-o $(PACKAGE) $(LIBS)|g' \
+ -e "s| ar| $(tc-getAR)|g" \
+ -e "s|ar cruv|$(tc-getAR) cruv|g" \
+ -e "s|WCS_INC.*=.*|WCS_INC = $($(tc-getPKG_CONFIG) --cflags wcstools)|g" \
+ -i Makefile.in */Makefile.in || die
+ # fix race condition (when ccache is on)
+ sed -e 's|$(LIB):|$(LIB): FORCE|g' \
+ -e '$aFORCE:' \
+ -i */Makefile.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --exec-prefix="${EPREFIX}/usr" \
+ --enable-shared \
+ --enable-dl \
+ --with-wcslib="$($(tc-getPKG_CONFIG) --libs wcstools)" \
+ --with-zlib="$($(tc-getPKG_CONFIG) --libs zlib)" \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_compile() {
+ emake
+ emake shtclfun
+}
+
+src_install () {
+ default
+ # install missing includes
+ insinto /usr/include/funtools/fitsy
+ doins fitsy/*.h
+ # fix bug #536630
+ mv "${ED}"/usr/share/man/man3/funopen.3 \
+ "${ED}"/usr/share/man/man7/funopen.7 \
+ || die
+ use doc && dodoc doc/*.pdf doc/*html doc/*c \
+ && docompress -x /usr/share/doc/${PF}/*.c
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+}
diff --git a/sci-astronomy/funtools/metadata.xml b/sci-astronomy/funtools/metadata.xml
new file mode 100644
index 000000000000..2d6b93e428d3
--- /dev/null
+++ b/sci-astronomy/funtools/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Funtools, is a minimal buy-in FITS library and utility package from
+ the SAO/HEAD. The Funtools library provides simplified
+ access to FITS images and binary tables, as well as to raw array and binary
+ event lists. The Funtools utilities provide high-level support for
+ processing astronomical data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ericmandel/funtools</remote-id>
+ </upstream>
+</pkgmetadata>