summaryrefslogtreecommitdiff
path: root/ros-meta/ros_control/ros_control-0.19.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /ros-meta/ros_control/ros_control-0.19.5.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'ros-meta/ros_control/ros_control-0.19.5.ebuild')
-rw-r--r--ros-meta/ros_control/ros_control-0.19.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/ros-meta/ros_control/ros_control-0.19.5.ebuild b/ros-meta/ros_control/ros_control-0.19.5.ebuild
new file mode 100644
index 000000000000..aad4ab131863
--- /dev/null
+++ b/ros-meta/ros_control/ros_control-0.19.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Controller interfaces, managers, transmissions, control_toolbox"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/combined_robot_hw
+ dev-ros/combined_robot_hw_tests
+ dev-ros/controller_interface
+ dev-ros/controller_manager
+ dev-ros/controller_manager_msgs
+ dev-ros/controller_manager_tests
+ dev-ros/hardware_interface
+ dev-ros/joint_limits_interface
+ dev-ros/rqt_controller_manager
+ dev-ros/transmission_interface
+"
+DEPEND="${RDEPEND}"