summaryrefslogtreecommitdiff
path: root/ros-meta/desktop/desktop-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /ros-meta/desktop/desktop-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'ros-meta/desktop/desktop-9999.ebuild')
-rw-r--r--ros-meta/desktop/desktop-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/ros-meta/desktop/desktop-9999.ebuild b/ros-meta/desktop/desktop-9999.ebuild
new file mode 100644
index 000000000000..57ee10fc02b5
--- /dev/null
+++ b/ros-meta/desktop/desktop-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for a basic ROS desktop install"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/robot
+ ros-meta/viz
+ dev-ros/roslint
+ ros-meta/visualization_tutorials
+"
+DEPEND="${RDEPEND}"