summaryrefslogtreecommitdiff
path: root/ros-meta/desktop/desktop-1.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
commit616579b5d773c50af31ee56f00105d96ce641ca2 (patch)
tree2ad4d3ba1429bd93a36ab99a2f5ec3490412115e /ros-meta/desktop/desktop-1.5.0-r1.ebuild
parent068424b26532f3551a81421a9be67ed206e5c11a (diff)
gentoo resync : 14.08.2021
Diffstat (limited to 'ros-meta/desktop/desktop-1.5.0-r1.ebuild')
-rw-r--r--ros-meta/desktop/desktop-1.5.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/ros-meta/desktop/desktop-1.5.0-r1.ebuild b/ros-meta/desktop/desktop-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..66b8115a2786
--- /dev/null
+++ b/ros-meta/desktop/desktop-1.5.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for a basic ROS desktop install"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/robot
+ ros-meta/viz
+ dev-ros/angles:0
+ ros-meta/common_tutorials
+ ros-meta/geometry_tutorials
+ dev-ros/joint_state_publisher_gui
+ ros-meta/ros_tutorials
+ dev-ros/roslint
+ dev-ros/urdf_tutorial
+ ros-meta/visualization_tutorials
+"
+DEPEND="${RDEPEND}"