summaryrefslogtreecommitdiff
path: root/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
commit4645b6f17f0da81e9fe84081fb126a37102ba153 (patch)
treee6c48cf3db2213af38cf528a5364fffd5c74c6d6 /net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild
parentebce8994fe3cc4ca9fbc96ca837cb4c4e98adcbd (diff)
gentoo resync : 08.05.2018
Diffstat (limited to 'net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild')
-rw-r--r--net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild b/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild
new file mode 100644
index 000000000000..8125eb474ee7
--- /dev/null
+++ b/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils linux-info udev
+
+DESCRIPTION="turns FL2000-based USB 3.0 to VGA adapters into low cost DACs"
+
+HOMEPAGE="https://osmocom.org/projects/osmo-fl2k/wiki"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.osmocom.org/osmo-fl2k"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+IUSE="udev"
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}
+ media-sound/sox
+ sys-apps/pv"
+
+# continguous memory allocator can optionally be used for zero-copy transfer
+# TODO: tell users to set CONFIG_CMA_SIZE_MBYTES or boot with cma=... parameter
+CONFIG_CHECK="~CMA ~DMA_CMA"
+
+src_configure() {
+ # udev rules use wrong filename and would go to wrong directory anyway
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="/usr/$(get_libdir)"
+ -DINSTALL_UDEV_RULES=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use udev; then
+ udev_newrules ${PN}.rules 99-${PN}.rules
+ fi
+ cmake-utils_src_install
+}