summaryrefslogtreecommitdiff
path: root/net-wireless/osmo-fl2k
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
commit4645b6f17f0da81e9fe84081fb126a37102ba153 (patch)
treee6c48cf3db2213af38cf528a5364fffd5c74c6d6 /net-wireless/osmo-fl2k
parentebce8994fe3cc4ca9fbc96ca837cb4c4e98adcbd (diff)
gentoo resync : 08.05.2018
Diffstat (limited to 'net-wireless/osmo-fl2k')
-rw-r--r--net-wireless/osmo-fl2k/Manifest4
-rw-r--r--net-wireless/osmo-fl2k/metadata.xml8
-rw-r--r--net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild48
-rw-r--r--net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild48
4 files changed, 108 insertions, 0 deletions
diff --git a/net-wireless/osmo-fl2k/Manifest b/net-wireless/osmo-fl2k/Manifest
new file mode 100644
index 000000000000..21eefcb3054f
--- /dev/null
+++ b/net-wireless/osmo-fl2k/Manifest
@@ -0,0 +1,4 @@
+DIST osmo-fl2k-0.1.1.tar.xz 59196 BLAKE2B 031b9bdf7f03f3e9c3bcb158bf5695b3771381d5cbabb94853580c57cf8a7bafcacba6168815b6ff46d6fb4e463ea6caff0e1d289692510801409d8b4cf28b72 SHA512 fb19c34919956970106fe7a69632e691f01caef3a1bc212501304f9d910dd08389f95b8d031b3336d009afc08744d846ea3bc349e1d9446bbfd13e11ec95ceff
+EBUILD osmo-fl2k-0.1.1.ebuild 1076 BLAKE2B 4ea025abae89747ec298edead411de981d76f3c2221b47af56a335474dd9d559b9d466d313545ac3b7d09b01cc6972a779a5638a01c95e8c7dca9c0f1bd25a87 SHA512 706599597c1f99901b52dc9939823835f419d300275af0761cbbf17519e651b511a523b45b76a197639887c1d753f7d861924ebda214a600d0790f6381a9c862
+EBUILD osmo-fl2k-9999.ebuild 1076 BLAKE2B 4ea025abae89747ec298edead411de981d76f3c2221b47af56a335474dd9d559b9d466d313545ac3b7d09b01cc6972a779a5638a01c95e8c7dca9c0f1bd25a87 SHA512 706599597c1f99901b52dc9939823835f419d300275af0761cbbf17519e651b511a523b45b76a197639887c1d753f7d861924ebda214a600d0790f6381a9c862
+MISC metadata.xml 238 BLAKE2B 34ac0d15fbd529b95d6a8c5656482832843c35f4befaa7bb238eec7634acb09a074de43cbd4d4c0a57d3b2810901bc85c7d2780beee573cd72c37b6244d78dc8 SHA512 b8e525ce325eb8201273f8d0ea320d6ba41a183d7f80b0f44dcca44c48049baec1c3489ebd32a17d3be9d6a31a9427ce40cd1686f12e42ca99b0d7037af9532f
diff --git a/net-wireless/osmo-fl2k/metadata.xml b/net-wireless/osmo-fl2k/metadata.xml
new file mode 100644
index 000000000000..1570f891c6a3
--- /dev/null
+++ b/net-wireless/osmo-fl2k/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>radio@gentoo.org</email>
+ <name>Radio</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild b/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild
new file mode 100644
index 000000000000..8125eb474ee7
--- /dev/null
+++ b/net-wireless/osmo-fl2k/osmo-fl2k-0.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils linux-info udev
+
+DESCRIPTION="turns FL2000-based USB 3.0 to VGA adapters into low cost DACs"
+
+HOMEPAGE="https://osmocom.org/projects/osmo-fl2k/wiki"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.osmocom.org/osmo-fl2k"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+IUSE="udev"
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}
+ media-sound/sox
+ sys-apps/pv"
+
+# continguous memory allocator can optionally be used for zero-copy transfer
+# TODO: tell users to set CONFIG_CMA_SIZE_MBYTES or boot with cma=... parameter
+CONFIG_CHECK="~CMA ~DMA_CMA"
+
+src_configure() {
+ # udev rules use wrong filename and would go to wrong directory anyway
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="/usr/$(get_libdir)"
+ -DINSTALL_UDEV_RULES=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use udev; then
+ udev_newrules ${PN}.rules 99-${PN}.rules
+ fi
+ cmake-utils_src_install
+}
diff --git a/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild b/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
new file mode 100644
index 000000000000..8125eb474ee7
--- /dev/null
+++ b/net-wireless/osmo-fl2k/osmo-fl2k-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils linux-info udev
+
+DESCRIPTION="turns FL2000-based USB 3.0 to VGA adapters into low cost DACs"
+
+HOMEPAGE="https://osmocom.org/projects/osmo-fl2k/wiki"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.osmocom.org/osmo-fl2k"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+IUSE="udev"
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}
+ media-sound/sox
+ sys-apps/pv"
+
+# continguous memory allocator can optionally be used for zero-copy transfer
+# TODO: tell users to set CONFIG_CMA_SIZE_MBYTES or boot with cma=... parameter
+CONFIG_CHECK="~CMA ~DMA_CMA"
+
+src_configure() {
+ # udev rules use wrong filename and would go to wrong directory anyway
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="/usr/$(get_libdir)"
+ -DINSTALL_UDEV_RULES=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use udev; then
+ udev_newrules ${PN}.rules 99-${PN}.rules
+ fi
+ cmake-utils_src_install
+}