summaryrefslogtreecommitdiff
path: root/net-misc/unix2tcp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-28 09:11:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-28 09:11:58 +0100
commitc50fa1b9d54c15707ec744b80db6610da7dd7832 (patch)
tree32b63837ee84220100640b5b035b0f8f94405b88 /net-misc/unix2tcp
parent1bc9c3b9d5a8c51b67f6ea2f57bdd76ff5073097 (diff)
gentoo auto-resync : 28:09:2022 - 09:11:58
Diffstat (limited to 'net-misc/unix2tcp')
-rw-r--r--net-misc/unix2tcp/Manifest3
-rw-r--r--net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch19
-rw-r--r--net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild22
3 files changed, 38 insertions, 6 deletions
diff --git a/net-misc/unix2tcp/Manifest b/net-misc/unix2tcp/Manifest
index d9b14bfefa5a..3309ff2114da 100644
--- a/net-misc/unix2tcp/Manifest
+++ b/net-misc/unix2tcp/Manifest
@@ -1,3 +1,4 @@
+AUX unix2tcp-0.8.2-clang16.patch 369 BLAKE2B 2749da2319f9264277648e219b8ffbab5aa73e8d8a025987e624c11ff291be8e05f9be4c952f01563c778c2fe7ebd54e83682e5d332ae5e8530571eb5b39872e SHA512 d98621c6c9830270976e38168f7d5684dd7b8b763a2970a80bd5ad7e9b7b949487319bc62f4c55c1ca8d40881346dc44686045a5a88d1f13569bb108770bb6bd
DIST unix2tcp-0.8.2.tar.bz2 29636 BLAKE2B 37b67cdac5d2db9fbf5dd2fc4277213796727c66ca1c2ececf8545017f1475e6e61454146bb04a1c72adaef5408e2ac873604f21fcdc090b2b1cad4f454ee8f7 SHA512 0f46895b1693065b592915574142c6475d79701c2f2eca70cfb40603849af9bdb6be939119fcca1d50d069ace940da691cf554a33eb2ac357194cf729b2c7a20
-EBUILD unix2tcp-0.8.2-r1.ebuild 400 BLAKE2B 6d0010480ef952e7a7c8611f510389b5134e08a0aee6cfce1495acd1e2181b47baf7e5f2c3df9567cbb763d334876442731ebecefc37a31dee2b96161d993717 SHA512 6d94755ba043811751e6ed3e7c5cdd81fbb775911f9a1ab42d94b4f515e1b1f8c6e3167633e05f3d7b3b8be9c8afdf99b8ee1e5020d1d8c2a88986df5ede2ee1
+EBUILD unix2tcp-0.8.2-r1.ebuild 500 BLAKE2B 9a447419fc2bc7d744599b99e3ced04c1cbfda5264e0fbaf5bd1849faa269d5ef2ca65f42002372cd8ef5d0c91752cd7936d15b28bf75950350b6bdbbe627dbb SHA512 fce1585ea2cac215a260c825316087337008105a21ce070e52fa799dc22941e00dfe54ed2e745db7a72ec77838fbe25b64ca973934175432cf0e5b15df5b8b50
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch b/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch
new file mode 100644
index 000000000000..a67cc13acb26
--- /dev/null
+++ b/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/870457
+--- a/server.c
++++ b/server.c
+@@ -61,2 +61,3 @@
+ #include "list.h"
++#include "mylog.h"
+ #include "unix2tcp.h"
+--- a/unix2tcp.c
++++ b/unix2tcp.c
+@@ -62,2 +62,3 @@
+ #include "list.h"
++#include "mylog.h"
+ #include "server.h"
+--- a/utelnet.c
++++ b/utelnet.c
+@@ -23,2 +23,3 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #ifdef HAVE_SYS_TYPES_H
diff --git a/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild b/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
index 5c2afd689c0c..d35532343648 100644
--- a/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
+++ b/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
@@ -1,14 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-DESCRIPTION="a connection forwarder that converts Unix sockets into TCP sockets"
-HOMEPAGE="http://gnu.gds.tuwien.ac.at/directory/all/unix2tcp.html"
+inherit autotools
+
+DESCRIPTION="Connection forwarder that converts Unix sockets into TCP sockets"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 arm ~hppa ~ia64 ppc ~s390 x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
DOCS=( ChangeLog README )
+
+src_prepare() {
+ default
+
+ eautoreconf #870457
+}