summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-28 09:11:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-28 09:11:58 +0100
commitc50fa1b9d54c15707ec744b80db6610da7dd7832 (patch)
tree32b63837ee84220100640b5b035b0f8f94405b88 /net-misc
parent1bc9c3b9d5a8c51b67f6ea2f57bdd76ff5073097 (diff)
gentoo auto-resync : 28:09:2022 - 09:11:58
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/Manifest.gzbin55215 -> 55226 bytes
-rw-r--r--net-misc/hashcash/Manifest3
-rw-r--r--net-misc/hashcash/files/hashcash-1.22-clang16.patch11
-rw-r--r--net-misc/hashcash/hashcash-1.22-r2.ebuild14
-rw-r--r--net-misc/unix2tcp/Manifest3
-rw-r--r--net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch19
-rw-r--r--net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild22
7 files changed, 63 insertions, 9 deletions
diff --git a/net-misc/Manifest.gz b/net-misc/Manifest.gz
index 2570c176a7c6..df12f69ed80f 100644
--- a/net-misc/Manifest.gz
+++ b/net-misc/Manifest.gz
Binary files differ
diff --git a/net-misc/hashcash/Manifest b/net-misc/hashcash/Manifest
index f00fd6a2ffa1..996af5415288 100644
--- a/net-misc/hashcash/Manifest
+++ b/net-misc/hashcash/Manifest
@@ -1,3 +1,4 @@
+AUX hashcash-1.22-clang16.patch 259 BLAKE2B c4f97047d7cfc3f94dab0df491b843d4263816471e126356c8b2dc7a7273e7cd958f6eca6ed07a96e2ee8769579f293cf496a9b8a9950d12878b2e760ce57cbe SHA512 b8a71f64ed6e611543619bc6c1e4e195e24c4462a748dbce1cb600d99d94c6079475b091f40be307293b39185f74d84a1bbf277391840c0b17418254acedaf4e
DIST hashcash-1.22.tgz 195193 BLAKE2B 2944dd8a852720af7deff1a85cbfc07e828bf2242996b95d8d05a3a8a3ece90abc47483252920ec14b603978aae2ddb9e770ef7b52904b3d24320b68e6695b37 SHA512 b803c27df2acdce70c587d15d4158ca8841328fd89d90213a00be35f7c9f1905db728a785ee70fa43a4262dabe20c3f0a9fff381e3db0d44c3175ca22da5d5c2
-EBUILD hashcash-1.22-r2.ebuild 670 BLAKE2B f6b042f0c1367fa7f5b0b1cca7deb08d28ac09ac7dc560424912f84e7034d212f2f7d9d842315f39795e3c5abc858c683a991ecd97cd190a2f90215b4a3ba61c SHA512 3bec3f7e0f646ae7d40deb894e6c0e137e2403d3f5e1d2b681af2058b94382d20a1152a9e4ffed00e6ff4eefebb4209a1ad76a19d8d468eba160d99b84e400db
+EBUILD hashcash-1.22-r2.ebuild 722 BLAKE2B 69e464afa7bb7651b2a6e7475d0ddc860a4e4ab7c1544f24acc96c8c7fea42e3d4ef64db87d6449de4eff1e9400f28af25f797b7a8b566fd6149bf264bd4f4de SHA512 a8dfdf3eb3baeb6860e7d489c118c2be6324005bd990c091622ac4a76017253c254e216756c9d1ce2696eb6201579eccca49ddc8e1d22e456c5af04f5a801287
MISC metadata.xml 169 BLAKE2B 25149b73446be31f3ea3dd3a6394230987e7d4c601d1605fd3827b37bd99b3301c2e0edb95d0f59a4577ed27919f43c2cc02b1edf62c4012b935a82e709e0c05 SHA512 55c53f74b001bae56ba8c54581a4168335b6b3a28dac23a2102b76795d5fd41de33b8b3e1ec03f9acc6e7a3a77e93b1a6ff3e3967c3156dcbf22b5b5a6245ef5
diff --git a/net-misc/hashcash/files/hashcash-1.22-clang16.patch b/net-misc/hashcash/files/hashcash-1.22-clang16.patch
new file mode 100644
index 000000000000..1ec15b110555
--- /dev/null
+++ b/net-misc/hashcash/files/hashcash-1.22-clang16.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/870466
+--- a/sha1.h
++++ b/sha1.h
+@@ -59,4 +59,7 @@
+ void SHA1_Init_With_IV( SHA1_ctx*, const byte[ SHA1_DIGEST_BYTES ] );
+
++void SHA1_Transform( word32 H[ SHA1_DIGEST_WORDS ],
++ const byte M[ SHA1_INPUT_BYTES ] );
++
+ #endif
+
diff --git a/net-misc/hashcash/hashcash-1.22-r2.ebuild b/net-misc/hashcash/hashcash-1.22-r2.ebuild
index 867929119c5a..c52b23016a1b 100644
--- a/net-misc/hashcash/hashcash-1.22-r2.ebuild
+++ b/net-misc/hashcash/hashcash-1.22-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -13,20 +13,30 @@ LICENSE="CPL-1.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
src_prepare() {
default
+
sed -i -e "/COPT_GENERIC = -O3/d" Makefile || die
}
src_compile() {
- emake CC="$(tc-getCC)" generic
+ tc-export AR CC
+
+ emake generic
}
src_install() {
dobin hashcash
doman hashcash.1
+
dodoc CHANGELOG
+
docinto examples
dodoc contrib/hashcash-{request,sendmail{,.txt}} contrib/hashfork.{c,py,txt}
+
docompress -x /usr/share/doc/${PF}/examples
}
diff --git a/net-misc/unix2tcp/Manifest b/net-misc/unix2tcp/Manifest
index d9b14bfefa5a..3309ff2114da 100644
--- a/net-misc/unix2tcp/Manifest
+++ b/net-misc/unix2tcp/Manifest
@@ -1,3 +1,4 @@
+AUX unix2tcp-0.8.2-clang16.patch 369 BLAKE2B 2749da2319f9264277648e219b8ffbab5aa73e8d8a025987e624c11ff291be8e05f9be4c952f01563c778c2fe7ebd54e83682e5d332ae5e8530571eb5b39872e SHA512 d98621c6c9830270976e38168f7d5684dd7b8b763a2970a80bd5ad7e9b7b949487319bc62f4c55c1ca8d40881346dc44686045a5a88d1f13569bb108770bb6bd
DIST unix2tcp-0.8.2.tar.bz2 29636 BLAKE2B 37b67cdac5d2db9fbf5dd2fc4277213796727c66ca1c2ececf8545017f1475e6e61454146bb04a1c72adaef5408e2ac873604f21fcdc090b2b1cad4f454ee8f7 SHA512 0f46895b1693065b592915574142c6475d79701c2f2eca70cfb40603849af9bdb6be939119fcca1d50d069ace940da691cf554a33eb2ac357194cf729b2c7a20
-EBUILD unix2tcp-0.8.2-r1.ebuild 400 BLAKE2B 6d0010480ef952e7a7c8611f510389b5134e08a0aee6cfce1495acd1e2181b47baf7e5f2c3df9567cbb763d334876442731ebecefc37a31dee2b96161d993717 SHA512 6d94755ba043811751e6ed3e7c5cdd81fbb775911f9a1ab42d94b4f515e1b1f8c6e3167633e05f3d7b3b8be9c8afdf99b8ee1e5020d1d8c2a88986df5ede2ee1
+EBUILD unix2tcp-0.8.2-r1.ebuild 500 BLAKE2B 9a447419fc2bc7d744599b99e3ced04c1cbfda5264e0fbaf5bd1849faa269d5ef2ca65f42002372cd8ef5d0c91752cd7936d15b28bf75950350b6bdbbe627dbb SHA512 fce1585ea2cac215a260c825316087337008105a21ce070e52fa799dc22941e00dfe54ed2e745db7a72ec77838fbe25b64ca973934175432cf0e5b15df5b8b50
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch b/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch
new file mode 100644
index 000000000000..a67cc13acb26
--- /dev/null
+++ b/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/870457
+--- a/server.c
++++ b/server.c
+@@ -61,2 +61,3 @@
+ #include "list.h"
++#include "mylog.h"
+ #include "unix2tcp.h"
+--- a/unix2tcp.c
++++ b/unix2tcp.c
+@@ -62,2 +62,3 @@
+ #include "list.h"
++#include "mylog.h"
+ #include "server.h"
+--- a/utelnet.c
++++ b/utelnet.c
+@@ -23,2 +23,3 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #ifdef HAVE_SYS_TYPES_H
diff --git a/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild b/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
index 5c2afd689c0c..d35532343648 100644
--- a/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
+++ b/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
@@ -1,14 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-DESCRIPTION="a connection forwarder that converts Unix sockets into TCP sockets"
-HOMEPAGE="http://gnu.gds.tuwien.ac.at/directory/all/unix2tcp.html"
+inherit autotools
+
+DESCRIPTION="Connection forwarder that converts Unix sockets into TCP sockets"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 arm ~hppa ~ia64 ppc ~s390 x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
DOCS=( ChangeLog README )
+
+src_prepare() {
+ default
+
+ eautoreconf #870457
+}