summaryrefslogtreecommitdiff
path: root/net-misc/streamlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-24 02:54:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-24 02:54:28 +0100
commit2995a1ea3e0d9c72087365b0278eb7b5f7a509fd (patch)
treee640a2eca99555fab882bc502927e624ec2c0758 /net-misc/streamlink
parent3018b5a4bd4777c51e2793818305d7af2409a7fd (diff)
gentoo auto-resync : 24:07:2023 - 02:54:28
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest4
-rw-r--r--net-misc/streamlink/streamlink-6.0.0.ebuild61
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild9
3 files changed, 70 insertions, 4 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 507a75683789..e36115e57dd7 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,4 +1,6 @@
DIST streamlink-5.5.1.tar.gz 536064 BLAKE2B 0a651c5dcf9fe0a70ee93505ad0a0ea6aaf10739edc763a796633ce34b8235e4aa6a5a45bd1f6dd2591ced9cd87141d4b89d34e9e399d6166d74c9c3ee12f5ea SHA512 2d7fd75bbf356baaf91791930e74e361b37abf0ff1251fa3022ca216dc16a8610635089cb746506baec82c31f8bc569e3b8e538b17ba910389168e61dcdbbe0f
+DIST streamlink-6.0.0.tar.gz 681437 BLAKE2B 32d8e334fd88efddf0532d459352d9a66276a69020d7be30632772636085e67b8dfc70606c9d5fb8b7ff14185c41774b4caa1a5a6b7dbbc698d4931739aeff1e SHA512 6726cfc5c4cb1572e2e476ec097db6edaace2516efb9e01c52498cfac8cc3f319b9aa4475f6726f7b9a0a15ddc0a8a3de37e1cadc995acbfaba6a8e198051e2c
EBUILD streamlink-5.5.1.ebuild 1544 BLAKE2B 80f5cc0c5b84ee0baf644d3af104d796f104474df6bd1039e87394f3a26732754cad19d6ac10533b2618a97db3c745d1e7fd52e78c25ae321610eab27af51336 SHA512 e21839c90166932d66de3946280397363493a725aa01b796d9b758492cb3dc16ac838aae753de88adc84ec94c24a882780cb72dcdefaed7cded987704b857383
-EBUILD streamlink-9999.ebuild 1545 BLAKE2B 37c18c303093a4c2cd0e90785c8d19332854c136f9b9a1b2b7557560626df022ade362204a711c42e27d4dcc89bb14689940a21bea47657cfacd7b4c7cedabbf SHA512 c96f7243ff58499dda9fdf4ef4f366e27bc9f70f4281a24a74570a82a083adf826840840c01f6272cddac64f5405e5a9ee03960f1bd39404405ba35c67381624
+EBUILD streamlink-6.0.0.ebuild 1692 BLAKE2B 33e0b64934664ea6c2ff156a9a66769d827857b933e05225b681c32cc656b2d0c3b3abd8189ed1a3c6550b96baba90dfdfec25282d1b60f84812f824a0c1cc82 SHA512 987d4158f1ed3419c3304b2eb114de8f31837637d0af0f7b9640743539b0f5d40a58ac113f3b11782d1da090a78e3afdf2acbfb47c126d6b0524bf8e486d0725
+EBUILD streamlink-9999.ebuild 1692 BLAKE2B 33e0b64934664ea6c2ff156a9a66769d827857b933e05225b681c32cc656b2d0c3b3abd8189ed1a3c6550b96baba90dfdfec25282d1b60f84812f824a0c1cc82 SHA512 987d4158f1ed3419c3304b2eb114de8f31837637d0af0f7b9640743539b0f5d40a58ac113f3b11782d1da090a78e3afdf2acbfb47c126d6b0524bf8e486d0725
MISC metadata.xml 374 BLAKE2B 8c5f72454d8d00a99c18328838cc9c3be82cd9d68405f6e702239b8475a9162f3ba945b142bf2f5762fcc4ac52cae95c8e2d5c0707b1028c11faba2341a2d8e9 SHA512 038e509b340b1cc31382b0a1edf0c273fe99ca7c8c40370039a01cf6a95101d1217db7fea64bc67f5c113c99d504ceb7256008c1539c4d7e13ad6ceb8b922a58
diff --git a/net-misc/streamlink/streamlink-6.0.0.ebuild b/net-misc/streamlink/streamlink-6.0.0.ebuild
new file mode 100644
index 000000000000..7d0a43ab5bbb
--- /dev/null
+++ b/net-misc/streamlink/streamlink-6.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+distutils_enable_tests pytest
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 6c6140e9a8da..7d0a43ab5bbb 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="BSD-2 Apache-2.0"
@@ -28,13 +28,15 @@ SLOT="0"
DEPEND="
$(python_gen_cond_dep '
dev-python/certifi[${PYTHON_USEDEP}]
- >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
>dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
')
@@ -50,6 +52,7 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
)
')