summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-24 02:54:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-24 02:54:28 +0100
commit2995a1ea3e0d9c72087365b0278eb7b5f7a509fd (patch)
treee640a2eca99555fab882bc502927e624ec2c0758 /net-misc
parent3018b5a4bd4777c51e2793818305d7af2409a7fd (diff)
gentoo auto-resync : 24:07:2023 - 02:54:28
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/Manifest.gzbin54120 -> 54124 bytes
-rw-r--r--net-misc/streamlink/Manifest4
-rw-r--r--net-misc/streamlink/streamlink-6.0.0.ebuild61
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild9
-rw-r--r--net-misc/whois/Manifest2
-rw-r--r--net-misc/whois/whois-5.5.18.ebuild81
6 files changed, 153 insertions, 4 deletions
diff --git a/net-misc/Manifest.gz b/net-misc/Manifest.gz
index 8952d00f19b0..f3d1cf233dd1 100644
--- a/net-misc/Manifest.gz
+++ b/net-misc/Manifest.gz
Binary files differ
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 507a75683789..e36115e57dd7 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,4 +1,6 @@
DIST streamlink-5.5.1.tar.gz 536064 BLAKE2B 0a651c5dcf9fe0a70ee93505ad0a0ea6aaf10739edc763a796633ce34b8235e4aa6a5a45bd1f6dd2591ced9cd87141d4b89d34e9e399d6166d74c9c3ee12f5ea SHA512 2d7fd75bbf356baaf91791930e74e361b37abf0ff1251fa3022ca216dc16a8610635089cb746506baec82c31f8bc569e3b8e538b17ba910389168e61dcdbbe0f
+DIST streamlink-6.0.0.tar.gz 681437 BLAKE2B 32d8e334fd88efddf0532d459352d9a66276a69020d7be30632772636085e67b8dfc70606c9d5fb8b7ff14185c41774b4caa1a5a6b7dbbc698d4931739aeff1e SHA512 6726cfc5c4cb1572e2e476ec097db6edaace2516efb9e01c52498cfac8cc3f319b9aa4475f6726f7b9a0a15ddc0a8a3de37e1cadc995acbfaba6a8e198051e2c
EBUILD streamlink-5.5.1.ebuild 1544 BLAKE2B 80f5cc0c5b84ee0baf644d3af104d796f104474df6bd1039e87394f3a26732754cad19d6ac10533b2618a97db3c745d1e7fd52e78c25ae321610eab27af51336 SHA512 e21839c90166932d66de3946280397363493a725aa01b796d9b758492cb3dc16ac838aae753de88adc84ec94c24a882780cb72dcdefaed7cded987704b857383
-EBUILD streamlink-9999.ebuild 1545 BLAKE2B 37c18c303093a4c2cd0e90785c8d19332854c136f9b9a1b2b7557560626df022ade362204a711c42e27d4dcc89bb14689940a21bea47657cfacd7b4c7cedabbf SHA512 c96f7243ff58499dda9fdf4ef4f366e27bc9f70f4281a24a74570a82a083adf826840840c01f6272cddac64f5405e5a9ee03960f1bd39404405ba35c67381624
+EBUILD streamlink-6.0.0.ebuild 1692 BLAKE2B 33e0b64934664ea6c2ff156a9a66769d827857b933e05225b681c32cc656b2d0c3b3abd8189ed1a3c6550b96baba90dfdfec25282d1b60f84812f824a0c1cc82 SHA512 987d4158f1ed3419c3304b2eb114de8f31837637d0af0f7b9640743539b0f5d40a58ac113f3b11782d1da090a78e3afdf2acbfb47c126d6b0524bf8e486d0725
+EBUILD streamlink-9999.ebuild 1692 BLAKE2B 33e0b64934664ea6c2ff156a9a66769d827857b933e05225b681c32cc656b2d0c3b3abd8189ed1a3c6550b96baba90dfdfec25282d1b60f84812f824a0c1cc82 SHA512 987d4158f1ed3419c3304b2eb114de8f31837637d0af0f7b9640743539b0f5d40a58ac113f3b11782d1da090a78e3afdf2acbfb47c126d6b0524bf8e486d0725
MISC metadata.xml 374 BLAKE2B 8c5f72454d8d00a99c18328838cc9c3be82cd9d68405f6e702239b8475a9162f3ba945b142bf2f5762fcc4ac52cae95c8e2d5c0707b1028c11faba2341a2d8e9 SHA512 038e509b340b1cc31382b0a1edf0c273fe99ca7c8c40370039a01cf6a95101d1217db7fea64bc67f5c113c99d504ceb7256008c1539c4d7e13ad6ceb8b922a58
diff --git a/net-misc/streamlink/streamlink-6.0.0.ebuild b/net-misc/streamlink/streamlink-6.0.0.ebuild
new file mode 100644
index 000000000000..7d0a43ab5bbb
--- /dev/null
+++ b/net-misc/streamlink/streamlink-6.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+distutils_enable_tests pytest
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 6c6140e9a8da..7d0a43ab5bbb 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="BSD-2 Apache-2.0"
@@ -28,13 +28,15 @@ SLOT="0"
DEPEND="
$(python_gen_cond_dep '
dev-python/certifi[${PYTHON_USEDEP}]
- >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
>dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
')
@@ -50,6 +52,7 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
)
')
diff --git a/net-misc/whois/Manifest b/net-misc/whois/Manifest
index 8e316c2047bf..19f9210dc261 100644
--- a/net-misc/whois/Manifest
+++ b/net-misc/whois/Manifest
@@ -2,6 +2,8 @@ AUX whois-4.7.2-config-file.patch 202 BLAKE2B b5c421655f40c22fcb9c9ac3194821e6e4
AUX whois-5.3.0-libidn_automagic.patch 778 BLAKE2B b9214f6f0c081abf6141057ee9f82db30dad7306fe611b1cb70d256b235d0ba544887f8b084d7b71a21486ad68d312ad98075aed51765f59ecbf7ced45684772 SHA512 8df8c99320ee4a4327f35a62dbaca0b071a3472d398604304d772f2424d607d109d87056b1a138b041c4c391409828cc7397dc62ed973dee500b2eb9f1735676
AUX whois-5.5.6-libxcrypt_automagic.patch 677 BLAKE2B e832e829f97c9b23ca4d62e037f74fdf87225390a399fa240f0789123144f07f3e2d66ec009662c9936d1a0f112998532350a2144d95dc96cac7b22250090fac SHA512 14b2787fc7933eaf21584dc93b84a605a3f593b77767f2b622b906f03c75edd3faee3d39281dc4332bb5b64b24bee07c7ccd1115f2e80ae394637bf093f70305
DIST whois_5.5.17.tar.xz 90608 BLAKE2B 82793097e421d88130d089fc64bb0bceac0c9170b39388262b45d2bf62fc2f8b7c4e393fc5351bba6be303ced00a00af1972bf73c1c8c7c86c812b19a0a6fb5a SHA512 0ed33edc2005eb51a88bda505cc3f6ebe3966095d6f12c03cfe62c12e7e575e1d008632d12de6f27b4c09b91ce5a45705d57acce88409e573bbd7b5132df7fc6
+DIST whois_5.5.18.tar.xz 90216 BLAKE2B 2098b15d36ee0f99e710fdeb10ce1650eba84da1ce770df46182439a6de07995b79746767968522200f5261490e5ffd262673705b12e1004e1ca0dd1af0b9e15 SHA512 28482a6b84d97e2ff69e7a2d01865d227d76aff41a42511a6ebd4ac636b9054643d1df800e6575fb846712e1473f7a31a211dbc08fbdfaaead443d22138266c7
EBUILD whois-5.5.17.ebuild 1809 BLAKE2B 931da25a9777ad25a76cc082f7837534e5b1c6f13c7fa4b670e8d6fba9945886d5202d98c9ecfd49f05748d331b8deb3b50c4b5c20c92fb0b8b5f92dc20f2f43 SHA512 037f25170e2e969537af8c72e30a41c16319b76fb9a5afbaa8fa0e3db1f0f89b14018fa0fb3811ffed1c60334944350f3319804469344861078c26abf10edeff
+EBUILD whois-5.5.18.ebuild 1816 BLAKE2B efd577b1381c19776018f0602f6344c938ade6f8de4382f19bd02e26eb3ae680256fcfd2cbe60e59346415884af99969224ec9ba017e7bccfbccb466822c388b SHA512 a24cef284e30e8f5306a23d18f45155ec03055b1c84cf86d7a641b741bdcd021a76ddc50a0de540fb391e65f84f390dc7f31d8a57dc7f0407269d2d3cca6ebd5
EBUILD whois-9999.ebuild 1816 BLAKE2B efd577b1381c19776018f0602f6344c938ade6f8de4382f19bd02e26eb3ae680256fcfd2cbe60e59346415884af99969224ec9ba017e7bccfbccb466822c388b SHA512 a24cef284e30e8f5306a23d18f45155ec03055b1c84cf86d7a641b741bdcd021a76ddc50a0de540fb391e65f84f390dc7f31d8a57dc7f0407269d2d3cca6ebd5
MISC metadata.xml 439 BLAKE2B 609f61e31ef22ab28f06d9f0b6542a0efbcb8a006b05f14ff6339a332bb3f04996d13c9a62b55765ce4611df0e9efe021b6f5b5060b13d00d72eae71eb9f9e3e SHA512 05bf067e25586b2032b137dae008a4c59aed9e633f37b545d6ccdca6dc3d69d8614d8ad26c34e87d956b93d24b7962c3fe908070dcfd6826c8fe916b51f29d2f
diff --git a/net-misc/whois/whois-5.5.18.ebuild b/net-misc/whois/whois-5.5.18.ebuild
new file mode 100644
index 000000000000..7d0d51aff22f
--- /dev/null
+++ b/net-misc/whois/whois-5.5.18.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Improved Whois Client"
+HOMEPAGE="https://github.com/rfc1036/whois"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rfc1036/whois.git"
+else
+ SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
+ #SRC_URI="https://github.com/rfc1036/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ #S="${WORKDIR}"/${PN}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="iconv idn nls xcrypt"
+
+RDEPEND="
+ iconv? ( virtual/libiconv )
+ idn? ( net-dns/libidn2:= )
+ nls? ( virtual/libintl )
+ xcrypt? ( >=sys-libs/libxcrypt-4.1:= )
+ !xcrypt? ( virtual/libcrypt:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ >=dev-lang/perl-5
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+ "${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+ "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
+)
+
+src_prepare() {
+ default
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile || die
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h || die
+
+ # don't generate po files when nls is disabled (bug #419889)
+ sed -i -e '/^all:/s/ pos//' \
+ -e '/^install:/s/ install-pos//' Makefile || die
+ fi
+}
+
+src_configure() { :; } # expected no-op
+
+src_compile() {
+ unset HAVE_ICONV HAVE_LIBIDN
+
+ use iconv && export HAVE_ICONV=1
+ use idn && export HAVE_LIBIDN=1
+ use xcrypt && export HAVE_XCRYPT=1
+
+ tc-export CC
+
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ emake BASEDIR="${ED}" prefix=/usr install
+
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+}