summaryrefslogtreecommitdiff
path: root/net-misc/sgopherd/sgopherd-18.08.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /net-misc/sgopherd/sgopherd-18.08.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'net-misc/sgopherd/sgopherd-18.08.ebuild')
-rw-r--r--net-misc/sgopherd/sgopherd-18.08.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/sgopherd/sgopherd-18.08.ebuild b/net-misc/sgopherd/sgopherd-18.08.ebuild
new file mode 100644
index 000000000000..d83915c04118
--- /dev/null
+++ b/net-misc/sgopherd/sgopherd-18.08.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small Gopher Server written in GNU Bash"
+HOMEPAGE="https://www.uninformativ.de/git/sgopherd"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="app-shells/bash
+ sys-apps/sed
+ sys-apps/xinetd"
+
+src_prepare() {
+ # Set default user to run sgopherd
+ sed -i -e '/user/s/http/nobody/' xinetd/xinetd-example.conf || die 'sed failed'
+
+ eapply_user
+}
+
+src_install() {
+ dodoc README
+ doman man8/"${PN}".8
+ dobin "${PN}"
+ insinto /etc/xinetd.d
+ newins xinetd/xinetd-example.conf "${PN}"
+ # TODO: add installation of systemd-related files
+}
+
+pkg_postinst() {
+ elog "${PN} can be launched through xinetd"
+ elog "Configuration options are in /etc/xinetd.d/${PN}"
+}