summaryrefslogtreecommitdiff
path: root/net-misc/sgopherd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /net-misc/sgopherd
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'net-misc/sgopherd')
-rw-r--r--net-misc/sgopherd/Manifest2
-rw-r--r--net-misc/sgopherd/sgopherd-18.08.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/sgopherd/Manifest b/net-misc/sgopherd/Manifest
index 188e4d0bb1db..35cff283c76e 100644
--- a/net-misc/sgopherd/Manifest
+++ b/net-misc/sgopherd/Manifest
@@ -1,3 +1,5 @@
DIST sgopherd-17.09.tar.gz 8855 BLAKE2B d79b6f2d6c19e0ec2878ff44c56d739863a74bfc967098d4e51d4b9a723fed587d5d52f78aeb5e915e466f43a28ac443b39e8b79e6a8e8fc82c4c049be7b8cb4 SHA512 7f3ef37d5ec08d21e7945f0327ea50697237461f717a2ce3c5a0fe9c077effe26710013725a59a184564e028f249f7b53087752410600da0f8feaf9cd1b9c7dc
+DIST sgopherd-18.08.tar.bz2 12777 BLAKE2B dde415822f9e4a41463fa6d2622b59adc5676b88cb5b5831ec3396869f6b2bfa4d605b92bd56c24d9aa1b8d4a0198c4f2f46a6141f5f2c913cde1cfb9e99d3db SHA512 830558f2be0763550f0229bfa22524de81c9ea119b2d0f00e465f76ba343d4f488e5595851bbf13697b270d7dc611eafb36a320b6dc2c7d27ad854bd14f4c10d
EBUILD sgopherd-17.09.ebuild 881 BLAKE2B 385053740a10062f894ce1e44834785d4f1fc93679a18198ad08411b165c17387f09212ac0b75a5dfc10e49eb8a4a7e7d802733ba4a587728cbba71a9274c32b SHA512 5097bae8034d6cb3eb680dc42956880dcf38dad2afc460ce5281dcc54999e6fa70b3e4a1cb9f83bac377be19f4e11933d6f3e986bee98f0edb7e11d38a35aa1c
+EBUILD sgopherd-18.08.ebuild 872 BLAKE2B b1d6b50cd57b0df8d29c80ccdf49bd35ab8f74e3842ff59a7194e43044c4661eee31fe3d40426b57abd8c68e98e9796aed7ceaf950e576dd06c3aab01883472e SHA512 c2d08328ed56c5dd1887614f7805a593576708a1b1695db0b30058db653895b3ddac40f7e6a7e31e375ca0285f95c47884f0de0e62e72a99589181d73e873306
MISC metadata.xml 325 BLAKE2B 466851c33b7e7823dfc601e38bc23ff344e623acda48d749a33ad70fd12623ebf2120fff9e7a67ccf48edd32b08088df3ed85de7f2a1ec8aab6b759932d9e123 SHA512 b0da1cc0212383ff00849f6c9b3cf1e96713d1db19e21711cb8147b43ac8dc696fbfb5ff4703f8b25f73f051c25d3f05dd3e59bf229528cc0a6652b57c2b19ef
diff --git a/net-misc/sgopherd/sgopherd-18.08.ebuild b/net-misc/sgopherd/sgopherd-18.08.ebuild
new file mode 100644
index 000000000000..d83915c04118
--- /dev/null
+++ b/net-misc/sgopherd/sgopherd-18.08.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small Gopher Server written in GNU Bash"
+HOMEPAGE="https://www.uninformativ.de/git/sgopherd"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="app-shells/bash
+ sys-apps/sed
+ sys-apps/xinetd"
+
+src_prepare() {
+ # Set default user to run sgopherd
+ sed -i -e '/user/s/http/nobody/' xinetd/xinetd-example.conf || die 'sed failed'
+
+ eapply_user
+}
+
+src_install() {
+ dodoc README
+ doman man8/"${PN}".8
+ dobin "${PN}"
+ insinto /etc/xinetd.d
+ newins xinetd/xinetd-example.conf "${PN}"
+ # TODO: add installation of systemd-related files
+}
+
+pkg_postinst() {
+ elog "${PN} can be launched through xinetd"
+ elog "Configuration options are in /etc/xinetd.d/${PN}"
+}