summaryrefslogtreecommitdiff
path: root/net-mail/list-remote-forwards
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
commitb987a550f067c3da93b0664cf1fdc8a624c0aa38 (patch)
tree9ad1767fad656d26471a81af6bac8400a1c75218 /net-mail/list-remote-forwards
parente3f21c8aff8a76afe3423721c437a088e9232840 (diff)
gentoo auto-resync : 24:04:2024 - 23:59:27
Diffstat (limited to 'net-mail/list-remote-forwards')
-rw-r--r--net-mail/list-remote-forwards/Manifest4
-rw-r--r--net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild42
-rw-r--r--net-mail/list-remote-forwards/metadata.xml146
3 files changed, 53 insertions, 139 deletions
diff --git a/net-mail/list-remote-forwards/Manifest b/net-mail/list-remote-forwards/Manifest
index c8b379175ebd..742a1a4b7b2f 100644
--- a/net-mail/list-remote-forwards/Manifest
+++ b/net-mail/list-remote-forwards/Manifest
@@ -1,3 +1,5 @@
DIST list-remote-forwards-0.0.3.tar.gz 26495 BLAKE2B 7bc0a02133dfabe0f27c7ed861bbb994757eadb4d55d369fdd143da7ef03fcadf7d1f11bb034fc8ade7dc879d4b615a3ae5ed44a1ed5af3e10f1aaffcd79210a SHA512 833bb0a3fda76b43d0004d7906c54aa21920f1db8ff50fc2c0d1da6f98dd49310041fa7101050108cb6cb803084fff0673316a1ce86224d35ba09e8060864a9d
+DIST list-remote-forwards-0.0.4.tar.gz 26653 BLAKE2B 743b35456698473184ef5c4ac9184b71e7cee821ab75df2267b3d60df67050231dc98b63dacb4fe4620d018524f3d739ecf026a31752494457b8dcc4a1656b67 SHA512 8df7e252ee186fa8569efe2e92fdc2e7db7b6044f9a7be97c42c152381129e9591d1ace91da8e5fcd2a70dda4976bae6c129d457641ee43bf3efaa5bcb8168dc
EBUILD list-remote-forwards-0.0.3.ebuild 1120 BLAKE2B f034e612cef58ba7a70c6cd0c44bbcdbb15098537232102e19666a6dbd55840099f1f9e51301d65e459764028dc8ed4cef88b55f375a3378e1222905bc2c203c SHA512 2939e77afc6848cac85a6cc086ce0003b7a20d05ae71a58583e476d7ad6b95b35485c582ef6e3cc5fd8587a7d27ca1034820245888fd6886ca150eaf1c2149a4
-MISC metadata.xml 4176 BLAKE2B ebc5feaa3fbc0cf1551aa2e80bb4e971918181f16e8b365c99297789d41b6dec7f138d2ccfb7ee69972e026299ad5b2e554ce3e136232af0f5eb4c46790bfb2e SHA512 277cc5c1b55a8890e26adf5762d4cd522dbbe81c9eaa0eb6a8126e2ddbbf3919bbac703e22fab0f924c08fd656d23dda4a74c48db26323552b1cc1595b6062af
+EBUILD list-remote-forwards-0.0.4.ebuild 1081 BLAKE2B b24a1b668ece4fe9735b5be56d5514736ed5085af12f6343eafe84ba168690627cd8ed0e159b14fa3fc7cf1e7126356a5784d59f5ab960c89d37f5014bd9f38b SHA512 76de320c75adc0195f58da5639b015c2e00d8704ac1d7053ef8ca236c143cc4f3bcf0480bef930d5c50a4002620d72311ea4984ef30d43a7ac268b52abac83d6
+MISC metadata.xml 369 BLAKE2B 4c33e23798141bec53a974c1aeb3036a72be1aba85ca654fe407dce4ecfe3e28e7aacc8b7d75e214ca9f11e49027fc09a8425074b349c4c91d41aa011b474c9c SHA512 707ad8c37747990be1f2235b241153d0a8f2245a11d1841a90905c29432b30bce2a89e6a5268f536cf51da388bce81db9ea476eafd95b05a32f0fbf8ac025874
diff --git a/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild b/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild
new file mode 100644
index 000000000000..ac047250e4b3
--- /dev/null
+++ b/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="List all remote forwards for mail accounts stored in a database"
+HOMEPAGE="https://michael.orlitzky.com/code/list-remote-forwards.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+# dev-haskell/dns and dev-haskell/resolv conflict
+# https://github.com/sol/doctest/issues/119
+RESTRICT=test
+
+RDEPEND=">=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/dns-1.4
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-lang/ghc-9.0.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )
+"
+
+src_install() {
+ haskell-cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}
diff --git a/net-mail/list-remote-forwards/metadata.xml b/net-mail/list-remote-forwards/metadata.xml
index d81f432bdff8..062f4341e706 100644
--- a/net-mail/list-remote-forwards/metadata.xml
+++ b/net-mail/list-remote-forwards/metadata.xml
@@ -1,142 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>mjo@gentoo.org</email>
- <name>Michael Orlitzky</name>
- </maintainer>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- /Usage/:
-
- @
- list-remote-forwards [OPTIONS]
- @
-
- List all remote forwards for mail accounts stored in a SQL database.
-
- A list of local domains is supplied to the program (more or less)
- through the @--domain-query@ option. Any addresses which
- forward to another address not contained in this list of local domains
- is considered a remote forward. Remote forwards can cause problems for
- a number of reasons, the most common of which are,
-
- * If the sender has an SPF record authorizing his mail server to send
- mail on his behalf, then when his message is forwarded by the
- recipient's mail server, it will fail any subsequent SPF checks. This
- will likely cause the message to be rejected, and the original
- recipient's server will generate backscatter.
-
- * If any spam makes it through the filter on the recipient's mail
- server, that spam will then be forwarded to a remote destination. The
- remote destination will blame the forwarding server for the spam, and
- that can impact its reputation and potentially lead to a blacklisting
- even though the spam did not originate on the recipient's server.
-
- Whether or not these are an issue depends on the circumstances, but in
- any case it is useful to know who is forwarding mail off-site.
-
- /Input:/
-
- None.
-
- /Output:/
-
- A list of addresses that are forwarded to remote domains.
-
- /Options/:
-
- @
- \--database
- @
-
- The name of the database (or file, if SQLite) to which we should
- connect.
-
- Default: The name of the current user (Postgres only).
-
- @
- \--domain-query
- @
- SQL query used to produce a list of local domains. This should return
- the set of all domains (i.e one column) that are local to the
- server. See the default value for an example.
-
- Default: \"SELECT domain FROM domain WHERE domain &lt;&gt; 'ALL' ORDER BY domain;\"
-
- @
- \--exclude-mx, -e
- @
-
- The name of a mail exchanger, the forwards of whose domains we should
- ignore. For example, if one mail exchanger, mx1.example.com, has
- strict spam filtering, it may be acceptable to have remote forwarding
- for domains that have mx1.example.com as their sole mail exchanger (MX
- record). In that case, you might want to exclude those domains from
- the report by naming mx1.example.com here.
-
- A forward will be excluded from the report only if /all/ of its MX
- records are contained in the given exclude list.
-
- This option can be repeated to add mail exchangers to the exclude list.
-
- Default: [] (empty)
-
- @
- \--forward-query, -f
- @
-
- SQL query used to produce a list of all forwards on the mail
- system. This query should return the set of all (address, goto)
- triples, where \"goto\" is the destination address; i.e. to where
- the \"address\" forwards. The \"goto\" field may contain more
- than one email address, separated by commas.
-
- Default: \"SELECT address,goto FROM alias ORDER BY address;\"
-
- @
- \--host, -h
- @
-
- Hostname where the database is located (Postgres-only).
-
- Default: None, a UNIX domain socket connection is attempted (Postgres only)
-
- @
- \--password
- @
-
- Password used to connect to the database (Postgres-only).
-
- Default: None (assumes passwordless authentication)
-
- @
- \--port
- @
- Port number used to connect to the database (Postgres-only).
-
- Default: None, a UNIX domain socket connection is attempted (Postgres only)
-
- @
- \--username, -u
- @
-
- Username used to connect to the database (Postgres-only).
-
- Default: The current user
-
- /Examples/:
-
- @
- $ list-remote-forwards --database=test/fixtures/postfixadmin.sqlite3
- user1@example.com -&gt; user1@example.net
- user2@example.com -&gt; user1@example.org
- user2@example.com -&gt; user2@example.org
- user2@example.com -&gt; user3@example.org
- user7@example.com -&gt; user8@example.net
- @
- </longdescription>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
</pkgmetadata>