summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
commitb987a550f067c3da93b0664cf1fdc8a624c0aa38 (patch)
tree9ad1767fad656d26471a81af6bac8400a1c75218 /net-mail
parente3f21c8aff8a76afe3423721c437a088e9232840 (diff)
gentoo auto-resync : 24:04:2024 - 23:59:27
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/Manifest.gzbin14052 -> 14056 bytes
-rw-r--r--net-mail/list-remote-forwards/Manifest4
-rw-r--r--net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild42
-rw-r--r--net-mail/list-remote-forwards/metadata.xml146
-rw-r--r--net-mail/mailbox-count/Manifest2
-rw-r--r--net-mail/mailbox-count/metadata.xml162
-rw-r--r--net-mail/public-inbox/Manifest4
-rw-r--r--net-mail/public-inbox/public-inbox-1.9.0_p20240422.ebuild53
-rw-r--r--net-mail/public-inbox/public-inbox-9999.ebuild4
9 files changed, 134 insertions, 283 deletions
diff --git a/net-mail/Manifest.gz b/net-mail/Manifest.gz
index 9058401509fd..91a3d20f793c 100644
--- a/net-mail/Manifest.gz
+++ b/net-mail/Manifest.gz
Binary files differ
diff --git a/net-mail/list-remote-forwards/Manifest b/net-mail/list-remote-forwards/Manifest
index c8b379175ebd..742a1a4b7b2f 100644
--- a/net-mail/list-remote-forwards/Manifest
+++ b/net-mail/list-remote-forwards/Manifest
@@ -1,3 +1,5 @@
DIST list-remote-forwards-0.0.3.tar.gz 26495 BLAKE2B 7bc0a02133dfabe0f27c7ed861bbb994757eadb4d55d369fdd143da7ef03fcadf7d1f11bb034fc8ade7dc879d4b615a3ae5ed44a1ed5af3e10f1aaffcd79210a SHA512 833bb0a3fda76b43d0004d7906c54aa21920f1db8ff50fc2c0d1da6f98dd49310041fa7101050108cb6cb803084fff0673316a1ce86224d35ba09e8060864a9d
+DIST list-remote-forwards-0.0.4.tar.gz 26653 BLAKE2B 743b35456698473184ef5c4ac9184b71e7cee821ab75df2267b3d60df67050231dc98b63dacb4fe4620d018524f3d739ecf026a31752494457b8dcc4a1656b67 SHA512 8df7e252ee186fa8569efe2e92fdc2e7db7b6044f9a7be97c42c152381129e9591d1ace91da8e5fcd2a70dda4976bae6c129d457641ee43bf3efaa5bcb8168dc
EBUILD list-remote-forwards-0.0.3.ebuild 1120 BLAKE2B f034e612cef58ba7a70c6cd0c44bbcdbb15098537232102e19666a6dbd55840099f1f9e51301d65e459764028dc8ed4cef88b55f375a3378e1222905bc2c203c SHA512 2939e77afc6848cac85a6cc086ce0003b7a20d05ae71a58583e476d7ad6b95b35485c582ef6e3cc5fd8587a7d27ca1034820245888fd6886ca150eaf1c2149a4
-MISC metadata.xml 4176 BLAKE2B ebc5feaa3fbc0cf1551aa2e80bb4e971918181f16e8b365c99297789d41b6dec7f138d2ccfb7ee69972e026299ad5b2e554ce3e136232af0f5eb4c46790bfb2e SHA512 277cc5c1b55a8890e26adf5762d4cd522dbbe81c9eaa0eb6a8126e2ddbbf3919bbac703e22fab0f924c08fd656d23dda4a74c48db26323552b1cc1595b6062af
+EBUILD list-remote-forwards-0.0.4.ebuild 1081 BLAKE2B b24a1b668ece4fe9735b5be56d5514736ed5085af12f6343eafe84ba168690627cd8ed0e159b14fa3fc7cf1e7126356a5784d59f5ab960c89d37f5014bd9f38b SHA512 76de320c75adc0195f58da5639b015c2e00d8704ac1d7053ef8ca236c143cc4f3bcf0480bef930d5c50a4002620d72311ea4984ef30d43a7ac268b52abac83d6
+MISC metadata.xml 369 BLAKE2B 4c33e23798141bec53a974c1aeb3036a72be1aba85ca654fe407dce4ecfe3e28e7aacc8b7d75e214ca9f11e49027fc09a8425074b349c4c91d41aa011b474c9c SHA512 707ad8c37747990be1f2235b241153d0a8f2245a11d1841a90905c29432b30bce2a89e6a5268f536cf51da388bce81db9ea476eafd95b05a32f0fbf8ac025874
diff --git a/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild b/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild
new file mode 100644
index 000000000000..ac047250e4b3
--- /dev/null
+++ b/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="List all remote forwards for mail accounts stored in a database"
+HOMEPAGE="https://michael.orlitzky.com/code/list-remote-forwards.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+# dev-haskell/dns and dev-haskell/resolv conflict
+# https://github.com/sol/doctest/issues/119
+RESTRICT=test
+
+RDEPEND=">=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/dns-1.4
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-lang/ghc-9.0.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )
+"
+
+src_install() {
+ haskell-cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}
diff --git a/net-mail/list-remote-forwards/metadata.xml b/net-mail/list-remote-forwards/metadata.xml
index d81f432bdff8..062f4341e706 100644
--- a/net-mail/list-remote-forwards/metadata.xml
+++ b/net-mail/list-remote-forwards/metadata.xml
@@ -1,142 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>mjo@gentoo.org</email>
- <name>Michael Orlitzky</name>
- </maintainer>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- /Usage/:
-
- @
- list-remote-forwards [OPTIONS]
- @
-
- List all remote forwards for mail accounts stored in a SQL database.
-
- A list of local domains is supplied to the program (more or less)
- through the @--domain-query@ option. Any addresses which
- forward to another address not contained in this list of local domains
- is considered a remote forward. Remote forwards can cause problems for
- a number of reasons, the most common of which are,
-
- * If the sender has an SPF record authorizing his mail server to send
- mail on his behalf, then when his message is forwarded by the
- recipient's mail server, it will fail any subsequent SPF checks. This
- will likely cause the message to be rejected, and the original
- recipient's server will generate backscatter.
-
- * If any spam makes it through the filter on the recipient's mail
- server, that spam will then be forwarded to a remote destination. The
- remote destination will blame the forwarding server for the spam, and
- that can impact its reputation and potentially lead to a blacklisting
- even though the spam did not originate on the recipient's server.
-
- Whether or not these are an issue depends on the circumstances, but in
- any case it is useful to know who is forwarding mail off-site.
-
- /Input:/
-
- None.
-
- /Output:/
-
- A list of addresses that are forwarded to remote domains.
-
- /Options/:
-
- @
- \--database
- @
-
- The name of the database (or file, if SQLite) to which we should
- connect.
-
- Default: The name of the current user (Postgres only).
-
- @
- \--domain-query
- @
- SQL query used to produce a list of local domains. This should return
- the set of all domains (i.e one column) that are local to the
- server. See the default value for an example.
-
- Default: \"SELECT domain FROM domain WHERE domain &lt;&gt; 'ALL' ORDER BY domain;\"
-
- @
- \--exclude-mx, -e
- @
-
- The name of a mail exchanger, the forwards of whose domains we should
- ignore. For example, if one mail exchanger, mx1.example.com, has
- strict spam filtering, it may be acceptable to have remote forwarding
- for domains that have mx1.example.com as their sole mail exchanger (MX
- record). In that case, you might want to exclude those domains from
- the report by naming mx1.example.com here.
-
- A forward will be excluded from the report only if /all/ of its MX
- records are contained in the given exclude list.
-
- This option can be repeated to add mail exchangers to the exclude list.
-
- Default: [] (empty)
-
- @
- \--forward-query, -f
- @
-
- SQL query used to produce a list of all forwards on the mail
- system. This query should return the set of all (address, goto)
- triples, where \"goto\" is the destination address; i.e. to where
- the \"address\" forwards. The \"goto\" field may contain more
- than one email address, separated by commas.
-
- Default: \"SELECT address,goto FROM alias ORDER BY address;\"
-
- @
- \--host, -h
- @
-
- Hostname where the database is located (Postgres-only).
-
- Default: None, a UNIX domain socket connection is attempted (Postgres only)
-
- @
- \--password
- @
-
- Password used to connect to the database (Postgres-only).
-
- Default: None (assumes passwordless authentication)
-
- @
- \--port
- @
- Port number used to connect to the database (Postgres-only).
-
- Default: None, a UNIX domain socket connection is attempted (Postgres only)
-
- @
- \--username, -u
- @
-
- Username used to connect to the database (Postgres-only).
-
- Default: The current user
-
- /Examples/:
-
- @
- $ list-remote-forwards --database=test/fixtures/postfixadmin.sqlite3
- user1@example.com -&gt; user1@example.net
- user2@example.com -&gt; user1@example.org
- user2@example.com -&gt; user2@example.org
- user2@example.com -&gt; user3@example.org
- user7@example.com -&gt; user8@example.net
- @
- </longdescription>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
</pkgmetadata>
diff --git a/net-mail/mailbox-count/Manifest b/net-mail/mailbox-count/Manifest
index e486ccbe65a5..ecce2d95cfd3 100644
--- a/net-mail/mailbox-count/Manifest
+++ b/net-mail/mailbox-count/Manifest
@@ -1,3 +1,3 @@
DIST mailbox-count-0.0.6.tar.gz 21176 BLAKE2B 655815d463e14ee8c32cc955819d6b95d5359a644fb09433cb8ab303f07a98ce33b4c048be724253f30d8855a921abb5a7a29e62391ef8a1a9288e2f430710fc SHA512 285aeeaa8cfaade6c91a850154772e47aa212f73d1206c3c8262d08a15b95f15ce812152ca5acf79f5390f476ed6af52a73e03af4ab297e1268044a4a9ece6b5
EBUILD mailbox-count-0.0.6.ebuild 909 BLAKE2B 1c4d5e6e76fe42ed08606e76aad0fc1ec75b29dd7de70f21f641ea0070a6e3fa3098e5d53af8a2c888e4bd66304c486cc1fe5ff22d221eb835538e5efd81799e SHA512 93b965b5d38edf94863fec72fa221bc91ff71c688b7b8ba8bedfb3d1879d50e933db5dfedafe1a92b7b9386aefc367151c58e92e501fb876509258da4cb6f0fc
-MISC metadata.xml 3289 BLAKE2B 5d1dec2ad9a593e25c496b66ae3c611c66aea004c0a1b235d6ef8cf16f91f2f8c55b5d7e901e8fe3f06b6e2b0b26fe91b51b3abfb5bdfff4766b620e3cd05fcb SHA512 fbd3e2e45ca48318b17b26acd9564d9e562a6c007413d9740226b7ca27152377c54a943f4d2be02fb757744e684f7798a1c6ba04cc00244dafa18aa0f6e09593
+MISC metadata.xml 1059 BLAKE2B edbab64630a76439222edc42778fd497de925c8e8c5817da4be3f978c582149d62c369828421d36f0969a2dfa4d87255acf601bf73d339acfea30fe8f1708543 SHA512 9eae87b53f29f2909be1e862b9f811a946f32b271fab52513a6322533b9aa9d0c0738ca8548c4350282fb3bbb879305f7fb82ae662bd9982f851b72eff7315c2
diff --git a/net-mail/mailbox-count/metadata.xml b/net-mail/mailbox-count/metadata.xml
index 4831484d5891..134a467564f6 100644
--- a/net-mail/mailbox-count/metadata.xml
+++ b/net-mail/mailbox-count/metadata.xml
@@ -1,144 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>mjo@gentoo.org</email>
- <name>Michael Orlitzky</name>
- </maintainer>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- /Usage/:
-
- @
- mailbox-count [OPTIONS]
- @
-
- Mailbox-count produces a simple count of mailboxes that exist
- per-domain in some SQL database. The default queries are compatible
- with the schema used by PostfixAdmin &lt;http://postfixadmin.sourceforge.net/&gt;,
- but it is possible to supply your own queries via the @--summary-query@
- and @--detail-query@ options.
-
- The summary report lists each domain, along with the number of
- mailboxes owned by that domain. The order is determined by the summary
- query, which lists the domains alphabetically by default.
-
- The default detail report shows the same, but also contains a list of
- each individual mailbox (again in alphabetical order) belonging to the
- domains.
-
- /Input/:
-
- None.
-
- /Output/:
-
- Either a summary, or detailed report (with @--detail@) of the
- number of mailboxes per-domain contained in the database.
-
- /Options/:
-
- @
- \--database
- @
-
- The name of the database (or file, if SQLite) to which we should
- connect.
-
- Default: The name of the current user (Postgres only).
-
- @
- \--detail
- @
-
- Produce a detailed report listing all mailboxes by domain.
-
- @
- \--detail-query
- @
-
- SQL query used to produce the detail report. This should return the
- set of all (domain, username) pairs. See the default value for an
- example.
-
- Default: \"SELECT domain,username FROM mailbox ORDER BY domain;\"
-
- @
- \--host
- @
-
- Hostname where the database is located (Postgres-only).
-
- Default: None, a UNIX domain socket connection is attempted (Postgres only)
-
- @
- \--password
- @
-
- Password used to connect to the database (Postgres-only).
-
- Default: None (assumes passwordless authentication)
-
- @
- \--port
- @
- Port number used to connect to the database (Postgres-only).
-
- Default: None, a UNIX domain socket connection is attempted (Postgres only)
-
- @
- \--summary-query
- @
-
- SQL query used to produce the summary report. This should return
- (domain, user count) pairs. See the default value for an
- example.
-
- Default: \"SELECT domain,COUNT(username) FROM mailbox GROUP BY domain
- ORDER BY domain;\"
-
- @
- \--username
- @
-
- Username used to connect to the database (Postgres-only).
-
- Default: The current user
-
- /Examples/:
-
- The default summary report:
-
- @
- $ mailbox-count --database=postfixadmin.sqlite3
- Summary (number of mailboxes per domain)
- \----------------------------------------
- example.com: 3
- example.invalid: 1
- example.net: 2
- example.org: 1
- @
-
- The more detailed report:
-
- @
- $ mailbox-count --detail --database=postfixadmin.sqlite3
- Detail (list of all mailboxes by domain)
- \----------------------------------------
- example.com (3):
- &amp;#x20; user1
- &amp;#x20; user3
- &amp;#x20; user5
- example.invalid (1):
- &amp;#x20; user7
- example.net (2):
- &amp;#x20; user2
- &amp;#x20; user4
- example.org (1):
- &amp;#x20; user6
- @
- </longdescription>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Mailbox-count produces a simple count of mailboxes that exist
+ per-domain in some SQL database. The default queries are compatible
+ with the schema used by PostfixAdmin but it is possible to supply
+ your own queries via the --summary-query and --detail-query options.
+
+ The summary report lists each domain, along with the number of
+ mailboxes owned by that domain. The order is determined by the
+ summary query, which lists the domains alphabetically by default.
+
+ The default detail report shows the same, but also contains a list
+ of each individual mailbox (again in alphabetical order) belonging
+ to the domains.
+ </longdescription>
</pkgmetadata>
diff --git a/net-mail/public-inbox/Manifest b/net-mail/public-inbox/Manifest
index 231a820b6506..1316a13342a4 100644
--- a/net-mail/public-inbox/Manifest
+++ b/net-mail/public-inbox/Manifest
@@ -1,8 +1,10 @@
DIST public-inbox-1.9.0.tar.gz 828312 BLAKE2B 0de7a2437074ca75b56872697d7dbc69e8f4cd3735d85b314f80f1d6037da27f29aaaae8aaf9836f089f950ec3be25e473d9cabff60bd8ec6cf4b90da4ee2ac0 SHA512 9d98b78d29fc35a80bd22b9e133a70ebb0dfacc68859b3ae602037485f44e36cd4cc60f86a9d732da657ea665f20ba31f28b0a6cfea34badd5f124cbc13a6533
DIST public-inbox-1.9.0_p20230918.tar.gz 918459 BLAKE2B e263d1ab599203ef9c4cfee3546856a5f472cec65b85d16014eec5359bbd6eb357242e98ffb1b355ce11ba1a5ce3e5c9c22dd51ce672adf0f83ed3c0f9df6ba2 SHA512 4359ba6876b5644cfa6e04ed0d8ed9a307407651f68503ed40841e7f2aaed540bf8d3ac07e7dde4fc2f19d8b0cadf2016e89bb346f58b24b8bb217003680a831
DIST public-inbox-1.9.0_p20231116.tar.gz 929149 BLAKE2B a8693c7720fff56069ac4147db42df4ff15b77b8d5127d12d9845f9b66ff3917f2f1ddbbca97432683bed2ad323e4300c9f3d3d9194cf24551296d64ecc1011d SHA512 f1fa8fa4093859010e1072694b0a46313c10e2d786a01e238600d9d4d669a9aace82959c240faf69ac8e4670953855e2bdc47afc512701b29d7a8d8c11da8c64
+DIST public-inbox-1.9.0_p20240422.tar.gz 959680 BLAKE2B 18fc839f946490aab1f61b82243e5ad5a5abb6e171fbc1abf88e9ce63d467add88324c4855e88fa29fe483e8c7a8ce632bd00c3d60316db14738e1bd6b3c0bfd SHA512 322b0416760f48003e7f3d89f8cb804c1a65127ed387528ded4c96d7af0ead588ec3c7cb1f0f239a859921927052c40bff631a862ad640bfd52777fe26e3dcbf
EBUILD public-inbox-1.9.0.ebuild 824 BLAKE2B d4f4c4b53ce981dd003759bd6aafc23e623f08bc4256a5252e9e1df810ecafc857d4fab31d5d821c0723611da71520407ecf2f3363c173613ef47a9c211c43d3 SHA512 94ef07ea15db2af08c02b33dd2e15663d07b92d099a502fa63a976b6e939ff9ee90db52ed969feda47532c3226fd511fe282be88de0ff5a4c7f961eb71303edb
EBUILD public-inbox-1.9.0_p20230918.ebuild 1259 BLAKE2B 780d716c3ce8e86278b116ac085f5a83eeb3ecfd76e99545e9b7ddcd8a48f99a903ec9ea7e59ba7840eef226f2fe46dffd2e6eaa0a9371a05a621ef808a1fc64 SHA512 550d9c9725750d9fc7115d6489c6257bffbd9bd577613d2e1486622f8c6e4b9a0155998a78b9c4542a2801d7017adae92eba9e5d66403acdad7f54d145de283f
EBUILD public-inbox-1.9.0_p20231116.ebuild 1259 BLAKE2B f1e04ededd5811b41eaf40f1eaff9b3be58015682ee768232f0e1debd68951d4103ce13fdb97cd8d633353dc17af7b676cf2f15c61c2c0c3782be613113c7ada SHA512 9e560c6eeb0db90d33128a5c2296895b8dff48d68331079e5c988436ea0f88e1a632b8b073ada4ed5d77391030d712a6ee4be740165bab338e62f9bfdb685273
-EBUILD public-inbox-9999.ebuild 1259 BLAKE2B 780d716c3ce8e86278b116ac085f5a83eeb3ecfd76e99545e9b7ddcd8a48f99a903ec9ea7e59ba7840eef226f2fe46dffd2e6eaa0a9371a05a621ef808a1fc64 SHA512 550d9c9725750d9fc7115d6489c6257bffbd9bd577613d2e1486622f8c6e4b9a0155998a78b9c4542a2801d7017adae92eba9e5d66403acdad7f54d145de283f
+EBUILD public-inbox-1.9.0_p20240422.ebuild 1259 BLAKE2B 843e5eec4be53881f84389519988d03612e283669699e94648d67858d2d21d4d022c92bd4dbcb7e46dc1435b683a973a3a370f7560b9773317cab2032380983d SHA512 52328cce39c2c24b2de14bd5c90b7959f586161da1c394a359659e6fb9f63ff86e7dd899062499ab4e54293ee37fc423e186cebac825f9e288f7790c8d8b43c7
+EBUILD public-inbox-9999.ebuild 1259 BLAKE2B 843e5eec4be53881f84389519988d03612e283669699e94648d67858d2d21d4d022c92bd4dbcb7e46dc1435b683a973a3a370f7560b9773317cab2032380983d SHA512 52328cce39c2c24b2de14bd5c90b7959f586161da1c394a359659e6fb9f63ff86e7dd899062499ab4e54293ee37fc423e186cebac825f9e288f7790c8d8b43c7
MISC metadata.xml 378 BLAKE2B 569717fcbe03797e4b5dd1fa859bddbb5947d1f4e51687c05ec955d23d85ba3c1b2cac0eaaa5221800e7db719c5106b1e2f3e9ba3e9594eff649ff2642b154bb SHA512 d5c104ddf9fbd660f6e57e6fb2543c0b5a166f6fc32a7f719a749641ba1a154781ee3745759ad649cba02815607b238b8a85f68580a3830d6d59f143f1dcce0c
diff --git a/net-mail/public-inbox/public-inbox-1.9.0_p20240422.ebuild b/net-mail/public-inbox/public-inbox-1.9.0_p20240422.ebuild
new file mode 100644
index 000000000000..dc0974b2946d
--- /dev/null
+++ b/net-mail/public-inbox/public-inbox-1.9.0_p20240422.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="An archives-first approach to mailing lists"
+HOMEPAGE="https://public-inbox.org"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="
+ https://public-inbox.org/public-inbox.git/
+ https://repo.or.cz/public-inbox.git
+ "
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ PUBLIC_INBOX_COMMIT="488958385c6b8974b8780fb44b91c481e57c2eea"
+ SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${PUBLIC_INBOX_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PUBLIC_INBOX_COMMIT}
+else
+ SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${P}.tar.gz"
+fi
+
+LICENSE="AGPL-3+"
+SLOT="0"
+if [[ ${PV} != 9999 ]] ; then
+ KEYWORDS="~amd64"
+fi
+
+# in order of mention in INSTALL.html, going more for feature completeness
+# than for minimal footprint
+RDEPEND="
+ dev-perl/BSD-Resource
+ dev-perl/DBD-SQLite
+ dev-perl/Email-Address-XS
+ dev-perl/Inline-C
+ dev-perl/Linux-Inotify2
+ dev-perl/Mail-IMAPClient
+ dev-perl/Net-Server
+ dev-perl/Parse-RecDescent
+ dev-perl/Plack
+ dev-perl/Search-Xapian
+ dev-perl/TimeDate
+ dev-perl/URI
+ dev-vcs/git
+ net-misc/curl
+ virtual/mta
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
diff --git a/net-mail/public-inbox/public-inbox-9999.ebuild b/net-mail/public-inbox/public-inbox-9999.ebuild
index e3774a99b324..dc0974b2946d 100644
--- a/net-mail/public-inbox/public-inbox-9999.ebuild
+++ b/net-mail/public-inbox/public-inbox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]] ; then
"
inherit git-r3
elif [[ ${PV} == *_p* ]] ; then
- PUBLIC_INBOX_COMMIT="1febc5cbb633cf7eac7dcaf382dd0ebbfe085380"
+ PUBLIC_INBOX_COMMIT="488958385c6b8974b8780fb44b91c481e57c2eea"
SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${PUBLIC_INBOX_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/${PUBLIC_INBOX_COMMIT}
else