summaryrefslogtreecommitdiff
path: root/net-libs/libbloom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /net-libs/libbloom
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'net-libs/libbloom')
-rw-r--r--net-libs/libbloom/Manifest2
-rw-r--r--net-libs/libbloom/libbloom-1.5-r1.ebuild (renamed from net-libs/libbloom/libbloom-1.5.ebuild)8
2 files changed, 8 insertions, 2 deletions
diff --git a/net-libs/libbloom/Manifest b/net-libs/libbloom/Manifest
index 2e361babc44d..a19fb5b68ff0 100644
--- a/net-libs/libbloom/Manifest
+++ b/net-libs/libbloom/Manifest
@@ -1,3 +1,3 @@
DIST libbloom-1.5.tar.gz 1210081 BLAKE2B 8af463c487c2898c5a4cf3f7541490e2b069d4667ccda4b536f347535be5c7f5664c8ee17e0789ac5325feb8f325ae30a89e2de34323962e89378724cf130a84 SHA512 0dd69e3ee102e5808ba4350c71d212876db56235e263f8d5a66d6c3616d2e51cc18b5ca3a5a946d79c12751d9cc5667f7c633d77645c4b88a4d16ea344b51929
-EBUILD libbloom-1.5.ebuild 465 BLAKE2B ebabfdbbe91d970999ffc2d4d4e855a7fa99ebc940b5b0dd6a058726eb76190aa4ce32639eb7b5cfc61ddecadf9f3c136789c9e802b7cbde690e3455b1f3fd08 SHA512 26f81fa54486c1a0524305e5cfc57a22d1bc56b6049c58cf0a3b8b70bd3f879c737f004a935c633b6144d83ad4b35bf6086d2ce80a582574b8d6b1c1b2bf6bd0
+EBUILD libbloom-1.5-r1.ebuild 546 BLAKE2B b456b74c3cdf402a327734716cf2547d232277b9a280b1f77f22735e9e40bedb246c439f1122ff64bcbd99d352b29ecba28ec281a2a5da895703abfe897efdbb SHA512 36f2d61b296fb01d533e7038b3efa3ac582de7d16c4501d60c6c6de1e04adea5bd5f2535b7d3ca803429c3ba6f2f47bc1832b527bbaf60a254e885e71258ce3a
MISC metadata.xml 321 BLAKE2B b9276958b83d4101521b0946b8cd6db70acfc4e7257fe1773cf0e85a1f6d9434c2d27022f3628578aad4156fedafd635f89c273b09933918149491c96918d207 SHA512 c744f0f8c72f05d96c85a7dade513d5aae40413450902b66d30a0eff88c92e4f9bbf2a1f0ccfef29bef817115dd85ff7ce4386592a25ee9f5e492a398a9ff4f8
diff --git a/net-libs/libbloom/libbloom-1.5.ebuild b/net-libs/libbloom/libbloom-1.5-r1.ebuild
index 665848c2f38d..7e255245ef90 100644
--- a/net-libs/libbloom/libbloom-1.5.ebuild
+++ b/net-libs/libbloom/libbloom-1.5-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="A simple and small bloom filter implementation in plain C."
HOMEPAGE="https://github.com/jvirkki/libbloom"
SRC_URI="https://github.com/jvirkki/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -15,6 +17,10 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
+src_compile() {
+ emake CC=$(tc-getCC) BITS=default OPT=
+}
+
src_install() {
doheader bloom.h
dolib.so build/${PN}.so*