summaryrefslogtreecommitdiff
path: root/net-libs/libbloom/libbloom-1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libbloom/libbloom-1.5-r1.ebuild')
-rw-r--r--net-libs/libbloom/libbloom-1.5-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libbloom/libbloom-1.5-r1.ebuild b/net-libs/libbloom/libbloom-1.5-r1.ebuild
new file mode 100644
index 000000000000..7e255245ef90
--- /dev/null
+++ b/net-libs/libbloom/libbloom-1.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple and small bloom filter implementation in plain C."
+HOMEPAGE="https://github.com/jvirkki/libbloom"
+SRC_URI="https://github.com/jvirkki/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC=$(tc-getCC) BITS=default OPT=
+}
+
+src_install() {
+ doheader bloom.h
+ dolib.so build/${PN}.so*
+}