summaryrefslogtreecommitdiff
path: root/net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild')
-rw-r--r--net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild b/net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild
new file mode 100644
index 000000000000..7bdabd41a8ef
--- /dev/null
+++ b/net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="QML bindings for accounts-qt and signond"
+HOMEPAGE="https://accounts-sso.gitlab.io/"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}-module/-/archive/VERSION_${PV}/${PN}-module-VERSION_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ net-libs/accounts-qt
+ net-libs/signond
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtgui:5
+ dev-qt/qttest:5
+ )
+"
+
+# dbus problems
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-no-tests.patch" )
+
+S="${WORKDIR}/${PN}-module-VERSION_${PV}"
+
+src_prepare() {
+ default
+ sed -e 's/-Werror//' -i common-project-config.pri || die
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install_subtargets
+}