summaryrefslogtreecommitdiff
path: root/net-libs/accounts-qml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-libs/accounts-qml
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-libs/accounts-qml')
-rw-r--r--net-libs/accounts-qml/Manifest4
-rw-r--r--net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild51
-rw-r--r--net-libs/accounts-qml/files/accounts-qml-0.7-no-tests.patch14
-rw-r--r--net-libs/accounts-qml/metadata.xml8
4 files changed, 77 insertions, 0 deletions
diff --git a/net-libs/accounts-qml/Manifest b/net-libs/accounts-qml/Manifest
new file mode 100644
index 000000000000..1a24d71a55dd
--- /dev/null
+++ b/net-libs/accounts-qml/Manifest
@@ -0,0 +1,4 @@
+AUX accounts-qml-0.7-no-tests.patch 307 BLAKE2B 2faefed0d6de1d0f271aece811b5fa064bf67017a8964ad4cd83d2b618e30cce6fabc0272ba3fa5949da1229255602a4b86191dd9e27a91c9f95fd20cffb26e1 SHA512 d0b199098bd7993178084b795138fc87282015525d11e14913056fbaa1b0954fd37d2ad6bb56855513d900fa0ea7a4a4beb31de6bdd4338785bcba9eb1df2eba
+DIST accounts-qml-module-VERSION_0.7.tar.gz 62029 BLAKE2B 0924b73868135ad5d9ec7545d5b0ba84f140053f0be4d17f1c6d3754ec19e362af906af60fb45e6405b5d080dd8f63845070815b12e8bfeda30032c9ed172708 SHA512 4e0e5df64d0a477e11f412c0def85d0de1730efff9682790f5339a57d58778282aa8ca0fa201e409b3b9a2a75fea70f10555b1f70224a3b95ab8d44b942cf7e1
+EBUILD accounts-qml-0.7-r1.ebuild 941 BLAKE2B 7e5a5649b875365c11192e0167fbf69e5a52ac4c33104e0a51f4752d22abe7b3ca54dbf6e7e9c94b1c07782216a0dbb887089d27939e227d76c9a0ad6ad323ef SHA512 2572a2dcd978400307954c71608ed1e44654959128d2089492c5dbc7e939a15f279cc7ad8c31e124d709e88ad58b34b64fb2efa6ea84bea1183bd092ad47e564
+MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild b/net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild
new file mode 100644
index 000000000000..7bdabd41a8ef
--- /dev/null
+++ b/net-libs/accounts-qml/accounts-qml-0.7-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="QML bindings for accounts-qt and signond"
+HOMEPAGE="https://accounts-sso.gitlab.io/"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}-module/-/archive/VERSION_${PV}/${PN}-module-VERSION_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ net-libs/accounts-qt
+ net-libs/signond
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtgui:5
+ dev-qt/qttest:5
+ )
+"
+
+# dbus problems
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-no-tests.patch" )
+
+S="${WORKDIR}/${PN}-module-VERSION_${PV}"
+
+src_prepare() {
+ default
+ sed -e 's/-Werror//' -i common-project-config.pri || die
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install_subtargets
+}
diff --git a/net-libs/accounts-qml/files/accounts-qml-0.7-no-tests.patch b/net-libs/accounts-qml/files/accounts-qml-0.7-no-tests.patch
new file mode 100644
index 000000000000..cfe8dec082bb
--- /dev/null
+++ b/net-libs/accounts-qml/files/accounts-qml-0.7-no-tests.patch
@@ -0,0 +1,14 @@
+--- a/accounts-qml-module.pro 2016-06-08 09:26:26.000000000 +0200
++++ b/accounts-qml-module.pro 2019-12-08 14:16:24.058806381 +0100
+@@ -5,8 +5,9 @@
+ TEMPLATE = subdirs
+ CONFIG += ordered
+ SUBDIRS = \
+- src \
+- tests
++ src
++
++CONFIG(tests): SUBDIRS += tests
+
+ include(common-installs-config.pri)
+
diff --git a/net-libs/accounts-qml/metadata.xml b/net-libs/accounts-qml/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/net-libs/accounts-qml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>