summaryrefslogtreecommitdiff
path: root/net-irc/limnoria-plugins-jlu5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /net-irc/limnoria-plugins-jlu5
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'net-irc/limnoria-plugins-jlu5')
-rw-r--r--net-irc/limnoria-plugins-jlu5/Manifest5
-rw-r--r--net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild41
-rw-r--r--net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild41
-rw-r--r--net-irc/limnoria-plugins-jlu5/metadata.xml13
4 files changed, 100 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-jlu5/Manifest b/net-irc/limnoria-plugins-jlu5/Manifest
new file mode 100644
index 000000000000..e8cb1829f939
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/Manifest
@@ -0,0 +1,5 @@
+DIST limnoria-plugins-jlu5-20200105_p20210305.tar.gz 95273 BLAKE2B cfdea4fadbfa050c56dd0f307cf43506391d0e35e31b46a649aaf70cfd4c8979e14192d66af408e33b4cc8c0e1917fdb5d2d2cf86029a9b6b204a56936c22b76 SHA512 b031cd9be28989499ed063e8bd2af8079415075710be4dcfd73051eb325e2e321a1589c6d7adc69a0e5ce8b4a0a96c4bb6b1108c4ee479bc074b70738727dd64
+DIST limnoria-plugins-jlu5-20200105_p20210530.tar.gz 99973 BLAKE2B a67e53a75a99ed406782cc74cc93c19ad4e7298a4e9b47781559609c7ed77fed157febb646147254f0fb8e73627f1fdfa23e80cd1893d394c779ee54f93357d9 SHA512 03f537b7100a747c408a754d368e679ceea313747cd27dea9ca26cc7d3cf9b4319faf37656b0c7b5134d8ca6a94a9bbf4c345aa8015bcab2a99648d38dddc272
+EBUILD limnoria-plugins-jlu5-20200105_p20210305.ebuild 1031 BLAKE2B 19ce4496278d49f9bdde443be28309603012c04833fbc680a4461b0d12dd9a522f647ef68c60010fa1e183dc103d9c7c4ad74b953b61f93569ddce7cc877d448 SHA512 c9a26be989eb83338568148d90bd64d32cc0b32d6230c3492c5de9d52c44b5e92f57af199ac14dfcc5ee9b2752a7fc1f165d281f504d2714471cfc7b58f26958
+EBUILD limnoria-plugins-jlu5-20200105_p20210530.ebuild 1031 BLAKE2B b594e855da77e4b4b811d25092f087cce7c59fbcf2a6732c2fbf54fd030515ba69844b2a8755c484f59b4eca1df9ef9211251de6b082f6e13a3dbf0904ff98a2 SHA512 fe89093287d636b27406234d70afeefcff7a54914439e6f32b918c8d0a40574ae46bbebd1661bf5cd10e6f02d20cee539c8462debe866525f7eabd68a75d647b
+MISC metadata.xml 411 BLAKE2B bed572da8c5e82c8cda548c287e3ecdfbfc8b7db97144f55b8d5e075eb794e6f1c6ff6c20eb3be15f01f71e244ecc9d64a112886b990cd5a09659b836e8102df SHA512 63d0c4ce1e98bb3068293b6f7fd33842085be1d7edfc4f3f63f9ceadda23531e99abb0e6a1ec1877baec3e8f0a1e6edda5742085a615c9404e0975d1fd102ddd
diff --git a/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild
new file mode 100644
index 000000000000..49b7c565b8c5
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="f9b6b4c24786460a4ad12d39af4d7865ebdf2904"
+
+DESCRIPTION="A collection of plugins for the Limnoria IRC bot."
+HOMEPAGE="https://github.com/jlu5/SupyPlugins"
+SRC_URI="https://github.com/jlu5/SupyPlugins/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="
+ net-irc/limnoria
+ dev-python/beautifulsoup
+"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/jlu5
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before these plugins can be used, your bot will need to be told where to"
+ elog "load them from. To do this, add /usr/share/limnoria-extra-plugins/jlu5 when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/jlu5"
+}
diff --git a/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild
new file mode 100644
index 000000000000..9d1174845dfb
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="7e695c00dfb665a16ff4f1d66ad3deb4598ea029"
+
+DESCRIPTION="A collection of plugins for the Limnoria IRC bot."
+HOMEPAGE="https://github.com/jlu5/SupyPlugins"
+SRC_URI="https://github.com/jlu5/SupyPlugins/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="
+ net-irc/limnoria
+ dev-python/beautifulsoup
+"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/jlu5
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before these plugins can be used, your bot will need to be told where to"
+ elog "load them from. To do this, add /usr/share/limnoria-extra-plugins/jlu5 when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/jlu5"
+}
diff --git a/net-irc/limnoria-plugins-jlu5/metadata.xml b/net-irc/limnoria-plugins-jlu5/metadata.xml
new file mode 100644
index 000000000000..a90483a553af
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wraeth@gentoo.org</email>
+ <name>Sam Jorna</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jlu5/SupyPlugins</remote-id>
+ <bugs-to>https://github.com/jlu5/SupyPlugins/issues</bugs-to>
+ </upstream>
+</pkgmetadata>