summaryrefslogtreecommitdiff
path: root/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild')
-rw-r--r--net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild
new file mode 100644
index 000000000000..49b7c565b8c5
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210305.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="f9b6b4c24786460a4ad12d39af4d7865ebdf2904"
+
+DESCRIPTION="A collection of plugins for the Limnoria IRC bot."
+HOMEPAGE="https://github.com/jlu5/SupyPlugins"
+SRC_URI="https://github.com/jlu5/SupyPlugins/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="
+ net-irc/limnoria
+ dev-python/beautifulsoup
+"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/jlu5
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before these plugins can be used, your bot will need to be told where to"
+ elog "load them from. To do this, add /usr/share/limnoria-extra-plugins/jlu5 when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/jlu5"
+}