summaryrefslogtreecommitdiff
path: root/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild')
-rw-r--r--net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild
new file mode 100644
index 000000000000..9d1174845dfb
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210530.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="7e695c00dfb665a16ff4f1d66ad3deb4598ea029"
+
+DESCRIPTION="A collection of plugins for the Limnoria IRC bot."
+HOMEPAGE="https://github.com/jlu5/SupyPlugins"
+SRC_URI="https://github.com/jlu5/SupyPlugins/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="
+ net-irc/limnoria
+ dev-python/beautifulsoup
+"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/jlu5
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before these plugins can be used, your bot will need to be told where to"
+ elog "load them from. To do this, add /usr/share/limnoria-extra-plugins/jlu5 when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/jlu5"
+}