summaryrefslogtreecommitdiff
path: root/net-im/dino/dino-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-im/dino/dino-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-im/dino/dino-9999.ebuild')
-rw-r--r--net-im/dino/dino-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index 937678aeb91c..87038c75d2fd 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -11,14 +11,14 @@ DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
LICENSE="GPL-3"
SLOT="0"
-IUSE="+gpg +http +omemo"
+IUSE="+gpg +http +omemo +notification-sound"
MY_REPO_URI="https://github.com/dino/dino"
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="${MY_REPO_URI}.git"
inherit git-r3
else
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
fi
@@ -39,6 +39,7 @@ RDEPEND="
dev-libs/libgcrypt:0
media-gfx/qrencode
)
+ notification-sound? ( media-libs/libcanberra:0[sound] )
"
DEPEND="
$(vala_depend)
@@ -57,7 +58,11 @@ src_configure() {
$(usex omemo "" "omemo")
$(usex http "" "http-files")
)
+ local enabled_plugins=(
+ $(usex notification-sound "notification-sound" "")
+ )
local mycmakeargs+=(
+ "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
"-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
"-DVALA_EXECUTABLE=${VALAC}"
)