summaryrefslogtreecommitdiff
path: root/net-im/dino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-im/dino
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/Manifest6
-rw-r--r--net-im/dino/dino-0.2.0.ebuild92
-rw-r--r--net-im/dino/dino-9999.ebuild9
-rw-r--r--net-im/dino/metadata.xml1
4 files changed, 104 insertions, 4 deletions
diff --git a/net-im/dino/Manifest b/net-im/dino/Manifest
index 861e2d1630cc..30b271fa2cc2 100644
--- a/net-im/dino/Manifest
+++ b/net-im/dino/Manifest
@@ -1,4 +1,6 @@
DIST dino-0.1.0.tar.gz 441638 BLAKE2B 08f332d38af866eed1049fae7d0e207da5a3486fdaf07eb5327e7abf614ac4adc130fd8f2d9465d6cb248ecfe4b809e022a69c72df5879d98719d24635771b33 SHA512 b63bf87dbf7f728f038f22d0dba34770a06d7eb1be2ec249293ff876e16c151165add895ff3cb20a3216c3581d20e10634d454ee8b024b895012efb34f9d7de8
+DIST dino-0.2.0.tar.gz 514257 BLAKE2B a4536372a806fa60e157a6492381b0204f33041b113dc26dfd4d494c86c96e5b94e928c400fde3198e481aecbfc79d0358979d4a20c550e35f762b3520e2f7c0 SHA512 296576f91d45a4dd8c548a7ca5b47bcaf847f6ff0f8e5dbafaa4eb49a2d4f1ed7e2bbfac94f1b32e22f5ec61b23748ac76b12bb4ceb710889aff166953ca7a2e
EBUILD dino-0.1.0.ebuild 1597 BLAKE2B ddcce77114ef37406b2c31eec69eb8d38a7cd476c150f0c9305aabcb9afd2e5c6f46d6310a78a8811d0c04f98b154638982cc354eb03d1667d136bbb7bc782c9 SHA512 c67877d9465cd93175f6d591fde849cc6667c84ba0000848f5a40a1233583c1d59afbb90f82584d478e85a2b2a30788898062af77cd6dbaa3b5ff960b08120c5
-EBUILD dino-9999.ebuild 1583 BLAKE2B 864709c4e4a9b34c6b444e1ae40a07b4697f3417be7641f229096bc7309c5e422953aca09d688afb410c4c921bd19457b6366c039f30d22d3357df17578e4686 SHA512 37c77529cae35d8e6ce438cb14fd970734c0cd900e4c0e55013c8996f4e759cdefb7d89890d28cbebf586307e1c1947561ed3ad543d835b504321d4473b46ffe
-MISC metadata.xml 573 BLAKE2B cf7a2731750afde53919e6a41541c0829df4ffa6da202c179092de0640a8ac044445b258350704822d02f302c601738f38f05fc2ab938d6f0ea55bead77b0eae SHA512 7023554fe0c67fd41d9134315500a7206653f34a192673db9bd741af22e05f0a00e431fa96c109c94bab6dbdb31334729bc272a07773dd7b905dd0422ce8532f
+EBUILD dino-0.2.0.ebuild 1817 BLAKE2B b7ad5c532f0903cf7d10bcd074fd21d03d53e45fc9e6bbc451043b72ac94e1b5bfdfa9673abe2f476ef9ba68ee053f36036d30528ad84178b79a797b18a57122 SHA512 7776ff0776e00efa5a343a324246ab7d734cd99a34656608d56d3091bb6796955a042e489de6182f8d516891e4177d5007b24718d57230f192516f6cb6b852dc
+EBUILD dino-9999.ebuild 1817 BLAKE2B b7ad5c532f0903cf7d10bcd074fd21d03d53e45fc9e6bbc451043b72ac94e1b5bfdfa9673abe2f476ef9ba68ee053f36036d30528ad84178b79a797b18a57122 SHA512 7776ff0776e00efa5a343a324246ab7d734cd99a34656608d56d3091bb6796955a042e489de6182f8d516891e4177d5007b24718d57230f192516f6cb6b852dc
+MISC metadata.xml 641 BLAKE2B 31f6c748c2bfe6279a574bf88b94caf476e1769159bdefc2fe4c35095d4e46cb30d6ad232f84cc614f83d1d319004398947fe65f0f9d1fc80dbdeef9497942de SHA512 a1b16eca16c3b7df169db8c7f8a2670cf97fab0c2913dad3ece312aa4e90429944148438b9d2bfd01661912ecffd950104b8324e83b691243841f810e6105ad5
diff --git a/net-im/dino/dino-0.2.0.ebuild b/net-im/dino/dino-0.2.0.ebuild
new file mode 100644
index 000000000000..87038c75d2fd
--- /dev/null
+++ b/net-im/dino/dino-0.2.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+VALA_MIN_API_VERSION="0.34"
+inherit cmake-utils gnome2-utils vala xdg-utils
+
+DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
+HOMEPAGE="https://dino.im"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+gpg +http +omemo +notification-sound"
+
+MY_REPO_URI="https://github.com/dino/dino"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="${MY_REPO_URI}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm64"
+ SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/icu
+ dev-libs/libgee:0.8
+ net-libs/glib-networking
+ net-libs/libsignal-protocol-c
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ gpg? ( app-crypt/gpgme:1 )
+ http? ( net-libs/libsoup:2.4 )
+ omemo? (
+ dev-libs/libgcrypt:0
+ media-gfx/qrencode
+ )
+ notification-sound? ( media-libs/libcanberra:0[sound] )
+"
+DEPEND="
+ $(vala_depend)
+ ${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local disabled_plugins=(
+ $(usex gpg "" "openpgp")
+ $(usex omemo "" "omemo")
+ $(usex http "" "http-files")
+ )
+ local enabled_plugins=(
+ $(usex notification-sound "notification-sound" "")
+ )
+ local mycmakeargs+=(
+ "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
+ "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
+ "-DVALA_EXECUTABLE=${VALAC}"
+ )
+
+ if has test ${FEATURES}; then
+ mycmakeargs+=("-DBUILD_TESTS=yes")
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/xmpp-vala-test || die
+}
+
+update_caches() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postinst() {
+ update_caches
+}
+
+pkg_postrm() {
+ update_caches
+}
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index 937678aeb91c..87038c75d2fd 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -11,14 +11,14 @@ DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
LICENSE="GPL-3"
SLOT="0"
-IUSE="+gpg +http +omemo"
+IUSE="+gpg +http +omemo +notification-sound"
MY_REPO_URI="https://github.com/dino/dino"
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="${MY_REPO_URI}.git"
inherit git-r3
else
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
fi
@@ -39,6 +39,7 @@ RDEPEND="
dev-libs/libgcrypt:0
media-gfx/qrencode
)
+ notification-sound? ( media-libs/libcanberra:0[sound] )
"
DEPEND="
$(vala_depend)
@@ -57,7 +58,11 @@ src_configure() {
$(usex omemo "" "omemo")
$(usex http "" "http-files")
)
+ local enabled_plugins=(
+ $(usex notification-sound "notification-sound" "")
+ )
local mycmakeargs+=(
+ "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
"-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
"-DVALA_EXECUTABLE=${VALAC}"
)
diff --git a/net-im/dino/metadata.xml b/net-im/dino/metadata.xml
index 05d64fd0a3f9..65da392eaa06 100644
--- a/net-im/dino/metadata.xml
+++ b/net-im/dino/metadata.xml
@@ -13,5 +13,6 @@
<flag name="gpg">Enable OpenPGP encryption plugin</flag>
<flag name="http">Enable HTTP file upload plugin</flag>
<flag name="omemo">Enable OMEMO encryption plugin</flag>
+ <flag name="notification-sound">notification sounds plugin</flag>
</use>
</pkgmetadata>