summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /net-analyzer/wireshark/wireshark-9999.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'net-analyzer/wireshark/wireshark-9999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild53
1 files changed, 22 insertions, 31 deletions
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 145ec1e5d572..01d79e76e7b1 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -18,8 +18,7 @@ else
SRC_URI="https://www.wireshark.org/download/src/all-versions/${P/_/}.tar.xz"
S="${WORKDIR}/${P/_/}"
- # Seems to break libvirt?
- #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86"
fi
LICENSE="GPL-2"
@@ -30,12 +29,14 @@ IUSE+=" +mergecap +minizip +netlink opus +plugins plugin-ifdemo +pcap +qt5 +rand
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump zlib +zstd"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ plugin-ifdemo? ( plugins )"
+
RESTRICT="!test? ( test )"
# bug #753062 for speexdsp
-CDEPEND="
- acct-group/pcap
- >=dev-libs/glib-2.32:2
+RDEPEND="acct-group/pcap
+ >=dev-libs/glib-2.38:2
>=net-dns/c-ares-1.5:=
dev-libs/libgcrypt:=
media-libs/speexdsp
@@ -70,18 +71,12 @@ CDEPEND="
sshdump? ( >=net-libs/libssh-0.6 )
ssl? ( net-libs/gnutls:= )
zlib? ( sys-libs/zlib )
- zstd? ( app-arch/zstd:= )
-"
-# We need perl for `pod2html`. The rest of the perl stuff is to block older
-# and broken installs. #455122
-DEPEND="
- ${CDEPEND}
- ${PYTHON_DEPS}
-"
-BDEPEND="
+ zstd? ( app-arch/zstd:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
dev-lang/perl
- sys-devel/bison
sys-devel/flex
+ sys-devel/gettext
virtual/pkgconfig
doc? (
app-doc/doxygen
@@ -93,17 +88,10 @@ BDEPEND="
test? (
dev-python/pytest
dev-python/pytest-xdist
- )
-"
-RDEPEND="
- ${CDEPEND}
+ )"
+RDEPEND="${RDEPEND}
qt5? ( virtual/freedesktop-icon-theme )
- selinux? ( sec-policy/selinux-wireshark )
-"
-REQUIRED_USE="
- lua? ( ${LUA_REQUIRED_USE} )
- plugin-ifdemo? ( plugins )
-"
+ selinux? ( sec-policy/selinux-wireshark )"
PATCHES=(
"${FILESDIR}"/${PN}-2.6.0-redhat.patch
@@ -119,7 +107,7 @@ src_configure() {
# Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
# --with-ssl to ./configure. (Mimics code from acinclude.m4).
- if use kerberos; then
+ if use kerberos ; then
case $(krb5-config --libs) in
*-lcrypto*)
ewarn "Kerberos was built with ssl support: linkage with openssl is enabled."
@@ -130,7 +118,7 @@ src_configure() {
esac
fi
- if use qt5; then
+ if use qt5 ; then
export QT_MIN_VERSION=5.3.0
append-cxxflags -fPIC -DPIC
fi
@@ -138,6 +126,7 @@ src_configure() {
python_setup
mycmakeargs+=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_{Asciidoctor,DOXYGEN}=$(usex !doc)
$(use androiddump && use pcap && echo -DEXTCAP_ANDROIDDUMP_LIBPCAP=yes)
$(usex qt5 LRELEASE=$(qt5_get_bindir)/lrelease '')
$(usex qt5 MOC=$(qt5_get_bindir)/moc '')
@@ -237,19 +226,21 @@ src_install() {
doins ${dir}/*.h
done
- if use qt5; then
+ if use qt5 ; then
local s
- for s in 16 32 48 64 128 256 512 1024; do
+
+ for s in 16 32 48 64 128 256 512 1024 ; do
insinto /usr/share/icons/hicolor/${s}x${s}/apps
newins image/wsicon${s}.png wireshark.png
done
+
for s in 16 24 32 48 64 128 256 ; do
insinto /usr/share/icons/hicolor/${s}x${s}/mimetypes
newins image/WiresharkDoc-${s}.png application-vnd.tcpdump.pcap.png
done
fi
- if [[ -d "${ED}"/usr/share/appdata ]]; then
+ if [[ -d "${ED}"/usr/share/appdata ]] ; then
rm -r "${ED}"/usr/share/appdata || die
fi
}
@@ -262,7 +253,7 @@ pkg_postinst() {
# Add group for users allowed to sniff.
chgrp pcap "${EROOT}"/usr/bin/dumpcap
- if use dumpcap && use pcap; then
+ if use dumpcap && use pcap ; then
fcaps -o 0 -g pcap -m 4710 -M 0710 \
cap_dac_read_search,cap_net_raw,cap_net_admin \
"${EROOT}"/usr/bin/dumpcap