summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /net-analyzer/wireshark/wireshark-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'net-analyzer/wireshark/wireshark-9999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 4871d3fcafeb..145ec1e5d572 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
LUA_COMPAT=( lua5-{1..2} )
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg-utils cmake
@@ -18,7 +18,8 @@ else
SRC_URI="https://www.wireshark.org/download/src/all-versions/${P/_/}.tar.xz"
S="${WORKDIR}/${P/_/}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86"
+ # Seems to break libvirt?
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86"
fi
LICENSE="GPL-2"
@@ -29,6 +30,8 @@ IUSE+=" +mergecap +minizip +netlink opus +plugins plugin-ifdemo +pcap +qt5 +rand
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump zlib +zstd"
+RESTRICT="!test? ( test )"
+
# bug #753062 for speexdsp
CDEPEND="
acct-group/pcap
@@ -102,12 +105,9 @@ REQUIRED_USE="
plugin-ifdemo? ( plugins )
"
-RESTRICT="test"
-
PATCHES=(
"${FILESDIR}"/${PN}-2.6.0-redhat.patch
"${FILESDIR}"/${PN}-3.4.2-cmake-lua-version.patch
- "${FILESDIR}"/${PN}-9999-ui-needs-wiretap.patch
)
pkg_setup() {
@@ -200,6 +200,9 @@ src_test() {
--disable-capture
--skip-missing-programs=all
--verbose
+
+ # Skip known failing tests
+ -E "(suite_decryption|suite_extcaps|suite_nameres)"
)
cmake_src_test
@@ -214,17 +217,19 @@ src_install() {
# install headers
insinto /usr/include/wireshark
doins ws_diag_control.h ws_symbol_export.h \
- "${BUILD_DIR}"/config.h "${BUILD_DIR}"/version.h
+ "${BUILD_DIR}"/config.h
+ # If trying to remove this, try build e.g. libvirt first!
+ # At last check, Fedora is still doing this too.
local dir dirs=(
epan
epan/crypt
epan/dfilter
epan/dissectors
epan/ftypes
- epan/wmem
wiretap
wsutil
+ wsutil/wmem
)
for dir in "${dirs[@]}" ; do
@@ -232,11 +237,6 @@ src_install() {
doins ${dir}/*.h
done
- #with the above this really shouldn't be needed, but things may be looking
- # in wiretap/ instead of wireshark/wiretap/
- insinto /usr/include/wiretap
- doins wiretap/wtap.h
-
if use qt5; then
local s
for s in 16 32 48 64 128 256 512 1024; do