summaryrefslogtreecommitdiff
path: root/net-analyzer/webfuzzer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-analyzer/webfuzzer/files
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-analyzer/webfuzzer/files')
-rw-r--r--net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch24
-rw-r--r--net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch37
2 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch
new file mode 100644
index 000000000000..9c40ecf167f7
--- /dev/null
+++ b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ # Makefile for Webfuzzer (c) gunzip
+ #
+
+-CFLAGS=-g -O3 -Wall -DCOLORS
++CFLAGS+= -Wall -DCOLORS
+ CC=gcc
+ LIBS=-lsocket -lnsl -lresolv
+ MOBJS=util.o getpost.o header.o parseform.o hash.o network.o parselinks.o cookies.o webfuzzer.o
+@@ -13,10 +13,10 @@
+ default: webfuzzer
+
+ webfuzzer: main.c $(MOBJS)
+- $(CC) $(CFLAGS) -o webfuzzer main.c $(MOBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o webfuzzer main.c $(MOBJS)
+
+ sunos: main.c $(MOBJS)
+- $(CC) $(CFLAGS) -o webfuzzer main.c $(MOBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o webfuzzer main.c $(MOBJS) $(LIBS)
+
+ clean:
+ rm -rf *.o webfuzzer core
diff --git a/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch
new file mode 100644
index 000000000000..ca40c4ee4f81
--- /dev/null
+++ b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch
@@ -0,0 +1,37 @@
+--- a/webfuzzer.h
++++ b/webfuzzer.h
+@@ -30,11 +30,11 @@
+ /**
+ ** GLOBAL HASHTABLES
+ **/
+-struct node * HTlinks[ HT_SIZE ];
+-struct node * HTforms[ HT_SIZE ];
+-struct node * HTusers[ HT_SIZE ];
+-struct node * HTtools[ HT_SIZE ];
+-struct node * HTcookies[ HT_SIZE ];
++extern struct node * HTlinks[ HT_SIZE ];
++extern struct node * HTforms[ HT_SIZE ];
++extern struct node * HTusers[ HT_SIZE ];
++extern struct node * HTtools[ HT_SIZE ];
++extern struct node * HTcookies[ HT_SIZE ];
+
+ #define VERSION "0.2.0"
+ #define BANNER GREEN "Webfuzzer " DEF VERSION " (c) gunzip"
+--- a/webfuzzer.c
++++ b/webfuzzer.c
+@@ -29,6 +29,15 @@
+ #include "technic.h"
+
+ /**
++ ** GLOBAL HASHTABLES
++ **/
++struct node * HTlinks[ HT_SIZE ];
++struct node * HTforms[ HT_SIZE ];
++struct node * HTusers[ HT_SIZE ];
++struct node * HTtools[ HT_SIZE ];
++struct node * HTcookies[ HT_SIZE ];
++
++/**
+ ** PROTOTYPES
+ **/
+