summaryrefslogtreecommitdiff
path: root/net-analyzer/webfuzzer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-analyzer/webfuzzer
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-analyzer/webfuzzer')
-rw-r--r--net-analyzer/webfuzzer/Manifest3
-rw-r--r--net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch24
-rw-r--r--net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch37
-rw-r--r--net-analyzer/webfuzzer/webfuzzer-0.2.0-r2.ebuild28
4 files changed, 92 insertions, 0 deletions
diff --git a/net-analyzer/webfuzzer/Manifest b/net-analyzer/webfuzzer/Manifest
index 7be26578da97..d6e37b56798d 100644
--- a/net-analyzer/webfuzzer/Manifest
+++ b/net-analyzer/webfuzzer/Manifest
@@ -1,3 +1,6 @@
+AUX webfuzzer-0.2.0-flags.patch 640 BLAKE2B f403d4505c912314e9966b17ac20b1c883c2bfad705dde711105fd10f20c7ab71dd3b29069398e1ee8532628893e94273e9eff9e710039aaa6f5c4e913075cdf SHA512 3c9827a44b1a3c6aa8851eb791eb61b43d7760cec4d77366491afeebf3db6d32ae836a7dc5ab475cccf70020d90ec96a9cf98ef933cb9d3e205cd84ae3352bac
+AUX webfuzzer-0.2.0-fno-common.patch 896 BLAKE2B 018272d0921634b669211a32f5a31e05abf5a6822701f3e3fc17034a6d3a3095cc7325b36b91041a889cc8e038531e02f32958849995903dcd539e0cc7ca4236 SHA512 5c62759e17809be3f26efd52043608408b1dbc493e07b72bc514cb0e73f92461c6c14994e0597c2efd1a1b0d44544e74b1aca9221025f7859b5e10a1ede8060d
DIST webfuzzer-0.2.0.tar.gz 29664 BLAKE2B 38c03f826c99887d8e8531a19634b250a73dad5cfa92386a033015c354739ba403c90faf9b0e99ac705ecd42cafe564d11edff9bdb71b9c4b29c048cbe64c1cc SHA512 7cb858178dd11e7b6020f2b0db1092462401aab552af6bdb8b8c95c018bd35572a981338226def07dc45ed8f0b5a0b282ad681e9d86bec14d14ffd623518082e
EBUILD webfuzzer-0.2.0-r1.ebuild 613 BLAKE2B 364a247e782af1584e2bd3f4c899367a7ab92880d2bb58e847940b5615c0e06c3bf4b0f62d0f30c4a249015dc898639863dd517fffc2254824f17b3fafa930d8 SHA512 e70b8c6c76fa58c93e90b3924d7a98ffc3da0f23e8c09943e12946a44f54dba5a6e61fd596e7bee475bc20796beef27903ccebba6da7c83cdd05a77cd090615e
+EBUILD webfuzzer-0.2.0-r2.ebuild 571 BLAKE2B a73aead55c7f50d0a45593af1bd07071dd4b86c849d2d63ffb7d605b8820feb89ee8b7648c1674a8f2458927f7c1ed1d2662b8a0d145c1ea661e89a8e61d151c SHA512 95bbc014327b4807ae76bc318c1faf11c4be82538ad3a1933a2f8271eb2c1d8edb5ae9ee22cc516f4735d771b0ae1d02ae7e94fce03e6c4786640bb65807a85f
MISC metadata.xml 276 BLAKE2B e21811549278e73aa9a14acfe242fd022106a39ac1300caa00615772d7f54d08a433052659a271f9ac0d453c7776fc2b9e8d86e6d3f637817c214174dde52cb2 SHA512 f0e6c6bc89659e01e157d9bf30d0a2f3fd2d71bc26c8d12489c4a44fc5237159946e25b46e7295ab4676aea63559194977a0b1e76aced31d81cf6387dd0f4250
diff --git a/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch
new file mode 100644
index 000000000000..9c40ecf167f7
--- /dev/null
+++ b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-flags.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ # Makefile for Webfuzzer (c) gunzip
+ #
+
+-CFLAGS=-g -O3 -Wall -DCOLORS
++CFLAGS+= -Wall -DCOLORS
+ CC=gcc
+ LIBS=-lsocket -lnsl -lresolv
+ MOBJS=util.o getpost.o header.o parseform.o hash.o network.o parselinks.o cookies.o webfuzzer.o
+@@ -13,10 +13,10 @@
+ default: webfuzzer
+
+ webfuzzer: main.c $(MOBJS)
+- $(CC) $(CFLAGS) -o webfuzzer main.c $(MOBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o webfuzzer main.c $(MOBJS)
+
+ sunos: main.c $(MOBJS)
+- $(CC) $(CFLAGS) -o webfuzzer main.c $(MOBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o webfuzzer main.c $(MOBJS) $(LIBS)
+
+ clean:
+ rm -rf *.o webfuzzer core
diff --git a/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch
new file mode 100644
index 000000000000..ca40c4ee4f81
--- /dev/null
+++ b/net-analyzer/webfuzzer/files/webfuzzer-0.2.0-fno-common.patch
@@ -0,0 +1,37 @@
+--- a/webfuzzer.h
++++ b/webfuzzer.h
+@@ -30,11 +30,11 @@
+ /**
+ ** GLOBAL HASHTABLES
+ **/
+-struct node * HTlinks[ HT_SIZE ];
+-struct node * HTforms[ HT_SIZE ];
+-struct node * HTusers[ HT_SIZE ];
+-struct node * HTtools[ HT_SIZE ];
+-struct node * HTcookies[ HT_SIZE ];
++extern struct node * HTlinks[ HT_SIZE ];
++extern struct node * HTforms[ HT_SIZE ];
++extern struct node * HTusers[ HT_SIZE ];
++extern struct node * HTtools[ HT_SIZE ];
++extern struct node * HTcookies[ HT_SIZE ];
+
+ #define VERSION "0.2.0"
+ #define BANNER GREEN "Webfuzzer " DEF VERSION " (c) gunzip"
+--- a/webfuzzer.c
++++ b/webfuzzer.c
+@@ -29,6 +29,15 @@
+ #include "technic.h"
+
+ /**
++ ** GLOBAL HASHTABLES
++ **/
++struct node * HTlinks[ HT_SIZE ];
++struct node * HTforms[ HT_SIZE ];
++struct node * HTusers[ HT_SIZE ];
++struct node * HTtools[ HT_SIZE ];
++struct node * HTcookies[ HT_SIZE ];
++
++/**
+ ** PROTOTYPES
+ **/
+
diff --git a/net-analyzer/webfuzzer/webfuzzer-0.2.0-r2.ebuild b/net-analyzer/webfuzzer/webfuzzer-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..66622a2b52db
--- /dev/null
+++ b/net-analyzer/webfuzzer/webfuzzer-0.2.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Poor man's web vulnerability scanner"
+HOMEPAGE="http://gunzip.altervista.org/g.php?f=projects"
+SRC_URI="http://gunzip.altervista.org/webfuzzer/webfuzzer-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/devel
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dodoc CHANGES README TODO
+ dobin webfuzzer
+}