summaryrefslogtreecommitdiff
path: root/net-analyzer/wapiti/wapiti-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-analyzer/wapiti/wapiti-9999.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-analyzer/wapiti/wapiti-9999.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-9999.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/net-analyzer/wapiti/wapiti-9999.ebuild b/net-analyzer/wapiti/wapiti-9999.ebuild
index 95c1263aa07a..e9d25d0eedfd 100644
--- a/net-analyzer/wapiti/wapiti-9999.ebuild
+++ b/net-analyzer/wapiti/wapiti-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE='xml'
inherit distutils-r1 git-r3
@@ -15,25 +15,33 @@ EGIT_REPO_URI="https://git.code.sf.net/p/wapiti/git wapiti-git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="kerberos ntlm"
+# Requires httpx-ntlm (to package)
+#IUSE="ntlm"
+# httpx requires brotli and socks, so depending on
+# dev-python/socksio and dev-python/brotlicffi
RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
>=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
dev-python/tld[${PYTHON_USEDEP}]
- dev-python/yaswfp[${PYTHON_USEDEP}]
- kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
- ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+ dev-python/yaswfp[${PYTHON_USEDEP}]"
distutils_enable_tests --install pytest
-BDEPEND+=" test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+# Tests also require unpackaged respx
+BDEPEND+=" test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
# Many tests require execution of local test php server
RESTRICT="test"
python_prepare_all() {
sed -e 's/"pytest-runner"//' \
- -e "/find_packages/s/()/(exclude=['tests*'])/" \
-e "/DOC_DIR =/s/wapiti/${PF}/" \
-i setup.py || die
distutils-r1_python_prepare_all