summaryrefslogtreecommitdiff
path: root/net-analyzer/wapiti
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-analyzer/wapiti
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-analyzer/wapiti')
-rw-r--r--net-analyzer/wapiti/Manifest4
-rw-r--r--net-analyzer/wapiti/wapiti-3.1.2.ebuild51
-rw-r--r--net-analyzer/wapiti/wapiti-9999.ebuild26
3 files changed, 71 insertions, 10 deletions
diff --git a/net-analyzer/wapiti/Manifest b/net-analyzer/wapiti/Manifest
index 0d835c357623..aa78d4817867 100644
--- a/net-analyzer/wapiti/Manifest
+++ b/net-analyzer/wapiti/Manifest
@@ -1,4 +1,6 @@
DIST wapiti3-3.0.5.tar.gz 573630 BLAKE2B 4f6425c54542e3fcf12f50a7ebe4aeeb38083bd04e6a9415466a24ca907e787149b6462972cb6c9d29f4c89bf1f941ae2566b126746bee3697172f342befd7fb SHA512 c1bfdcd4114ec508b4b16e7a4389b23b25326816c7daf0e7fb634ce08b59b983dec92f92287a18cbe7ecde9a06a04da98cfd744f818efc57c606be143fe7db4d
+DIST wapiti3-3.1.2.tar.gz 654586 BLAKE2B 6abbb35060ef554e8b803a82744527a361fe3803871b39dc078938c4af70a3f6e1a2adeec95c0ff487aff650d92a3638cb655439d342c2b516a5279ee02af472 SHA512 cd16d5b265a49441ad45341630ea6a2df150172b774d3282ee229b5a73274eed293ad35c6fc5e26443dc96f1437dcd28b77240210840c65cb3f1f7b6e9234c2d
EBUILD wapiti-3.0.5.ebuild 1178 BLAKE2B 89931c4319e7a120ac3fe1e06770a11691d75c41c8208e01b611448cc6bbe7b6b8d24ced28b79bc4ffd0ce5cb09607088ae6c255b93be9216623064a40e8ef5c SHA512 57d8831c22c3473923c546badfe52c067dbbc75b0bd263274d7f7ec7aa26e30f47722d1a96a5edea44e67191ad121e253652c5976bc94fc896cad4f76724a615
-EBUILD wapiti-9999.ebuild 1146 BLAKE2B aa89174a5e38d39699307d03660b2d73462cf76c46aa36b4e2795c7ba8a172f2864a5ac777a7d8b762b97962167f905bb712bddefc99b597c783adc3eb457346 SHA512 f7282751bcf844410cf488b83ebeefb0cc432f397d1bb57f3768eba2ce403f32868f1af336d601b5eb2ebaca905427fcbd39186b2f85167fe609e36cc3714a97
+EBUILD wapiti-3.1.2.ebuild 1390 BLAKE2B 562667e0a3c36ce3f4d4257cf19b67fd7016d0b79ea23568824e132209fb63bbcb9fb321b6bb1944de2ee1e173d633125d27f219bab960158a12f30c99ad9e56 SHA512 457adf9733fd0c914643dd5bad43069c983da43b06932a78626ef68faa37e26ee4716003813f03fdc86031e00b08c78660a2b54bf5eebf2b4a98ba2ba1591960
+EBUILD wapiti-9999.ebuild 1358 BLAKE2B b7d0920f05fb6a45ad568fc6a846080927a180a64b1e59e984ae129a28f1dfb0351953aee24ff6ed290fa8273c3af58dbf2b5f183067476db6abe12faf339e7a SHA512 0a82eb56c829168b37e901085c465be634343a98c227076806170b8e21b565ad4fe5c1ecacac3efe613ab7eaa20149cdde45f4fd30ca29e1b25bd430a5d7097f
MISC metadata.xml 865 BLAKE2B e8781a338561470a25c292df4d1daf6e44321f78c9209b5606bc2fc1746853750b591b670ebd2567423926c4b65d85580e0d752c3dfd0b833b8010f4f4cb5f48 SHA512 f67382517b25273f45510a2d84128c139b9ac989584290c1ff84e22c16ba79d5a950071434ab54818a09c127db6c0ab1f3c15bb1e1171c9618b7f8c3744e9876
diff --git a/net-analyzer/wapiti/wapiti-3.1.2.ebuild b/net-analyzer/wapiti/wapiti-3.1.2.ebuild
new file mode 100644
index 000000000000..8d4a9ed067d8
--- /dev/null
+++ b/net-analyzer/wapiti/wapiti-3.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='xml'
+
+inherit distutils-r1
+
+MY_P=${PN}3-${PV}
+DESCRIPTION="Web-application vulnerability scanner"
+HOMEPAGE="http://wapiti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Requires httpx-ntlm (to package)
+#IUSE="ntlm"
+
+# httpx requires brotli and socks, so depending on
+# dev-python/socksio and dev-python/brotlicffi
+RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/tld[${PYTHON_USEDEP}]
+ dev-python/yaswfp[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+# Tests also require unpackaged respx
+BDEPEND+=" test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+# Many tests require execution of local test php server
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed -e 's/"pytest-runner"//' \
+ -e "/DOC_DIR =/s/wapiti/${PF}/" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/net-analyzer/wapiti/wapiti-9999.ebuild b/net-analyzer/wapiti/wapiti-9999.ebuild
index 95c1263aa07a..e9d25d0eedfd 100644
--- a/net-analyzer/wapiti/wapiti-9999.ebuild
+++ b/net-analyzer/wapiti/wapiti-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE='xml'
inherit distutils-r1 git-r3
@@ -15,25 +15,33 @@ EGIT_REPO_URI="https://git.code.sf.net/p/wapiti/git wapiti-git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="kerberos ntlm"
+# Requires httpx-ntlm (to package)
+#IUSE="ntlm"
+# httpx requires brotli and socks, so depending on
+# dev-python/socksio and dev-python/brotlicffi
RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
>=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
dev-python/tld[${PYTHON_USEDEP}]
- dev-python/yaswfp[${PYTHON_USEDEP}]
- kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
- ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+ dev-python/yaswfp[${PYTHON_USEDEP}]"
distutils_enable_tests --install pytest
-BDEPEND+=" test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+# Tests also require unpackaged respx
+BDEPEND+=" test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
# Many tests require execution of local test php server
RESTRICT="test"
python_prepare_all() {
sed -e 's/"pytest-runner"//' \
- -e "/find_packages/s/()/(exclude=['tests*'])/" \
-e "/DOC_DIR =/s/wapiti/${PF}/" \
-i setup.py || die
distutils-r1_python_prepare_all